Subject: Re: Please share your views in our first annual IETF community survey

From: tom petch <[email-masked]>
Date: Fri, 7 May 2021 09:21:13 +0100

On 07/05/2021 01:18, IETF Executive Director wrote:
> Hi
>
> I am writing to you from the IETF to ask you to participate in our first annual IETF community survey.  This survey will help us better understand our community and its makeup, get your views on how well the IETF works for you and your perceptions of the IETF, and give us insight into how we compare to similar organisations.  Even if you no longer participate in the IETF or have never actively participated, we still want to hear from you.

I am slightly surprised not to see something from the IETF Chair about 
this, such as who commissioned the survey and why.  I note that one of 
the questions is about how well the IETF is managed and the lack of 
anything from IETF Chair, IESG (IAB?) etc beforehand colours my response 
to that question.  I would have expected advance warning from some such.

Tom Petch

> Please help us by filling out this survey, it should only take about six minutes of your time:
>
> 	https://ietf.iad1.qualtrics.com/jfe/form/SV_b9ibDun9807ZT8O
>
> This survey is completely anonymous and the only data we collect are the answers that you provide, nothing else.
>
>
> You have received this email because your email address is subscribed to at least one IETF mailing list.  You may unsubscribe from all future emails regarding this survey here: https://www.ietf.org/mailman/listinfo/ietf-surveys
>
>
> To find out more about this survey, please see this blog post:
>
> 	https://www.ietf.org/blog/first-annual-ietf-community-survey/
>
>
> Thanks in advance
> Jay
>

---

From: "Andrew G. Malis" <[email-masked]>
Date: Fri, 7 May 2021 07:14:31 -0400

Tom,

Jay sent a separate introductory email to ietf-announce, perhaps you missed
that.

Cheers,
Andy

On Fri, May 7, 2021 at 4:24 AM tom petch <[email-masked]> wrote:

> > I am writing to you from the IETF to ask you to participate in our first
> annual IETF community survey.  This survey will help us better understand
> our community and its makeup, get your views on how well the IETF works for
> you and your perceptions of the IETF, and give us insight into how we
> compare to similar organisations.  Even if you no longer participate in the
> IETF or have never actively participated, we still want to hear from you.
>
>
> > You have received this email because your email address is subscribed to
> at least one IETF mailing list.  You may unsubscribe from all future emails
> regarding this survey here:
> https://www.ietf.org/mailman/listinfo/ietf-surveys
> >
> >

---

From: Jared Mauch <[email-masked]>
Date: Fri, 7 May 2021 07:21:22 -0400

If you have concerns feel free to email them to the IAB or I'd be happy to schedule time with you with IAB hat on to discuss them. 

I will point out it was in the IAB minutes here:

https://www.iab.org/documents/minutes/minutes-2021/iab-minutes-2021-04-21/

Sent from my TI-99/4a

> On May 7, 2021, at 4:24 AM, tom petch <[email-masked]> wrote:
> 
> 
> 
> I am slightly surprised not to see something from the IETF Chair about this, such as who commissioned the survey and why.  I note that one of the questions is about how well the IETF is managed and the lack of anything from IETF Chair, IESG (IAB?) etc beforehand colours my response to that question.  I would have expected advance warning from some such.
> 
> Tom Petch
> 
> 
>

---

From: "Livingood, Jason" <[email-masked]>
Date: Fri, 7 May 2021 13:14:43 +0000

This survey has been in the works since the Executive Director was hired, with the objective to strive to make more data-driven decisions & better understand the needs of the community. Jay has posted an email separately, which refers to a blog post at https://www.ietf.org/blog/first-annual-ietf-community-survey/. This was also most recently in the IETF LLC’s minutes at https://www.ietf.org/media/documents/IETF_LLC_2021_Strategic_Planning_Retreat_Minutes.pdf.

Jason

From: ietf <[email-masked]> on behalf of Jared Mauch <[email-masked]>
Date: Friday, May 7, 2021 at 7:26 AM
To: tom petch <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, IETF Executive Director <[email-masked]>
Subject: Re: Please share your views in our first annual IETF community survey

https://www.iab.org/documents/minutes/minutes-2021/iab-minutes-2021-04-21/<https://urldefense.com/v3/__https:/www.iab.org/documents/minutes/minutes-2021/iab-minutes-2021-04-21/__;!!CQl3mcHX2A!Sh-BNxQ7CPkEqa4F-dXD4dy0rjGWlaS6oci8Ga49_Da935P723dvt8gCFDfLJPmCRZMdtQ$>
Sent from my TI-99/4a

Hi

Tom Petch

   https://ietf.iad1.qualtrics.com/jfe/form/SV_b9ibDun9807ZT8O<https://urldefense.com/v3/__https:/ietf.iad1.qualtrics.com/jfe/form/SV_b9ibDun9807ZT8O__;!!CQl3mcHX2A!Sh-BNxQ7CPkEqa4F-dXD4dy0rjGWlaS6oci8Ga49_Da935P723dvt8gCFDfLJPkV60pJIA$>

You have received this email because your email address is subscribed to at least one IETF mailing list.  You may unsubscribe from all future emails regarding this survey here: https://www.ietf.org/mailman/listinfo/ietf-surveys<https://urldefense.com/v3/__https:/www.ietf.org/mailman/listinfo/ietf-surveys__;!!CQl3mcHX2A!Sh-BNxQ7CPkEqa4F-dXD4dy0rjGWlaS6oci8Ga49_Da935P723dvt8gCFDfLJPkGNcaY4Q$>

   https://www.ietf.org/blog/first-annual-ietf-community-survey/<https://urldefense.com/v3/__https:/www.ietf.org/blog/first-annual-ietf-community-survey/__;!!CQl3mcHX2A!Sh-BNxQ7CPkEqa4F-dXD4dy0rjGWlaS6oci8Ga49_Da935P723dvt8gCFDfLJPn6elN_SA$>

Thanks in advance
Jay

---

From: tom petch <[email-masked]>
Date: Fri, 7 May 2021 15:38:52 +0100

> https://www.iab.org/documents/minutes/minutes-2021/iab-minutes-2021-04-21/<https://urldefense.com/v3/__https:/www.iab.org/documents/minutes/minutes-2021/iab-minutes-2021-04-21/__;!!CQl3mcHX2A!Sh-BN…

Thank you for the pointers.  I am on the ietf-announce list but the 
e-mail from Jay to that list came to me after I had received the one 
about the survey on a WG list and had completed the survey.  (In 
passing, I use more than one address to subscribe to WG lists but have 
ignored the later invitations to participate in the survey - I assume 
that it was humans that were expected to respond and not e-mail addresses!)

IAB minutes are not something I look at, unless, e.g., there is a post 
to an ietf list with a link to something there.   Likewise, LLC minutes 
I only look at when there is a pointer to them.  I have been around 
since before the Executive Director was hired but, again, did not notice 
any reference to the survey.

Not, I think, worth taking up IAB time with.

Tom Petch

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Sun, 9 May 2021 12:17:26 -0500

Hi, Jared,

On Fri, May 7, 2021 at 6:26 AM Jared Mauch <[email-masked]> wrote:

> If you have concerns feel free to email them to the IAB or I'd be happy to
> schedule time with you with IAB hat on to discuss them.
>

I'm not sure if this was the set of meeting minutes you meant to point to
(I'm not seeing a helpful mention of "survey", just by searching for the
character string), but more broadly, I understand this survey, coming from
the IAB, to be squarely within the IAB's chartered responsibilities from
https://www.rfc-editor.org/rfc/rfc2850.html#section-2:

   (c) Standards Process Oversight and Appeal
*   The IAB provides oversight of the process used to create Internet
   Standards [BCP 9].*

   The IAB serves as an appeal board for complaints of improper
   execution of the standards process, with powers defined in [BCP 9].

I'd have to say, as a former IAB member, I'm kind of pleased to see that
the IAB was taking this action (this chartered responsibility was mostly
about appeals in 2010-2013, when I was serving), but I understand why Tom
might have been startled! I tend to respond to IETF surveys from Jay
automatically, and wasn't thinking that it might be part of the IAB's
oversight responsibility (the usual post-IETF surveys were usually
discussed by the IESG when I was serving there).

So, to the IAB, good job, and we're all (more) awake now!

I just filled out the survey, and it seemed reasonable. I do wish there had
been one or more places to provide explanations, which I remember is
usually true for the post-IETF surveys. I assume something like this survey
will be sent out again, if it turns out to be helpful, so that can be added
next time.

> Sent from my TI-99/4a

This is the best signature line I've seen in email for a while ... I always
enjoy Warren Kumari's, but we don't chat as much as we used to chat. 😀

Best,

Spencer

---

From: tom petch <[email-masked]>
Date: Mon, 10 May 2021 16:56:25 +0100

> So, to the IAB, good job, and we're all (more) awake now!

Jared

Until I read the preceding paragraph, I had no idea that the IAB had 
anything to do with the survey.  To me it was an action by the admin 
part of the organisation getting information for its own benefit and 
treading on the toes of such as the IETF Chair and the IESG who were 
being bypassed.

So no, bad job IAB, you failed to communicate adequately IMHO and left 
me with the wrong impression, and a bad one, of the admin part of the 
IETF.  Checking the blog, I do see that the IAB gets a mention and that 
the survey is on behalf of the IESG but that passed me by, unlike the 
references to the admin side of the IETF which I picked up on several 
times in several places.  I cannot recall any mention of the IAB or IESG 
in the survey itself and while I was performing the survey, I was 
looking for why was this being done and who has initiated this process 
and sensing that that was colouring my answers.

The IAB says so little that an announcement from the IAB carries a lot 
of weight; I think that one would have been warranted in this case.

Tom Petch