Subject: Re: IPv4 depletion makes CNN

From: [email-masked] (Noel Chiappa)
Date: Thu, 27 May 2010 09:59:56 -0400 (EDT)

> From: Ole Jacobsen <[email-masked]>

    > this story was written by someone with a clue.

Not really. A high marketing FUD / technical content ratio.

	Noel

---

From: Steve Crocker <[email-masked]>
Date: Thu, 27 May 2010 15:11:21 +0100

I agree.  That said, it's a bit challenging to get the right message across.  IPv4 hosts will continue to increase for quite a while, but address space will increasingly hard to obtain.  The large growth will come in the IPv6 space.  IPv6 networks and products are maturing but are still not yet on a par with IPv6 networks and products.  Anyone want to hazard a guess when  they will be fully competitive?  And then there's the problem of interoperability...

I think the CNN story carries the wrong message, both in the specifics -- IPv4 won't stop growing anytime soon -- and in the implied conclusion that the Internet will stop growing in 18 months.

Steve  

Sent from my iPad

On May 27, 2010, at 2:59 PM, [email-masked] (Noel Chiappa) wrote:

> _______________________________________________
> Ietf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf

---

From: Rumbidzayi Gadhula <[email-masked]>
Date: Thu, 27 May 2010 16:14:24 +0200

On 27 May 2010 16:11, Steve Crocker <[email-masked]> wrote:

> I agree.  That said, it's a bit challenging to get the right message
> across.  IPv4 hosts will continue to increase for quite a while, but address
> space will increasingly hard to obtain.  The large growth will come in the
> IPv6 space.  IPv6 networks and products are maturing but are still not yet
> on a par with IPv6 networks and products.  Anyone want to hazard a guess
> when  they will be fully competitive?  And then there's the problem of
> interoperability...
>
> typo or am i lost?

> I think the CNN story carries the wrong message, both in the specifics --
> IPv4 won't stop growing anytime soon -- and in the implied conclusion that
> the Internet will stop growing in 18 months.
>
> Steve
>
> Sent from my iPad
>

---

From: Steve Crocker <[email-masked]>
Date: Thu, 27 May 2010 15:26:35 +0100

IPv6 networks and products are maturing but are still not on a par with *IPv4* networks and services.

Apologies.

Steve 

Sent from my iPad

---

From: Ole Jacobsen <[email-masked]>
Date: Thu, 27 May 2010 07:44:50 -0700 (PDT)

I guess my point was more that this article actually quotes a *real* 
expert rather than someone we've never heard of --- a more common
practice for the press. Whether or not you agree with Daniel, he does
at least have extensive experience in these matters.

Ole

Ole J. Jacobsen
Editor and Publisher,  The Internet Protocol Journal
Cisco Systems
Tel: +1 408-527-8972   Mobile: +1 415-370-4628
E-mail: [email-masked]  URL: http://www.cisco.com/ipj

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 28 May 2010 04:14:00 +1200

> at least have extensive experience in these matters.

The major problem with the story is that it confounds IANA runout
(objectively predicted for 2011) with when ISPs run out of IPv4 space
(which is not so easy to predict, but 2015 is a popular estimate). The
rest is pretty good for a story in the non-technical media, IMHO.

You can find Daniel's recent talk at http://www.ipv6.ie/summit2010/.

   Brian

---

From: David Conrad <[email-masked]>
Date: Thu, 27 May 2010 09:51:03 -0700

On May 27, 2010, at 9:14 AM, Brian E Carpenter wrote:

> (which is not so easy to predict, but 2015 is a popular estimate).

Well, no.  While that is a problem, I suspect the real issue is:

'Within 18 months it is estimated that the number of new devices able to connect to the world wide web will plummet as we run out of "IP addresses"'

and this quote:

"The internet as we know it will no longer be able to grow,"

That's just factually incorrect and sensationalistic hype. Whether it is counter-productive depends on whether people simply dismiss it out of hand as "yeah, yeah, just like the world will end at Y2K."

IPv4 free pool runout simply means connecting to the Internet is going to get more expensive.

Regards,
-drc

---

From: Martin Rex <[email-masked]>
Date: Thu, 27 May 2010 19:08:27 +0200 (MEST)

> "The internet as we know it will no longer be able to grow,"

This means "no more 'new kids' on the block", they will
have to "sublicense" from existing "kids".

> is going to get more expensive.

That is one of the effects of free markets.
If a resource depletes, prices go up.

But mainly I expect that overall usage and cascading depth
of NATs is going to increase and it may result in DSL offerings
where you no longer get a real IP, at which point you no longer
have to option to host at least one service under a well-known
port (forwarded from the NAT on your DSL router).

-Martin

PS: I like this one http://www.explainxkcd.com/2010/05/19/campfire/

---

From: <[email-masked]>
Date: Thu, 27 May 2010 16:02:40 -0400

2015 seems awfully optimistic. I wouldn't want to be the poor soul responsible for their ISP network who built a transition plan based on a 2015 depletion and then realized I was wrong by a few years. 

Jason

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Brian E Carpenter
Sent: Thursday, May 27, 2010 12:14 PM
To: Ole Jacobsen
Cc: Noel Chiappa; [email-masked]
Subject: Re: IPv4 depletion makes CNN

   Brian

---

From: Ofer Inbar <[email-masked]>
Date: Thu, 27 May 2010 16:52:20 -0400

> rest is pretty good for a story in the non-technical media, IMHO.

More generally - and this is not a problem I have with the CNN
article, just in general with IPv4 depletion conversations -
I've been hearing about imminent IPv4 address depletion for 15
years or maybe 20 by now.

 - We were going to run out of Class C's, but then we converted to
   CIDR so were no longer bound by the rigid old classes and got to
   allocate addresses much more efficiently, buying many years.

 - We were going to run out of blocks to allocate even with CIDR, but
   lots of institutions adopted NAT so that places that would've
   needed large blocks started being able to make do with /25s or
   similar sizes for their few public IPs.

 - We were going to run low on public IPs despite NAT due to the rapid
   growth of web servers, but we got name based virtual hosting which
   let lots of web servers share the same IP.

... what's next?
  Carrier-based NAT?
  Virtual-hosting encrypted http?
  Actually using IPv6 en masse?
  Something else?

It seems like the limits we're running up against aren't really a
matter of growing demand vs. dwinding supply; for more than that,
the limits are based on our cleverness in coming up with new ideas
to conserve or use our IPv4 address supply more efficiently.  We've
had several large shifts of this sort and each time we buy years of
time.  Each such shift also has a cost, though it varies - name based
virtual web hosting has relatively little cost and is a big win;
CIDR was a hard transition but once done it's all win and no lose;
Heavy use of NAT causes lots of problems and will continue to. But
when it comes to "we're 1-2 years away and need to buy more time!"
we always seem to end up with another one of these clever new ideas
instead.  Will there come a time when the least-cost clever "new"
idea is an actual transition to IPv6?  Probably, but I don't know
when and I don't know that it makes sense to assume that is the next
one, or to estimate which year it'll be.

> You can find Daniel's recent talk at http://www.ipv6.ie/summit2010/.

I can find a link to his talk on that site, but each time I click on
that link I get a quickly-broken TCP connection.  Overloaded, perhaps?
  -- Cos

---

From: Mark Andrews <[email-masked]>
Date: Fri, 28 May 2010 08:37:35 +1000

>    allocate addresses much more efficiently, buying many years.

And it did.
 
>    similar sizes for their few public IPs.

And it did.  Also small institutions known as homes. :-)
 
>    let lots of web servers share the same IP.

Which helps with one specific application.

>   Virtual-hosting encrypted http?

Which helps a little with one specific application.

> to conserve or use our IPv4 address supply more efficiently.

Once you can't get a address for yourself, when you need it, you
have reached the limits of the net and start seriously impacting
on what you can do.  We are reaching that point.

> We've
> time.
> Each such shift also has a cost, though it varies - name based

And https is a really small percentage of web traffic.  It really
won't recover a lot of addresses overall.

> CIDR was a hard transition but once done it's all win and no lose;

But no-one has another CIDR like fix to deploy.

> Heavy use of NAT causes lots of problems and will continue to.

And CGN causes even more problem.

> But when it comes to "we're 1-2 years away and need to buy more time!"

The point of the article was to make more people aware of IPv6 and to
urge them actually start planning to move to IPv6.

I've got IPv6 at home today (tunneled).  If my ISP moves to CGN
without also enabling native IPv6 I will loose my IPv6.  That would
be going backwards.

For the client side there is no downside in enabling IPv6 today.

Mark

-- 
Mark Andrews, ISC
1 Seymour St., Dundas Valley, NSW 2117, Australia
PHONE: +61 2 9871 4742                 INTERNET: [email-masked]

---

From: Patrik Fältström <[email-masked]>
Date: Fri, 28 May 2010 06:30:18 +0200

As native IPv6 connections are compared more and more with IPv4 NAT:ed connections, I think this will go quicker than what people think. Note that most of the difference between the protocols are features and operational experiences the ISPs have. For the end user...how much difference is there really in how Google or Facebook works?

But you asked for a year Steve, and I think we are now in IPv6 where we where with IPv4 around 1994. But those 16 years will take 8 years to catch up.

The end user though, will not notice when IPv6 is in use. Not even now I claim... (and turn on my flame protector).

1.4% of the unique IP addresses each 24h to my mail server (that is not large, handles maybe 30k email messages a day) are IPv6 today, and that is when I merge incoming and outgoing SMTP, i.e. both clients that are configured to use the name of the server explicitly (for outgoing mail), and those that look up MX and then A/AAAA (incoming).

   Patrik

---

From: Patrik Fältström <[email-masked]>
Date: Fri, 28 May 2010 07:04:30 +0200

I also think 2015 is very optimistic for some players. Specifically cellphone providers that provide data access over for example 3G or 4G. The growth is so fast that the block allocations from the RIRs are hard to compute.

I helped one at the last RIPE meeting in Prague, and then will now get a /13 that will help them through calendar year 2010. They will definitely not be able to get today the addresses they need until 2015. And they definitely do not have it.

And that is in Sweden, only 9 million people.

   Patrik

---

From: Masataka Ohta <[email-masked]>
Date: Fri, 28 May 2010 16:01:27 +0900

>    Actually using IPv6 en masse?

Something else of port restricted IP, with which an IPv4 address
can be shared by 100 or 1,000 hosts while keeping the end to end
transparency.

> Heavy use of NAT causes lots of problems and will continue to.

End to end NAT is a form of port restricted IP without any
problem of legacy NAT.

						Masataka Ohta

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 28 May 2010 20:29:13 +1200

On 2010-05-28 04:51, David Conrad wrote:
...
> 'Within 18 months it is estimated that the number of new devices able to connect to the world wide web will plummet as we run out of "IP addresses"'

I strongly suspect that Daniel said "connect directly", which is certainly
true when an ISP runs out of global IPv4 addresses.

> That's just factually incorrect 
Today, most users are *not* behind ISP NAT or some other form
of global address sharing. A double-NATted Internet is very different
from a single-NATted Internet as we know it today.

and sensationalistic hype. Whether it is counter-productive depends on whether people simply dismiss it out of hand as "yeah,
yeah, just like the world will end at Y2K."
> IPv4 free pool runout simply means connecting to the Internet is going to get more expensive.

No, it means it is going to require double NAT unless providers deploy IPv6.
That is the message that needs to be got across.

   Brian

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 28 May 2010 20:22:44 +1200

Patrik,

Of course, the exact depletion date experienced by an ISP will vary
very widely. 2015 is the date *most frequently* cited by the ISPs
reported on in draft-ietf-v6ops-isp-scenarios.

Regards
   Brian Carpenter

---

From: "t.petch" <[email-masked]>
Date: Fri, 28 May 2010 13:48:07 +0200

----- Original Message ----- 
From: "Mark Andrews" <[email-masked]>
To: "Ofer Inbar" <[email-masked]>
Cc: <[email-masked]>
Sent: Friday, May 28, 2010 12:37 AM

> For the client side there is no downside in enabling IPv6 today.

Recently I set up a new account with the incumbent ISP and asked their sales
department (several times) about IPv6 support.  Their reply was odd,
and I eventually found that the translation was
'you have mentioned something we have had no training in so this is
our stock response.'

This persisted even when I got into second and third level support, 
so there are big ISP out there who have not yet heard of IPv6.  We have
a long way to go and not much time to go it in.

Tom Petch

---

From: Jari Arkko <[email-masked]>
Date: Fri, 28 May 2010 16:42:31 +0300

The size and timing of the address resource problem depends on your 
viewpoint, of course. Your existing address resources, your growth rate, 
your subscriber base, the extent to which more NATs remove your problem 
all vary.

But I would argue this does not really matter so much. I think we have 
already run out of the addresses, with consequent implications to 
applications, end-to-end nature of the Internet, and business planning. 
Just as an example, one mobile operator who participates in the IETF 
IPv6 and NAT work has half a billion subscribers. Think their planning 
revolves around asking the RIRs for an address to each customer, as they 
are rapidly transitioning from circuit switched voice to voip and 
browser/email/google/facebook-on-everyone's-device model? Arguing about 
exact dates or the level of catastrophe seems like rearranging the deck 
chairs on Titanic. Things will be bad. We should focus on changing the 
direction and making things better.

In any case, I think we are missing the point if we try to argue about 
the accuracy of mainstream media news articles. Of course they are 
simplified and twisted to a ridiculous level. Just check any other 
article where you knew what really was going on.

But I think the important point is that a change is needed. For that to 
happen, we need to have both an alternative and global awareness of the 
problem. We will need also mainstream news articles in the latter.

Jari

---

From: Arnt Gulbrandsen <[email-masked]>
Date: Fri, 28 May 2010 15:50:03 +0200

On 05/28/2010 03:42 PM, Jari Arkko wrote:
> We will need also mainstream news articles in the latter.

Expect that around the end of July, intoning «In one year, the Internet 
Assigned Numbers Authority is expected…»

Arnt

---

From: David Conrad <[email-masked]>
Date: Fri, 28 May 2010 08:01:00 -0700

On May 28, 2010, at 1:29 AM, Brian E Carpenter wrote:
> Today, most users are *not* behind ISP NAT or some other form of global address sharing.

An interesting assertion.  I'd agree on the ISP NAT part.  Not sure about the "other form of global address sharing" part, since single NAT is address sharing.  Do you have any data?

> No, it means it is going to require double NAT unless providers deploy IPv6.

I've been told on numerous occasions that multi-layer NAT will significantly increase opex.

> That is the message that needs to be got across.

I suspect your message will result in a response of "Double whasis? I can still get my pr0n, right?".  I'd imagine a message that says "you're going to end up paying more for your pr0n" will get more people's attention.

Regards,
-drc

---

From: "Spencer Dawkins" <[email-masked]>
Date: Fri, 28 May 2010 10:40:59 -0500

The world will continue to rotate just fine, without me prognosticating 
about the universal deployment of IPv6, but I did want to agree with Jari on 
one point:

> Just as an example, one mobile operator who participates in the IETF IPv6 
> and NAT work has half a billion subscribers. Think their planning revolves 
> around asking the RIRs for an address to each customer, as they are 
> rapidly transitioning from circuit switched voice to voip and 

I agree with Jari - doesn't matter. I suspect that there is enough variation 
in IP address inventories, subscriber growth, and a variety of other 
factors, that trying to figure out when "we" will "run out" of IPv4 prefixes 
isn't helpful - the range of values for "we" and "run out" add too much 
variation to the discussion for it to converge.

The good news is that (much like the Titanic), we don't all run into an 
iceberg and sink at the same time, so we'll probably learn a lot from every 
sinking, and every sinking will probably motivate at least some people who 
are still afloat.

The bad news is that we all need to keep an eye out for icebergs, and 90 
percent of icebergs are underwater :D

Thanks,

Spencer

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 29 May 2010 03:57:25 +1200

> An interesting assertion.  I'd agree on the ISP NAT part.  Not sure about the "other form of global address sharing" part, since single NAT is address sharing.  Do you have any data?

Sorry, I should have written "subscribers" instead of "users". Most subscribers
get global addresses on the outside of their domestic gateway, but of course
that gateway is unfortunately a NAT in most cases.

> I've been told on numerous occasions that multi-layer NAT will significantly increase opex.

Yes. It will also significantly increase breakage at application level.
I understand there is plenty of running code proof of this, for example
in India.

> I suspect your message will result in a response of "Double whasis? I can still get my pr0n, right?".  I'd imagine a message that says "you're going to end up paying more for your pr0n" will get mo…

In fact I think the message now should be to content *providers*, because they
will bear the costs unless they pressure their ISPs into doing the right thing.

   Brian

---

From: Arnt Gulbrandsen <[email-masked]>
Date: Fri, 28 May 2010 17:57:30 +0200

> An interesting assertion.  I'd agree on the ISP NAT part.  Not sure about the "other form of global address sharing" part, since single NAT is address sharing.  Do you have any data?

Consider bittorrent. Bittorrent clients generally can run behind NAT, 
but in that case they have to be on the same ethernet as the NATbox, so 
it's a safe bet that the bittorrent USER has a real address. Am I 
stepping out on a limb if I state that most users can run bittorrent?

Arnt

---

From: David Conrad <[email-masked]>
Date: Fri, 28 May 2010 09:39:27 -0700

On May 28, 2010, at 8:57 AM, Arnt Gulbrandsen wrote:
> Consider bittorrent. Bittorrent clients generally can run behind NAT, but in that case they have to be on the same ethernet as the NATbox, so it's a safe bet that the bittorrent USER has a real address. Am I stepping out on a limb if I state that most users can run bittorrent?

No idea. No clue how popular bittorrent is. I was under the impression that the vast majority of folks on residential-level connections were sitting behind a NAT box. Perhaps my impression is wrong?

Regards,
-drc

---

From: Sabahattin Gucukoglu <[email-masked]>
Date: Sun, 30 May 2010 15:44:19 +0100

> No idea. No clue how popular bittorrent is. I was under the impression that the vast majority of folks on residential-level connections were sitting behind a NAT box. Perhaps my impression is wrong?

BitTorrent is popular, yes.  People at home *are* behind NAT boxes, with all the usual pain that implies *.  It's just that BitTorrent, being a straightforward TCP protocol with no embedded payload addresses **, can operate behind NATs, and those NATs can be configured either manually or automatically by users or their client software ***.  If the NAT should move to the ISP, it seems possible that this is no longer true.

Cheers,
Sabahattin

* Subjective, I know, but people for whom NAT is not a problem are not full participants of the Internet, and do not use it to full potential.  Most of them think the web is the Internet.  I regret losing my public addresses to the cloud.
** Actually, BitTorrent does allow clients to tell trackers their addresses, for example to get around proxies; in such cases dynamic addresses are a problem, as are cases where tracker and client live on the same machine, as happens when publishing.  This doesn't affect most users though, because trackers default to taking the public IP address of the connecting client as the peer address given to other clients.
*** Of course, there's still a learning curve, in which users will sooner or later become acquainted with the mechanics of port forwarding and all that; it rarely "Just works".  I'm reluctant to admit everybody capable of comprehending this stuff at first blush; certainly there are many peers who are firewalled and thus get reduced speeds.

---

From: Arnt Gulbrandsen <[email-masked]>
Date: Sun, 30 May 2010 17:02:47 +0200

> BitTorrent is popular, yes.  People at home *are* behind NAT boxes, with all the usual pain that implies *.  It's just that BitTorrent, being a straightforward TCP protocol with no embedded payload…

Not quite.

1. Bittorrent clients connect to each other via TCP. Each connection is 
incoming at one end. Torrent clients mostly use UPNP to accept incoming 
connections.

2. UPNP is an ethernet-level protocol (it uses UDP/IP broadcasts), so it 
works only if the USER is on the public internet. Hence, NAT within the 
user's network is now very different from NAT within the ISP's network.

That's why I said the wide popularity of bittorrent shows that USERS are 
on the public internet.

Arnt

---

From: Sabahattin Gucukoglu <[email-masked]>
Date: Sun, 30 May 2010 16:30:24 +0100

On 30 May 2010, at 16:02, Arnt Gulbrandsen wrote:
> 1. Bittorrent clients connect to each other via TCP. Each connection is incoming at one end. Torrent clients mostly use UPNP to accept incoming connections.
> 
> 2. UPNP is an ethernet-level protocol (it uses UDP/IP broadcasts), so it works only if the USER is on the public internet. Hence, NAT within the user's network is now very different from NAT within the ISP's network.
> 
> That's why I said the wide popularity of bittorrent shows that USERS are on the public internet.

Right, yes, I didn't see it from that standpoint.  However UPnP can of course be substituted by NAT-PMP/PCP or something else that doesn't have the same discovery problem, and ISP-level NATs will no longer be a "Problem" for clients needing incoming connections even though they can no longer be said to be "Public".  Of course we're assuming that clients are in direct contact with their gateway here, I'm not sure how true that is, there may need to be added proxying to replicate requests otherwise.  It certainly isn't impossible to do.

Cheers,
Sabahattin

---

From: Masataka Ohta <[email-masked]>
Date: Mon, 31 May 2010 15:34:55 +0900

Sabahattin Gucukoglu wrote:

> Right, yes, I didn't see it from that standpoint.  However UPnP
> can of course be substituted by NAT-PMP/PCP or something else
> that doesn't have the same discovery problem, and ISP-level NATs
> will no longer be a "Problem" for clients needing incoming
> connections even though they can no longer be said to be "Public".

Right.

For example, an ISP, today, can tell its client public IP addresses
assigned to the client. Then, the client can configure them by hand.
There is no discovery problem.

Just like that, an ISP can tell its client a public IP address and
public port numbers of the address assigned to the client. Then, the
client can configure them by hand.

Or, it is trivially easy to add DHCP/PP option so that ISPs can
automatically tell their clients the address/port information for
each client.

If port allocation is more dynamic involving gateway-client
communication, there should be a DHCP/PPP option to tell client
the IP address (and port) of a gateway for the gateway-client
communication.

> Of course we're assuming that clients are in direct contact with
> their gateway here, I'm not sure how true that is, there may need
> to be added proxying to replicate requests otherwise. It certainly
> isn't impossible to do.

Sure. What is necessary is clear documentation of DHCP/PPP
extensions and gateway-client protocols.

						Masataka Ohta

---

From: Arnt Gulbrandsen <[email-masked]>
Date: Mon, 31 May 2010 13:59:57 +0200

On 05/31/2010 03:49 AM, Phillip Hallam-Baker wrote:
> So we need to extend the UPNP protocol so that when the local NAT box
> receives a request to open up an external port, it relays the request
> to the carrier NAT.

So what are you waiting for? Go ahead, read http://upnp.org, find the 
relevant WG, propose the extension, talk to implementers, you know the 
routine as well as I do.

Arnt