Subject: 128 bit IP addresses

From: "Bill Cunningham" <[email-masked]>
Date: Tue, 1 Jan 2002 23:23:17 -0500

I've been hearing now for 2 years about the 128 bit IP addressing system and how important it is.  Why are we still using 32 bit IP addresses if we need the 128 bit ones?
And if we do finally go this route, will the 128 bit IP addresses simply absorb the 32 bit addresses?

---

From: Miguel Angel Rodriguez Jodar <[email-masked]>
Date: Wed, 2 Jan 2002 11:58:05 +0100

Hola Bill,

El día Wednesday, January 02, 2002, 5:23:17 AM, escribiste:

BC> I've been hearing now for 2 years about the 128 bit IP addressing system and how important it is.  Why are we still using 32 bit IP addresses if we need the 128 bit ones?
BC> And if we do finally go this route, will the 128 bit IP addresses simply absorb the 32 bit addresses?

Well... as with multicast, not every router allows IPv6 at this time.
What is being done now is to form the so-called 6-Bone (the same idea as
m-Bone) to join IPv6 capable networks while the necesary technology is
deployed to all routers.

-- 
Miguel Angel Rodriguez Jodar | http://icaro.fie.us.es
Arquitectura y Tecnología de Computadores
Universidad de Sevilla

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 02 Jan 2002 14:45:40 +0100

> Bill Cunningham wrote:
> 
> I've been hearing now for 2 years about the 128 bit IP addressing system and how important it is.  Why are we still using 32
> bit IP addresses if we need the 128 bit ones?

It's hard to know where to start. Probably http://www.ipv6forum.com is the best place;
look for the various presentations or white papers. Or to toot my own trumpet,
see http://www.isoc.org/briefings/001/ . Also see http://www.isoc.org/briefings/004/index.html
on deployment issues.

We are still using IPv4 with 32 bit addresses because upgrading to a new version of
IP is a very hard thing to do and is bound to take years; some say it's impossible.

IPv6 has its own addressing scheme. There are some transition mechanisms allowing
IPv4 addresses to be used within IPv6 addresses, but that is only part of the story.
In general, sites will simply get a new (bigger) range of addresses.

   Brian

---

From: Margaret Wasserman <[email-masked]>
Date: Wed, 02 Jan 2002 08:56:21 -0500

Hi Bill,

 >At 11:23 PM 1/1/02 , Bill Cunningham wrote:
 >I've been hearing now for 2 years about the 128 bit IP addressing system
 >and how important it is.  Why are we still using 32 bit IP addresses if
 >we need the 128 bit ones?  And if we do finally go this route, will the
 >128 bit IP addresses simply absorb the 32 bit addresses?

128-bit IP Addresses are one feature of IP version6 (or IPv6).
Most of us still use IP version 4 (or IPv4), with 32-bit addresses.
Most of the core IPv6 standards are at the Draft Standard level,
and we are in the early stages of commercial deployment.

To find out more about the current status of IPv6, you may want to look
in the following places:

	IETF IPv6 Working Group page (defining the standards for IPv6):

		http://www.ietf.org/html.charters/ipv6-charter.html

		and

		http://playground.sun.com/pub/ipng/html/ipng-main.html

	IETF Next Generation Transition Working Group page (defining
		mechanisms for transition from IPv4 to IPv6):

		http://www.ietf.org/html.charters/ngtrans-charter.html

	The IPv6 Forum web page:

		http://www.ipv6forum.org/

Enjoy,

Margaret