Subject: IPv10 is the solution.

From: Khaled Omar <[email-masked]>
Date: Tue, 1 Feb 2022 09:45:12 +0000

Hi all,

I read a lot of articles on the internet about IPv10, and i think there is full support from the internet community, engineers and researchers fully understand the solution, so it is weird that the IETF didn't officially announce something about IPv10 whether supporting the I-D or not.

I'm not writing today because i'm the author of IPv10 I-D, but i write because we are really in need to this solution and be implemented in today's networks.

I hope this time will not receive sarcastic response because the recent situation requires something serious or official from the IETF side.

Best regards,
Khaled Omar

---

From: Khaled Omar <[email-masked]>
Date: Tue, 1 Feb 2022 11:54:57 +0000

FYI.

Get Outlook for iOS<https://aka.ms/o0ukef>
________________________________
From: Khaled Omar <[email-masked]>
Sent: Tuesday, February 1, 2022 1:51:13 PM
To: Stewart Bryant <[email-masked]>
Cc: Stewart Bryant <[email-masked]>
Subject: Re: IPv10 is the solution.

https://inf.news/en/tech/f825c3ee3a61bcb355e15a475b765da0.html

https://www.tech-wd.com/wd/2017/09/09/%D8%A7%D9%84%D8%A5%D8%B5%D8%AF%D8%A7%D8%B1-%D8%A7%D9%84%D8%B9%D8%A7%D8%B4%D8%B1-%D9%85%D9%86-%D8%A8%D8%B1%D9%88%D8%AA%D9%88%D9%83%D9%88%D9%84-%D8%A7%D9%84%D8%A5%D9%86%D8%AA%D8%B1%D9%86%D8%AA-ipv10/amp/

https://www.phoronix.com/scan.php?page=news_item&px=IPv10-Draft-Specification

http://www.1040494.com/Z35K3oQXb/630917357421723648.html

https://www.exeley.com/international_journal_advanced_network_monitoring_controls/doi/10.21307/ijanmc-2019-075

Best regards,
Khaled Omar

Get Outlook for iOS<https://aka.ms/o0ukef>
________________________________
From: Stewart Bryant <[email-masked]>
Sent: Tuesday, February 1, 2022 1:43:09 PM
To: Khaled Omar <[email-masked]>
Cc: Stewart Bryant <[email-masked]>
Subject: Re: IPv10 is the solution.

If you want to have a conversation with people or to get people to read things you have to point them to the exact text that they need for a common view of the situation.

Stewart

On 1 Feb 2022, at 10:25, Khaled Omar <[email-masked]<mailto:[email-masked]>> wrote:

Hi Stewart,

Google “IPv10” or “IPv10 RFC” and you will find what i’m talking about in many languages.

Best regards,
Khaled Omar

Get Outlook for iOS<https://aka.ms/o0ukef>
________________________________
From: Stewart Bryant <[email-masked]<mailto:[email-masked]>>
Sent: Tuesday, February 1, 2022 12:20:29 PM
To: Khaled Omar <[email-masked]<mailto:[email-masked]>>
Cc: Stewart Bryant <[email-masked]<mailto:[email-masked]>>
Subject: Re: IPv10 is the solution.

On 1 Feb 2022, at 09:45, Khaled Omar <[email-masked]<mailto:[email-masked]>> wrote:

I read a lot of articles on the internet about IPv10

Please provide references.

- Stewart

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Tue, 1 Feb 2022 13:02:12 +0100

On Tue, Feb 01, 2022 at 11:54:57AM +0000,
 Khaled Omar <[email-masked]> wrote 

> https://www.exeley.com/international_journal_advanced_network_monitoring_controls/doi/10.21307/ijanmc-2019-075

Just for the people who don't know: there are many journals with the
look and feel of scientific journals, and overblown titles such as
"International journal of advanced things" that publish anything,
literally anything, just to have content (and sometimes the author has
to pay for it).

It is not specific to computer networks, there are a lot of them in
biology, for instance, allowing unscrupulous or desperate people to
inflate their list of publications <https://en.wikipedia.org/wiki/Publish_or_perish>

Don't fall in the trap: anyone can publish anything on the Internet
and these journals are contentless.

---

From: Khaled Omar <[email-masked]>
Date: Tue, 1 Feb 2022 12:09:56 +0000

I didn’t pay any of these journals, all what i received was only invitation to a university in China “Xian institute of technology” to teach IPv10 for students, but that was in January 2020 and was planned to be in March, 2020, so you can imagine, i didn’t go because of COVID-19, anyway, all these articles are by people whom i don’t know.

Best regards,
Khaled Omar

Get Outlook for iOS<https://aka.ms/o0ukef>
________________________________
From: ietf <[email-masked]> on behalf of Stephane Bortzmeyer <[email-masked]>
Sent: Tuesday, February 1, 2022 2:02:12 PM
To: [email-masked] <[email-masked]>
Subject: Re: Fwd: IPv10 is the solution.

---

From: Masataka Ohta <[email-masked]>
Date: Tue, 1 Feb 2022 21:23:34 +0900

Khaled Omar wrote:

> I read a lot of articles on the internet about IPv10,

I'm afraid it is a reinvention of "IPv4-compatible IPv6 address".

As IPv6 is hopeless partly because of its unnecessarily lengthy
addresses, I can't see any point to deploy something else with
address length as long as that of IPv6.

						Masataka Ohta

---

From: Khaled Omar <[email-masked]>
Date: Tue, 1 Feb 2022 12:27:28 +0000

>> I can't see any point to deploy something else with

Please read the IPv10 draft again.

Best regards,
Khaled Omar

Get Outlook for iOS<https://aka.ms/o0ukef>
________________________________
From: ietf <[email-masked]> on behalf of Masataka Ohta <[email-masked]>
Sent: Tuesday, February 1, 2022 2:23:34 PM
To: [email-masked] <[email-masked]>
Subject: Re: IPv10 is the solution.

                                                Masataka Ohta

---

From: Ladislav Lhotka <[email-masked]>
Date: Tue, 1 Feb 2022 13:27:44 +0100

> and these journals are contentless.

Maybe we have to ask whether it is still a good thing that anybody can 
publish anything as an Internet-Draft. Yes, IPv10 is quite a singular 
case, but this is already n-th iteration ...

Lada

-- 
Ladislav Lhotka
Head, CZ.NIC Labs
PGP Key ID: 0xB8F92B08A9F76C67

---

From: Khaled Omar <[email-masked]>
Date: Tue, 1 Feb 2022 12:34:45 +0000

publish anything as an Internet-Draft. Yes, IPv10 is quite a singular
case, but this is already n-th iteration .

IMHO, it is a good thing, good ideas will continue and other ideas will vanish.

Good point Lada.

Best regards,
Khaled Omar

Get Outlook for iOS<https://aka.ms/o0ukef>
________________________________
From: ietf <[email-masked]> on behalf of Ladislav Lhotka <[email-masked]>
Sent: Tuesday, February 1, 2022 2:27:44 PM
To: [email-masked] <[email-masked]>
Subject: Re: Fwd: IPv10 is the solution.

Lada

---

From: "Scheffenegger, Richard" <[email-masked]>
Date: Tue, 1 Feb 2022 13:41:19 +0100

nothing to see here - after this discussion sparked my interest (I'm not
saying if in a positive or less so way).

To quote the only actual text from the draft

https://datatracker.ietf.org/doc/html/draft-omar-ipv10-13

"This contribution has been withdrawn."

Can we please move on?

R

Am 01.02.2022 um 13:27 schrieb Ladislav Lhotka:
>> inflate their list of publications
>> <https://en.wikipedia.org/wiki/Publish_or_perish>
>>

---

From: Khaled Omar <[email-masked]>
Date: Tue, 1 Feb 2022 12:45:13 +0000

You can read version 12.

Get Outlook for iOS<https://aka.ms/o0ukef>
________________________________
From: ietf <[email-masked]> on behalf of Scheffenegger, Richard <[email-masked]>
Sent: Tuesday, February 1, 2022 2:41:19 PM
To: Ladislav Lhotka <[email-masked]>; [email-masked] <[email-masked]>
Subject: Re: Fwd: IPv10 is the solution.

Can we please move on?

R

---

From: Masataka Ohta <[email-masked]>
Date: Tue, 1 Feb 2022 21:50:09 +0900

> Please read the IPv10 draft again.

That it support address range as large as that of IPv6
makes it operationally hopeless, just as IPv6 is
operationally hopeless, regardless of protocol details
on how the so lengthy addresses are specified.

					Masataka Ohta

---

From: Khaled Omar <[email-masked]>
Date: Tue, 1 Feb 2022 12:55:30 +0000

IPv6 is important, maybe the length would decrease a little bit :D
But at the same time, it has to support large number of hosts, that's why IPv10 as a solution it paves the road to IPv6 to dominate smoothly or to live in peace with IPv4.

Best regards,
Khaled Omar

Get Outlook for iOS<https://aka.ms/o0ukef>
________________________________
From: Masataka Ohta <[email-masked]>
Sent: Tuesday, February 1, 2022 2:50:09 PM
To: Khaled Omar <[email-masked]>; [email-masked] <[email-masked]>
Subject: Re: IPv10 is the solution.

                                        Masataka Ohta

---

From: Masataka Ohta <[email-masked]>
Date: Tue, 1 Feb 2022 22:22:20 +0900

Khaled Omar wrote:

> IPv6 is important,

Not at all.

So, please don't try to make it worse with your added complication
as it is already too much complicated to be useless.

					Masataka Ohta

---

From: Khaled Omar <[email-masked]>
Date: Tue, 1 Feb 2022 13:25:41 +0000

-1 IPv6 supporter.

Sent: Tuesday, February 1, 2022 3:22:20 PM

Not at all.

                                        Masataka Ohta