Subject: RFC 4858 on shepherding

From: "Salz, Rich" <[email-masked]>
Date: Sun, 13 Feb 2022 21:02:31 +0000

That RFC, which I got from reading the Tao, seems very updated.  In my experience, the WG chair usually does the writeup and the responsible AD handles the followups.  Is that generally true?

---

From: Donald Eastlake <[email-masked]>
Date: Sun, 13 Feb 2022 17:01:00 -0500

> That RFC, which I got from reading the Tao, seems very updated.  In my experience, the WG chair usually does the writeup and the responsible AD handles the followups.  Is that generally true?

I think you mean "outdated", not "updated". The Shepherd normally does
the write-up, it is just that it is common for a Chair to be appointed
Shepherd.  Follow-ups are a complex multi-party process. If the
Authors are on the ball, there may be nothing for the Shepherd to do
that the authors are not already following up.

Thanks,
Donald
===============================
 Donald E. Eastlake 3rd   +1-508-333-2270 (cell)
 2386 Panoramic Circle, Apopka, FL 32703 USA
 [email-masked]

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Sun, 13 Feb 2022 22:26:13 +0000

Document shepherds are quite often one of the WG chairs. And this is something that I try to avoid as an AD by pushing the WG participants to step forward with the help of the chairs.

Nothing of course "against" the WG chairs but more to get more people on board with the IETF processes and hopefully getting some shepherds into a WG chair position or other position.

To be honest, this is not really easy to find volunteers to be shepherd, but sometimes it works ;-)

Regards

-éric

On 13/02/2022, 23:02, "ietf on behalf of Donald Eastlake" <[email-masked] on behalf of [email-masked]> wrote:

    Thanks,
    Donald

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 14 Feb 2022 11:32:49 +1300

I don't think it's outdated at all. It was a very necessary document at the time, because many WGs were suffering from process delays when WG chairs and authors were unclear on the process. My memory is that Alison Mankin in particular pushed for a more systematic approach, reagardless of whether it is a WG Chair or another designated person that acts as shepherd. These days, this approach is built into WG Chair culture and is supported by the tracker.

Having a non-WG-Chair as shepherd is particularly useful if one, or even both, chairs are authors of the draft in question. In that case it avoids a tricky conflict of interest. In other cases it simply spreads the workload, if a WG has many documents reaching maturity at the same time.

Regards
    Brian Carpenter

---

From: Michael Richardson <[email-masked]>
Date: Sun, 13 Feb 2022 17:41:40 -0500

Brian E Carpenter <[email-masked]> wrote:
    > Having a non-WG-Chair as shepherd is particularly useful if one, or
    > even both, chairs are authors of the draft in question. In that case it
    > avoids a tricky conflict of interest. In other cases it simply spreads
    > the workload, if a WG has many documents reaching maturity at the same
    > time.

My view is that the most valuable thing is that it exposes more people to the
process.  They become possible WG chair candidates, if not in that WG, then
perhaps another.

I would really like to find a way to raise the profile of the shepherd, and
make it something that people aspire to.

--
Michael Richardson <[email-masked]>   . o O ( IPv6 IøT consulting )
           Sandelman Software Works Inc, Ottawa and Worldwide

---

From: John C Klensin <[email-masked]>
Date: Sun, 13 Feb 2022 18:17:58 -0500

--On Sunday, February 13, 2022 17:41 -0500 Michael Richardson
<[email-masked]> wrote:

>     > Having a non-WG-Chair as shepherd is particularly useful
> if one, or     > even both, chairs are authors of the draft in
> question. In that case it     > avoids a tricky conflict of
> interest. In other cases it simply spreads     > the workload,
> if a WG has many documents reaching maturity at the same     >
> time.
> 
> My view is that the most valuable thing is that it exposes
> more people to the process.  They become possible WG chair
> candidates, if not in that WG, then perhaps another.
> 
> I would really like to find a way to raise the profile of the
> shepherd, and make it something that people aspire to.

One easy step, which assorted authors have, IIR, done at their
discretion, is that, especially when the shepherd is not a WG
chair, simply add them to the Acknowledgments for the document
with that particular designation, e.g., Thanks to <name> for
acting as Shepherd and assisting in moving this document through
the system.  It wouldn't be a bad idea to add the shepherd
name(s) to the RFC Editor datebase for published documents (in
addition to the line in the datatracker display for the I-Ds)
either.  And someone might look at the Nomcom questionnaires and
similar places where experience as a shepherd might be more
explicitly asked about.

Of course, any or all of that could be done by convention and
establishing the practice -- no updates to 4858 required.

    john

---

From: tom petch <[email-masked]>
Date: Mon, 14 Feb 2022 09:21:26 +0000

> To be honest, this is not really easy to find volunteers to be shepherd, but sometimes it works ;-)

My experience is otherwise (Routing, Ops WGs).  I think it rare for a WG 
Chair to be shepherd and I often see a Chair asking for a volunteer to 
be shepherd and getting one, perhaps a Chair of another WG.  (I am 
amazed, looking at the Datatracker, how many names there are that I 
think of as document authors who are actually WG Chairs of another WG).

Where the process may be less good is the production of the shepherd 
report and discussion thereof, taking time and not having a mechanism 
for resolution of disagreements between Shepherd and WG Chairs.

Tom Petch

---

From: "Salz, Rich" <[email-masked]>
Date: Mon, 14 Feb 2022 15:28:20 +0000

Yes, that's what I meant.  Thanks.

Perhaps the RFC needs updating, to remove everyth8ing but the doc?

---

From: "Salz, Rich" <[email-masked]>
Date: Mon, 14 Feb 2022 16:03:08 +0000

My original note wasn't clear, sorry for the confusion.

RFC 4858 talk in detail about writing the shepherd document, and then working with the various parties to get the document through the AD, IESG, IETF LC, and IANA reviews.  I was asking if the *everything but the document part* is obsolete.  Does anyone have recent examples (use your own definition of recent; mine is like five years) where the *document shepherd* guided the draft through all of the other parts, as described in the RFC?

---

From: "Adrian Farrel" <[email-masked]>
Date: Mon, 14 Feb 2022 16:15:11 -0000

[Beware: trumpet blowing]

Yes, I often take the time as document shepherd to chivvy the process along. Chasing ADs to review, issue IETF last call, put the document on an agenda; chasing authors to update the document after reviews; chasing ADs and authors to talk about Comments and Discusses; chasing ADs to clear Discusses when the document has been updated. Even chasing authors to do Auth48 sign-off (although the RPC is pretty good at that).

Is that part of the shepherd's brief? By 4858, possibly. By my understanding of what is needed, definitely.

Cheers,
Adrian

---

From: "Joel M. Halpern" <[email-masked]>
Date: Mon, 14 Feb 2022 11:16:51 -0500

When I as chair appoint a non-chair shepherd I expect them to do the 
whole job.  And they, and the authors, generally do.  As chair, I do 
keep an eye on things to help if needed.

Yours,
Joel

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 14 Feb 2022 17:29:42 +0100

On 2022-02-14, at 17:03, Salz, Rich <rsalz=[email-masked]> wrote:
> 
> Does anyone have recent examples (use your own definition of recent; mine is like five years) where the *document shepherd* guided the draft through all of the other parts, as described in the RFC?

The future is already here, it’s just not evenly distributed.

I’d rephrase the question:  
What can we do to make this more universally the case?

Grüße, Carsten

---

From: tom petch <[email-masked]>
Date: Mon, 14 Feb 2022 16:53:28 +0000

> keep an eye on things to help if needed.

I have seen this in action many times and think that it works very well,

Tom Petch

>> RFC 4858 talk in detail about writing the shepherd document, and then
>> working with the various parties to get the document through the AD,
>> IESG, IETF LC, and IANA reviews.  I was asking if the *everything but
>> the document part* is obsolete.  Does anyone have recent examples (use
>> your own definition of recent; mine is like five years) where the
>> *document shepherd* guided the draft through all of the other parts,
>> as described in the RFC?
>>
>>
>>
>
> .
>

---

From: John C Klensin <[email-masked]>
Date: Mon, 14 Feb 2022 12:10:54 -0500

--On Monday, February 14, 2022 17:29 +0100 Carsten Bormann
<[email-masked]> wrote:

> On 2022-02-14, at 17:03, Salz, Rich
>> Does anyone have recent examples (use your own definition of
>> recent; mine is like five years) where the *document
>> shepherd* guided the draft through all of the other parts, as
>> described in the RFC?
> 
> The future is already here, it's just not evenly distributed.
> 
> I'd rephrase the question:  

Carsten, I'd urge a little caution.  Explanations as part of
whatever is done in WG Chair and Author training, definitely.
Better and more systematic acknowledgments, possibly.  Maybe an
upgrade to the IESG's statements about what shepherds are
expected to report about to more strongly emphasize the rest of
the role.   But Areas are different, working groups are
different even within areas, documents from "dispatch"-like WGs
or other AD-sponsored documents can be very different from
ordinary WG ones, and so on.  Some ADs might even decide there
are documents they should shepherd personally or assign to
another AD (something I'm generally opposed to if IESG members
are authors or instigators).

I'm also a bit concerned about anything that could be seen or
used to either eliminate AD discretion or reduce AD
accountability.

So, while I think this discussion itself may be helpful in
improving the situation (assuming the relevant people read this
list), I'd be _very_ hesitant to see any formal procedural
changes, including revisions to 4858, that would lock in a
particular way of doing things and that could get in the way of
making case-specific decisions and Doing the Right Thing.  I
don't think that is what you were proposing, but it is where
discussions like this can easily lead.

   john

---

From: Warren Kumari <[email-masked]>
Date: Mon, 14 Feb 2022 11:12:08 -0600

> process.  They become possible WG chair candidates, if not in that WG, then
Yup. I think that there are 2 really valuable aspects of having non-chairs
be shepherds:
1: It's an easy way for people to get more experience with the process -
they see how the sausage is made, and that there really isn't any magic.
They then are much more likely to be willing (and good!) chairs.
but also
2: it provides a really valuable second set of eyes. In many cases the
shepherd notices something that the chairs had overlooked, or where they
may have (probably unintentionally) over-judged consensus or otherwise
allowed their biases to influence the outcome.

A third aspect is that it also takes some load off of the chairs (which
also makes more people willing and able to chair)

> make it something that people aspire to.

Yup. I fairly regularly ask my chairs to please ask for volunteers to
shepherd -- this hasn't proved to be especially effective. Chairs do ask,
but often have a hard time getting volunteers (and often it's easier for
them to just ask once or twice and then start doing them themselves).
Some of this is that many people aren't really sure how much work it is,
some of this is small concerns about potentially offending the chair
("Srsly!? You thought that *that* was consensus?!"), but much of it is also
that there isn't much / any incentive for taking on the extra work.

A while back I'd had some discussions, and was planning on asking all of
the authors in my area to please add something to the acknowledgements
section along the lines of:
"Thanks to Sophia Adamos being the Document Shepherd for this document, and
to Ige Ayaan and Amira Mitchel for chairing the WG" -- I believe that the
acknowledgement section belongs to the authors, and so they could always
just say "No...".
I *do* think that it is important / useful to also thank the chairs -- it
is sometimes hard to find people willing to serve as chairs (or the people
who are willing might be obviously conflicted), and, apart from just being
polite, thanking people may make it easier for them to justify their time.

All of this morphed into discussions on having a standard section which
listed the document shepherd and chairs, but that fell into drama (and I
became distracted :-)).

I'm planning on reviving the general idea of asking the authors to please
add a sentence or two thanking the shepherds. Can't hurt...

W

-- 
The computing scientist’s main challenge is not to get confused by the
complexities of his own making.
  -- E. W. Dijkstra

---

From: Allison Mankin <[email-masked]>
Date: Mon, 14 Feb 2022 13:55:51 -0500

I am just revisiting the RFC with a new non-Chair Shepherd  in my WG (ECRIT).
IMO, It's holding up well other than the antiquated sample questionnaire..
I'd be happy to work with someone on removing the sample and revising a bit.

My co-chair Randall and I expect the Shepherd to do the whole thing,
with mentoring
from us where needed, and (crucial) cooperation and support from the
authors. We made sure the authors were aware of Dwight (the Shepherd) and
that's been fine.  The writeup questionnaire was a great learning
experience - it's got a lot in it and done right (which it was), there's
IETF gold there.

Agreeing with some things in the thread: as Michael, Brian and others said,
they help IETF train potential future Chair (and recruit) and I love this. But
also they are needed multipliers, because Chairs have lots docs in flight
at once and frequently have several or lots of WGs. The Shepherd can focus
on the doc process fine points with close attention. The Chair roles of
leading the WG and ensuring quality review have to be done before the
Shepherd starts work with the Writeup (before the Chair can ask for
publication).  I think everyone knows this last point, but reminding people
if they don't.

As has been mentioned, the Shepherd role and the Writeup are well
integrated in the datatracker now and have been for a few years.  I wrote
up a document a few years back for the WG and that was the case.

I'd love to see nomcom ask about shepherding experience, what a great
idea.  As far as I can tell, it's hard to search the datatracker for a
person's Writeups, but the candidate could supply them and the nomcom could
get from people what they well were good and challenging ones to take a
look at - you can link.

One possible integration gap: is the shepherd role included in the draft
email aliases?  I think maybe not.

Allison

On Mon, Feb 14, 2022 at 11:17 Joel M. Halpern <[email-masked]> wrote:

> working with the various parties to get the document through the AD, IESG,
> IETF LC, and IANA reviews.  I was asking if the *everything but the
> document part* is obsolete.  Does anyone have recent examples (use your own
> definition of recent; mine is like five years) where the *document
> shepherd* guided the draft through all of the other parts, as described in
> the RFC?
> >
> >
> >
>
>

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 15 Feb 2022 08:47:03 +1300

Hi Allison,

> One possible integration gap: is the shepherd role included in the draft email aliases?  I think maybe not.

Yes, the shepherd is in the .shepherd, .all and .notify aliases, among others.

Example: https://datatracker.ietf.org/doc/draft-ietf-anima-grasp-distribution/email/

(Another reason to use the .all alias for sending reviews etc.)

Regards

---

From: Behcet Sarikaya <[email-masked]>
Date: Tue, 15 Feb 2022 09:52:18 -0600

On Mon, Feb 14, 2022 at 10:15 AM Adrian Farrel <[email-masked]> wrote:

> Yes, I often take the time as document shepherd to chivvy the process
> along. Chasing ADs to review, issue IETF last call, put the document on an
> agenda; chasing authors to update the document after reviews; chasing ADs
> and authors to talk about Comments and Discusses; chasing ADs to clear
> Discusses when the document has been updated. Even chasing authors to do
> Auth48 sign-off (although the RPC is pretty good at that).
>
>

I did some shepherd ing both as a chair and as a WG member. To my
knowledge, shepherd's job finishes after sending the document to IESG.
The rest just flows along, no need to keep checking everything at every
step.
Actually it used to be the chair(s) who did the job, I think that was the
correct procedure.

 Behcet

> Is that part of the shepherd's brief? By 4858, possibly. By my
> understanding of what is needed, definitely.
>
> Cheers,
> Adrian
> To: tom petch <[email-masked]>; Eric Vyncke (evyncke) <evyncke=
> [email-masked]>; Donald Eastlake <[email-masked]>
> Cc: [email-masked]

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 15 Feb 2022 17:04:52 +0100

> On 2022-02-14, at 18:10, John C Klensin <[email-masked]> wrote:
> 
> I'd be _very_ hesitant to see any formal procedural
> making case-specific decisions and Doing the Right Thing.  

Hi John,

I didn’t even think I’d need to write something to exclude this.
I was purely talking about aids that might spread the word that this has worked well for some of us and that might help in the actual execution, and thank you for your suggestions.

> I

I wasn’t proposing that, and I’d be the first to argue against trying to make life more difficult for everyone by adding more rules (*).

Grüße, Carsten

(*) I still fondly remember the recent term limits discussion.

---

From: Michael Richardson <[email-masked]>
Date: Tue, 15 Feb 2022 13:22:42 -0500

tom petch <[email-masked]> wrote:
    ev> To be honest, this is not really easy to find volunteers to be
    ev> shepherd, but sometimes it works ;-)

    tp> My experience is otherwise (Routing, Ops WGs).  I think it rare for a
    tp> WG Chair to be shepherd and I often see a Chair asking for a
    tp> volunteer to be shepherd and getting one, perhaps a Chair of another

If document shepherding is working well in the Routing area, that's really
great news.  Can you teach the rest of us how to be better?

    tp> WG.  (I am amazed, looking at the Datatracker, how many names there
    tp> are that I think of as document authors who are actually WG Chairs of
    tp> another WG).

Well, so maybe this is really what's happening: people who are chairs know
the challenges that other chairs have.

    tp> Where the process may be less good is the production of the shepherd
    tp> report and discussion thereof, taking time and not having a mechanism
    tp> for resolution of disagreements between Shepherd and WG Chairs.

!

---

From: tom petch <[email-masked]>
Date: Fri, 18 Feb 2022 17:05:46 +0000

> great news.  Can you teach the rest of us how to be better?

Get yourself an AD who encourages the process.  I was going to say get a 
better AD but that would be wrong, ADs are good already, but I suspect 
that this goes back a decade or two, perhaps to just one AD, an AD who 
encouraged the chairs to work this way and then this has cascaded down 
the successive occupants of the posts, especially when Chairs become ADs.

I think that the AD-Chair relationship is a key factor in the success or 
otherwise of the processes, more clearly seen, perhaps, when the 
processes are less successful.

Tom Petch

---

From: Lars Eggert <[email-masked]>
Date: Mon, 21 Feb 2022 17:29:44 +0200

Hi,

On 2022-2-14, at 20:55, Allison Mankin <[email-masked]> wrote:
> I am just revisiting the RFC with a new non-Chair Shepherd  in my WG (ECRIT). IMO, It's holding up well other than the antiquated sample questionnaire.. I'd be happy to work with someone on removing the sample and revising a bit.

FYI, the current questionnaire templates live at https://www.ietf.org/chairs/document-writeups/

Also, the IESG is in the last stages of revising the template; expect an announcement soon.

Thanks,
Lars