Subject: Update on www.ietf.org analytics and proposal for next steps

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Wed, 9 Feb 2022 08:18:47 +0000

Hello,

This note provides a follow up on the deployment of analytics on www.ietf.org<http://www.ietf.org> [1] and proposes next steps for deploying analytics on other IETF websites.

Per the implementation plan [2], the IESG and IETF Tools Team have reviewed the current deployment on www.ietf.org<http://www.ietf.org> and have confirmed it is delivering anticipated results. In the past year, information from web analytics on has been used by IETF LLC staff and the Secretariat to understand and improve use of www.ietf.org in various ways, including by:

  *   prioritizing and improving content on the most visited pages
  *   identifying reachability issues for specific URLs
  *   understanding sources of visitors to web pages
  *   tailoring site-wide features to improve access to specific content

Aggregated analytics is available to the community at:

​​https://www.ietf.org/policies/web-analytics/

During the discussion around the initial call for community input, several responses suggested expanding the scope of web analytics to include other IETF Internet properties.

Based on the IESG and Tools Team reviews, and experience gained in the past year, and requests by maintainers of other IETF websites, we propose to implement analytics on:

  *   IETF Datatracker (datatracker.ietf.org)
  *   The IETF meeting registration system (registration.ietf.org)
  *   Sites using the new wiki platform, Wiki.js (e.g. chairs.ietf.org and authors.ietf.org)[3]
  *   Related Internet properties such as yangcatalog.org

These deployments would replicate and conform to the implementation plan developed for www.ietf.org<http://www.ietf.org>. They would NOT enable cross domain linking.[4] As with the initial deployment on www.ietf.org<http://www.ietf.org>, the IESG and Tools Team would review these deployments after one year to ensure they are delivering the expected results.

The IESG appreciates any input from the community on this proposal and will consider all input received by February 23, 2022.

Regards,

Éric Vyncke

On behalf of the IESG

[1] https://mailarchive.ietf.org/arch/msg/ietf/g0uqkYtFx3aFeOwyLxY7ob1DdTI/

[2] https://www.ietf.org/media/documents/www.ietf.org-AnalyticsProposal-Revised-2019-09-24.pdf

[3] https://mailarchive.ietf.org/arch/msg/tools-discuss/eGihlMqjx9yKQqWhqnn4DtgKaSg/

[4] https://matomo.org/faq/how-to/faq_23654/

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 10 Feb 2022 08:45:07 +1300

Éric,

> prioritizing and improving content on the most visited pages

Right, but IMHO an equally important point is looking at which pages are less visited *and why not*. Is it because they are not so important, or because they are hard to find? Are there pages that we would consider important that nobody looks at?

> The aggregated data is made available to the IETF LLC staff, contractors whose role requires it, and the Internet Engineering Steering Group.

I would suggest that EMO also needs to see the data. Are people finding and using the educational/tutorial material? There isn't enough detail in the overview reports to answer that (it's all hidden in the "Others" category), but thanks for publishing them.

Regards
    Brian Carpenter

On 09-Feb-22 21:18, Eric Vyncke (evyncke) wrote:
> Hello,
> 
> This note provides a follow up on the deployment of analytics on www.ietf.org <http://www.ietf.org>[1] and proposes next steps for deploying analytics on other IETF websites.
> 
> Per the implementation plan [2], the IESG and IETF Tools Team have reviewed the current deployment on www.ietf.org <http://www.ietf.org>and have 
confirmed it is delivering anticipated results. In the past year, information from web analytics on has been used by IETF LLC staff and the Secretariat to understand and improve use of www.ietf.org in various ways, including by:
> ​​https://www.ietf.org/policies/web-analytics/ <https://www.ietf.org/policies/web-analytics/>
> 
> These deployments would replicate and conform to the implementation plan developed for www.ietf.org <http://www.ietf.org>. They would NOT enable 
cross domain linking.[4] As with the initial deployment on www.ietf.org <http://www.ietf.org>, the IESG and Tools Team would review these deployments after one year to ensure they are delivering the expected results.
> [1] https://mailarchive.ietf.org/arch/msg/ietf/g0uqkYtFx3aFeOwyLxY7ob1DdTI/ <https://mailarchive.ietf.org/arch/msg/ietf/g0uqkYtFx3aFeOwyLxY7ob1DdTI/>
> 
> [2] https://www.ietf.org/media/documents/www.ietf.org-AnalyticsProposal-Revised-2019-09-24.pdf <https://www.ietf.org/media/documents/www.ietf.org-AnalyticsProposal-Revised-2019-09-24.pdf>
> 
> [3] https://mailarchive.ietf.org/arch/msg/tools-discuss/eGihlMqjx9yKQqWhqnn4DtgKaSg/ <https://mailarchive.ietf.org/arch/msg/tools-discuss/eGihlMqjx9yKQqWhqnn4DtgKaSg/>
> 
> [4] https://matomo.org/faq/how-to/faq_23654/ <https://matomo.org/faq/how-to/faq_23654/>
> 
>

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Wed, 9 Feb 2022 19:49:59 +0000

Brian

All very good and *useful* comments. Unsure though how to answer the  "why not" question but knowing that parts of the IETF web properties are never used is already interesting. 

I will work with Greg and the tools team to ensure giving more visibility to EMO.

Regards "et merci"

-éric 

On 09/02/2022, 20:45, "Brian E Carpenter" <[email-masked]> wrote:

    Éric,

    Regards
        Brian Carpenter

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Mon, 28 Feb 2022 09:43:23 +0000

Last Thursday, the IESG has discussed this topic including the received feedback [1] and we will go forward with the analytics, including YangCatalog.org.

The received suggestion of giving some more detailed information to specific groups (e.g., Brian's suggestion about emodir) will be technically evaluated by the tools team.

Regards

-éric

[1] https://mailarchive.ietf.org/arch/msg/ietf/68Vo73QiDuQJUyMUuO9YFPc5wxM/

From: Eric Vyncke <[email-masked]>
Date: Wednesday, 9 February 2022 at 09:18
To: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Update on www.ietf.org analytics and proposal for next steps

Hello,

Per the implementation plan [2], the IESG and IETF Tools Team have reviewed the current deployment on www.ietf.org<http://www.ietf.org> and have confirmed it is delivering anticipated results. In the past year, information from web analytics on has been used by IETF LLC staff and the Secretariat to understand and improve use of www.ietf.org in various ways, including by:
·         prioritizing and improving content on the most visited pages
·         identifying reachability issues for specific URLs
·         understanding sources of visitors to web pages
·         tailoring site-wide features to improve access to specific content

·         IETF Datatracker (datatracker.ietf.org)
·         The IETF meeting registration system (registration.ietf.org)
·         Sites using the new wiki platform, Wiki.js (e.g. chairs.ietf.org and authors.ietf.org)[3]
·         Related Internet properties such as yangcatalog.org

Regards,

Éric Vyncke

On behalf of the IESG