Subject: The IETF and Brexit

From: Brian E Carpenter <[email-masked]>
Date: Fri, 1 Jan 2021 17:21:24 +1300

In the spirit of not taking life too seriously, I thought people might like to know that the IETF is mentioned four times in the recent "TRADE AND COOPERATION AGREEMENT BETWEEN THE EUROPEAN UNION AND THE EUROPEAN ATOMIC ENERGY COMMUNITY, OF THE ONE PART, AND THE UNITED KINGDOM OF GREAT BRITAIN AND NORTHERN IRELAND, OF THE OTHER PART", i.e. the Brexit deal.

For a pointer to the 1246-page document, see https://www.theregister.com/2020/12/31/brexitl_obsolete_tech_explained/

Seriously, however, this shows that what we do does actually impact international law, sometimes many years after the IETF has moved on. Who'd have guessed that classful addressing was part of the Brexit deal:

"A dedicated block half B class subnet has currently been allocated by the European IP registration authority (RIPE) to TESTA." (page 925). 

Not to mention things like "the hash algorithm SHA-1 shall be applied." (page 921)

Regards
   Brian Carpenter

---

From: <[email-masked]>
Date: Fri, 1 Jan 2021 00:37:10 -0500

> Not to mention things like "the hash algorithm SHA-1 shall be applied." (page

Schneier mentions this and RSA 1024, among other things. It's copy and paste to continue support for some old treaty, as the register clarifies:
https://www.theregister.com/2020/12/31/brexitl_obsolete_tech_explained/

Gabriel