Subject: Re: Protecting Copyright.

From: "Salz, Rich" <[email-masked]>
Date: Fri, 1 May 2020 13:56:31 +0000

*   So let’s make it clear, one of the ietf rules is to use and apply the contents of any ID without any acknowledgment from either the author or the ietf.

Read what you agreed to when you submitted your draft after acknowledging the Note Well and the documents it references.

Short answer: yes.

---

From: Khaled Omar <[email-masked]>
Date: Fri, 1 May 2020 14:06:47 +0000

> Short answer: yes.

Conclusion: ietf does protect any copyright, it is not responsible for any kind of stealing ideas, the ietf related work is from hearts to humanity and we don’t expect any outcome as it is not a profitable organization.

My conclusion: I’ll not accept any of my ideas to be used without my acknowledgment or agreement, and I’ll not post any new drafts to this ietf.

Khaled Omar

From: Salz, Rich <[email-masked]>
Sent: Friday, May 1, 2020 3:57 PM
To: Khaled Omar <[email-masked]>; [email-masked]; 'Joseph Touch' <[email-masked]>
Cc: 'ietf' <[email-masked]>
Subject: Re: Protecting Copyright.

Ø  So let’s make it clear, one of the ietf rules is to use and apply the contents of any ID without any acknowledgment from either the author or the ietf.

Short answer: yes.

---

From: "Salz, Rich" <[email-masked]>
Date: Fri, 1 May 2020 14:32:03 +0000

*   My conclusion: I’ll not accept any of my ideas to be used without my acknowledgment or agreement, and I’ll not post any new drafts to this ietf.

Given that you stubbornly refuse to read the rules and copyright, despite the efforts of many people here to encourage you, that is best.

---

From: Khaled Omar <[email-masked]>
Date: Fri, 1 May 2020 14:34:27 +0000

> Given that you stubbornly refuse to read the rules and copyright, despite the efforts of many people here to encourage you, that is best.

Sorry, but I don’t care about the written rules, I care about the applied and enforced rules, I think there is a clear example now about the rules, and the applied rules.

Sent: Friday, May 1, 2020 4:32 PM

Ø  My conclusion: I’ll not accept any of my ideas to be used without my acknowledgment or agreement, and I’ll not post any new drafts to this ietf.

---

From: Bob Hinden <[email-masked]>
Date: Fri, 1 May 2020 08:43:43 -0700

> On May 1, 2020, at 7:06 AM, Khaled Omar <[email-masked]> wrote:
> 
> > Short answer: yes.
> 

You are confusing copyrights and patents.  Copyrights only protect the words in a document, not the ideas in the document.   If you want to protect an idea, you need to get a patent for it.

Bob

---

From: Khaled Omar <[email-masked]>
Date: Fri, 1 May 2020 15:55:21 +0000

> If you want to protect an idea, you need to get a patent for it.

Yes, this is out the scope of ietf.

Get Outlook for Android<https://aka.ms/ghei36>

________________________________
From: Bob Hinden <[email-masked]>
Sent: Friday, May 1, 2020, 5:43 PM
To: Khaled Omar
Cc: Bob Hinden; IETF
Subject: Re: Protecting Copyright.

Bob

---

From: John C Klensin <[email-masked]>
Date: Fri, 01 May 2020 12:01:14 -0400

--On Friday, May 1, 2020 14:34 +0000 Khaled Omar
<[email-masked]> wrote:

>> Given that you stubbornly refuse to read the rules and
>> copyright, despite the efforts of many people here to
>> encourage you, that is best.
> 
> Sorry, but I don't care about the written rules, I care
> about the applied and enforced rules, I think there is a clear
> example now about the rules, and the applied rules.

Khaled,

If you don't care about the written rules, then don't agree to
them.   You make that agreement each time you post a draft that
explicitly contains the required Copyright section.  Indeed, you
consented to those rules for any posting you make when you
joined this mailing list or join any other IETF mailing list.

Now, if you intend your statement above to mean that,
independent of your apparent consent to those written rules, you
are going to continue to ignore them, formulate your own
interpretation of them, and then complain that your desired
interpretation is not accepted by others, I assume that, sooner
or later, the IETF will demonstrate to you that it has rules
that it will enforce.  That is, for the record, not a prediction
as to when or how, nor (at least at this time) a request.

regards,
   john

---

From: Michael StJohns <[email-masked]>
Date: Fri, 1 May 2020 12:04:05 -0400

> as to when or how, nor (at least at this time) a request.
Well said!

---

From: Khaled Omar <[email-masked]>
Date: Fri, 1 May 2020 16:29:57 +0000

> the IETF will demonstrate to you that it has rules

Anyone can make rules, it is basics, but does these rules protect rights, does those rules are enforced on everyone, does these rules has ethics, if yes, then it should be explained clearly and signed by each new participant, but don't tell me an ID must follow this formula and once i do, someone steals the contents and you tell me you agreed, i didn't sign an agreement, maybe i didn't read all BCPs, but from what i experienced, no protection for authors at all.

If someone can use the content, then use it, many are supporting you :D even it is not right.

Look i think we shouldn't spend all this time in this discussion, anyone will find his work is stolen, will not accept it, and i think many are understanding, so no need to enter an infinite loop because some don't want to understand that human rights are not rules only, it is actions to take to achieve these rights.

Khaled Omar

________________________________
From: ietf <[email-masked]> on behalf of Michael StJohns <[email-masked]>
Sent: Friday, May 1, 2020 6:04:05 PM
To: [email-masked] <[email-masked]>
Subject: Re: Protecting Copyright.

Well said!

---

From: Abdussalam Baryun <[email-masked]>
Date: Sat, 2 May 2020 16:35:47 +0200

On Thu, Apr 30, 2020 at 6:07 PM Khaled Omar <[email-masked]>
wrote:

> Hi AB,
>
>
>
> > This happens in IETF when the WG chair is not engaging the work with wg
> participants
>
>
>
> The issue is that WG chairs are not welcoming my drafts and they act like
> this ID is not related to my work area J and you find someone copied and
> applied without a notice.
>

It is important to take WG chair/AD advises, and gain interest/support from
ietf community.
Regarding copying, there is big possibility no copy because ideas not
completed nor implemented.

>
>
> No discussion, no comments, only criticism, actually I use the ietf as a
> scientific journal, to publish my ideas, and they even don’t grant
> protection to the copyright in their journal J
>

You can get discussions within your country or city or company, find
engineers in your field that you know and can discuss with, then update
your work. Many will ask if you implemented it and what were the results.

Take care,

AB

>
>
> Khaled Omar
>
>
>
> *From:* Abdussalam Baryun <[email-masked]>
> *Sent:* Thursday, April 30, 2020 5:49 PM
> *To:* [email-masked]
> *Cc:* ietf <[email-masked]>
> *Subject:* Re: Protecting Copyright.
>
>
>
> Hello Khaled,
>
>
>
> This happens in IETF when the WG chair is not engaging the work with wg
> participants. IMO the WG chair is the one to communicate with and to check
> with or the AD. Overall it is healthy to share ideas/comments and to
> acknowledge them.
>
>
>
> My comments below [AB],
>
>
>
>
>
> From: ietf <[email-masked]> <&lt;[email-masked]&gt;> On Behalf Of Khaled Omar
>
> Sent: 28 April 2020 16:35
>
> To: [email-masked]
>
> Subject: Protecting Copyright.
>
> >Hi all,
>
>
>
> >I would like to ask why ideas submitted into ietf drafts are applied without a notice to the draft authors ?!!!
>
> [AB] that should not happen,
>
>
>
> >Before NEP ID, there was no IGP uses a composite metric such as NEP uses, and now I can see that cisco added a third factor to its eigrp metric calculation (they call it K6) and became as NEP ID.
>
> [AB] I did not understand, however, ideas can be used but always must be acknowledged, but still most ietf culture still leave acknowledgement to authors only and not the WG. That IMHO is wrong and hopefully the culture changes to be more open to all and more social.
>
>
>
> >The funny thing is that during NEP presentation at the ietf meeting someone from cisco asked "what are the benefits to add this factor to the metric", and then you see this factor added to their IGP.
>
>
>
> >Actually, I received no notice from cisco before applying such thing to their IGP.
>
>
>
> >Can someone tells me what this means or what to call this?
>
> [AB] May call it bad situation or bad working-groupings. Some IETF WG are having groups inside the main WG, which is not healthy. There is a possibility of using the idea without copying, because may be no direct input to the draft or WG. I once complained about authors not acknowledging WG participants influenced a change to draft, and I still think it is not right to use reviewer comments without acknowledging.
>
> Best Regards
>
> AB
>
>