Subject: Re: I-D Action: draft-hoffman-dns-terminology-00.txt

From: John C Klensin <[email-masked]>
Date: Fri, 28 Nov 2014 12:02:28 -0500

--On Friday, 28 November, 2014 07:24 -0800
[email-masked] wrote:

> 
> A New Internet-Draft is available from the on-line
> Internet-Drafts directories.
> 
> 
>         Title           : DNS Terminology
>         Authors         : Paul Hoffman
>                           Andrew Sullivan
>                           Kazunori Fujiwara
> 	Filename        : draft-hoffman-dns-terminology-00.txt
> 	Pages           : 9
> 	Date            : 2014-11-28
> 
> Abstract:
>    The DNS is defined in literally dozens of different RFCs.
> The    terminology used in by implementers and developers of
> DNS protocols,    and by operators of DNS systems, has
> sometimes changed in the decades    since the DNS was first
> defined.  This document gives current    definitions for many
> of the terms used in the DNS in a single    document.
> 
> 
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-hoffman-dns-terminology/

Gentlemen,

I am delighted that someone is finally taking this on in a
serious way.  I find it interesting that the two terms that I
believe are most often abused -- "host" and "hostname" do not
seem to be covered.  If you can't come up with reasonable
definitions for them, I think you should at least warn against
their unqualified use.

Also, there is a DNS terminology discussion (and a rant about
the issues with sloppy terminology) in the now-expired
draft-klensin-dotless-terminology-harmful-00   I've been trying
to find time to revise it somewhat and see if the ISE would
publish it, but, if you want to adapt some of those ideas and/or
text, I'd be delighted.

   john

---

From: Paul Hoffman <[email-masked]>
Date: Fri, 28 Nov 2014 10:27:55 -0800

As a side-note, we started discussion on the DNSOP WG mailing list, but are happy to take suggestions in other places. And we again note that this is very preliminary document. (You, John, know how "very preliminary" drafts of terminology works out from our earlier work on RFC 6365.)

> definitions for them, I think you should at least warn against

Noted for the next draft, definitely.

> publish it, but, if you want to adapt some of those ideas and/or

We'll definitely take a look. The result will likely be less satirical than what is there, but we can probably glean some ideas.

--Paul Hoffman