Subject: Blog: YANG Really Takes Off in the Industry

From: Benoit Claise <[email-masked]>
Date: Thu, 27 Nov 2014 12:31:49 +0100

Dear all,

[netmod WG list is bcc'ed]

Enjoy 
http://www.ietf.org/blog/2014/11/yang-really-takes-off-in-the-industry/

Regards, Benoit

---

From: Jari Arkko <[email-masked]>
Date: Thu, 27 Nov 2014 16:08:12 +0200

Thanks for writing this article, Benoit!

The wave of new data models is obviously interesting and exciting. But I wanted to open a discussion with you all on what we should do with regards to serving this need better. Is there something that we could do better at the IETF to be able deal with this new work?

Jari

---

From: Benoit Claise <[email-masked]>
Date: Fri, 28 Nov 2014 14:12:54 +0100

Hi Jari,

Let me open the discussion.
What is important at this point in time is the coordination of those 
YANG models.
All of them come at the same time, and this required some urgent attention.
Focusing on the routing YANG models with "[email-masked]" 
<[email-masked]> 
<https://www.ietf.org/mailman/listinfo/rtg-yang-coord> is a step in the 
right direction. Indeed the community needs to agree on how to model 
IGPs, BGP, the topology, etc...
However, the coordination should also occur with the data models 
developed in other IETF WGs. And the IETF might need to reach out to 
different SDOs/consortia.
As the operators told me: we can't afford to develop those data models 
independently from each others.

Regards, Benoit

---

From: Tina TSOU <[email-masked]>
Date: Sat, 29 Nov 2014 04:17:41 +0000

Dear Benoit et al,

Good blog. I see this wave too.

Something needs to to be done to adapt to these YANG models.

Thank you,
Tina

From: netmod [mailto:[email-masked]] On Behalf Of Benoit Claise
Sent: Thursday, November 27, 2014 7:32 PM
To: IETF-Discussion list
Subject: [netmod] Blog: YANG Really Takes Off in the Industry

Dear all,

Enjoy http://www.ietf.org/blog/2014/11/yang-really-takes-off-in-the-industry/

Regards, Benoit

---

From: Dean Bogdanovic <[email-masked]>
Date: Mon, 1 Dec 2014 04:33:04 +0000

Benoit,

You describe the situation really well, but as next step we have to get more organized and more coordination in modeling work. We have to make sure that there is not too much overlap between efforts, not too waste resources and as well create an architecture description document, where the relationship between models will be described. With that we can see which models can be reused as base model in other models.
Good example of coordination is the rtg-coord-yang mailing list, but we need one for all IETF, to be able to find what are other the teams working on.

We should not let this momentum go away and with few simple steps (like improving coordination and system meta architecture), continue to feed positive energy into this situation.

Dean
On Nov 27, 2014, at 6:31 AM, Benoit Claise <[email-masked]<mailto:[email-masked]>> wrote:

Dear all,

Regards, Benoit

_______________________________________________
netmod mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/netmod