Subject: Re: IESG Teleconference Participation for November 25, 2014

From: Ted Lemon <[email-masked]>
Date: Tue, 18 Nov 2014 12:33:29 -0500

Do we have a calendar to subscribe to yet?

---

From: Ted Lemon <[email-masked]>
Date: Tue, 18 Nov 2014 12:36:02 -0500

> Do we have a calendar to subscribe to yet?

Sorry, I think Reply-to bit me.   Obviously the IETF mailing list is not the place to ask this question... :}

---

From: Chris Inacio <[email-masked]>
Date: Thu, 20 Nov 2014 05:32:05 +0000

> On Nov 18, 2014, at 12:36 PM, Ted Lemon <[email-masked]> wrote:
> 

Ahh, but maybe it is.

So in the SACM group I just filled out a Doodle poll with 60 options to create a interim meeting time.  Obviously the whole SACM group is expected to do this which is effectively copy our corporate/personal calendar into a Doodle poll.  This made me look into “is there a better way”?

First, I would hope to think that IETF could potentially host dudle, from TU-Dresden (https://dudle.inf.tu-dresden.de).  It’s an open source tool that allows the creation of polls just like Doodle.

Secondly, and more ambitiously, I was looking at tools like Doodle Premium, TimeBridge, WhenIsGood, and ScheduleOnce which allow calendar integration from user calendars (e.g. Exchange, Google, Apple Calendar, …) and helps in scheduling.

Having tooling like that to schedule an interim meeting would be great.

There is an “Interim Meeting Manager” but you need to login to see it - so I didn’t check it out.

--
Chris Inacio
[email-masked]

---

From: Ted Lemon <[email-masked]>
Date: Thu, 20 Nov 2014 07:43:25 -0500

> Secondly, and more ambitiously, I was looking at tools like Doodle Premium, TimeBridge, WhenIsGood, and ScheduleOnce which allow calendar integration from user calendars (e.g. Exchange, Google, App…

A privacy-preserving system for sharing calendars would really be nice.   Unfortunately I don't think these sites would work--I couldn't use them even if I weren't concerned about privacy because I'd have to hand them the keys to my corporate email/calendar account.   This is definitely an interesting problem.  :)

Dudle is interesting, but possibly expensive in terms of cost to set up.   The way things like that succeed in the IETF is that someone just sets them up and offers them, and then we find out if they are worthwhile.   If they are, then maybe we spend the money making them official.

---

From: Cyrus Daboo <[email-masked]>
Date: Thu, 20 Nov 2014 09:40:59 -0500

Hi Chris,

--On November 20, 2014 at 5:32:05 AM +0000 Chris Inacio <[email-masked]> 
wrote:

> Ahh, but maybe it is.
>
> So in the SACM group I just filled out a Doodle poll with 60 options to
> create a interim meeting time.  Obviously the whole SACM group is
> expected to do this which is effectively copy our corporate/personal
> calendar into a Doodle poll.  This made me look into “is there a better
> way”?
>
> First, I would hope to think that IETF could potentially host dudle, from
> TU-Dresden (https://dudle.inf.tu-dresden.de).  It’s an open source tool
> that allows the creation of polls just like Doodle.
>
> Secondly, and more ambitiously, I was looking at tools like Doodle
> Premium, TimeBridge, WhenIsGood, and ScheduleOnce which allow calendar
> integration from user calendars (e.g. Exchange, Google, Apple Calendar,
> …) and helps in scheduling.
>

FYI there is an effort underway to create a standards based calendaring 
feature based on the IETF's existing iCalendar standard (RFC5545). This 
effort involves a new iCalendar component type: "VPOLL" - 
<http://tools.ietf.org/html/draft-york-vpoll-02> (currently expired mostly 
because authors are concentrating on the existing Calsify WG work). The 
idea of VPOLL is to allow for regular scheduling messaging to convey poll 
information directly to users' calendar clients so that polls can be 
"overlaid" on top of their existing calendars making it easier to reply (or 
even having those clients auto-respond or at least fill out likely 
responses). There are already a couple of experimental implementations. 
This recognizes the fact that, in spite of having the ability to lookup 
free busy time sing iCalendar, the reality is that a poll-based solution is 
often better and quicker at homing in on a meeting time and it makes sense 
to standardize that process.

-- 
Cyrus Daboo

---

From: Michael Richardson <[email-masked]>
Date: Thu, 20 Nov 2014 14:04:29 -0500

Ted Lemon <[email-masked]> wrote:
    > A privacy-preserving system for sharing calendars would really be nice.
    > Unfortunately I don't think these sites would work--I couldn't use them
    > even if I weren't concerned about privacy because I'd have to hand them
    > the keys to my corporate email/calendar account.   This is definitely
    > an interesting problem.  :) 

not necessarily the "keys"; 
    - doodle is happy to use OAUTH to access, if you want it to be able to
      write back to your account the results, and let you see things.

    - you can give it a basic freebusy .ics file to sync against, which is
      enough for you to see when you might be available.

It might be that some of these features moved from Basic to Premium; I signed
up 2 years ago or so, so I wouldn't know.

I haven't looked at the other options.

-- 
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Michael Richardson <[email-masked]>
Date: Thu, 20 Nov 2014 14:06:11 -0500

Cyrus Daboo <[email-masked]> wrote:
    > <http://tools.ietf.org/html/draft-york-vpoll-02> (currently expired
    > mostly because authors are concentrating on the existing Calsify WG
    > work). The idea 
    > of VPOLL is to allow for regular scheduling messaging to convey poll

cool...  are the doodle/timebridge/whenisgood/... peope involved?

-- 
]               Never tell me the odds!                 | ipv6 mesh networks [ 
]   Michael Richardson, Sandelman Software Works        | network architect  [ 
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [