Subject: setting a goal for an inclusive IETF

From: Jari Arkko <[email-masked]>
Date: Tue, 30 Jul 2013 15:53:17 +0200

We have discussed diversity at the IETF at length. Yesterday, Pete Resnick and I wrote an article about what we think the goal for the IETF should be, as well as listing some of the early activities that we have taken at the IETF. Our goal is making the IETF more inclusive for everyone who needs to be working on Internet standards. We are at the beginning, however, and a lot of work remains ahead. Here's the article:

http://www.ietf.org/blog/2013/07/a-diverse-ietf/

Also, I wanted to let everyone know that tomorrow in the Administrative Plenary, Kathleen Moriarty and Suresh Krishnan will be talking about what they have uncovered so far in their efforts in the diversity design team. I'm looking very much forward to their report. Their efforts will help us understand where we have room to improve - often by much :-) - and what kinds of actions we can take to improve our inclusiveness.

Jari

---

From: Arturo Servin <[email-masked]>
Date: Tue, 30 Jul 2013 16:25:25 +0200

Jari, Peter

	Thanks for the article. It is really welcomed to see that "diversity"
is something that the IETF is taking really seriously.

	Now, something general related to the blog. Perhaps it would be good to
enable comments, isn't it?

	I think that it would be good to interact there instead of here. One of
the values of this list is to have important topics, In general
blog-comments do not reach that level of importance, although it is
important to comment about the topic somewhere.

Thanks,
as

---

From: Jari Arkko <[email-masked]>
Date: Tue, 30 Jul 2013 16:34:02 +0200

> enable comments, isn't it?

Yes, that has been issue that has bugged me as well. The IT team tells me that it is problematic from a spam perspective, and they do not want me spending my time approving/removing comments. I don't have practical experience if that's a real issue on this platform (WordPress), though in other similar arrangements it has not been a big problem in my experience. Maybe the IETF community has some advice to us on this...

Jari

---

From: Arturo Servin <[email-masked]>
Date: Tue, 30 Jul 2013 16:40:42 +0200

Captchas? Recaptchas?

    Also, AFAIK WordPress has some good anti-spam add-ons.

Regards,
as

---

From: Peter Saint-Andre <[email-masked]>
Date: Tue, 30 Jul 2013 16:42:38 +0200

> Also, AFAIK WordPress has some good anti-spam add-ons.

Yes, Akismet helps a lot.

But this is probably a better topic for the tools-discuss list, eh? ;-)

Peter

- -- 
Peter Saint-Andre
https://stpeter.im/

---

From: joel jaeggli <[email-masked]>
Date: Tue, 30 Jul 2013 16:44:04 +0200

>     Also, AFAIK WordPress has some good anti-spam add-ons.
the obvious one is simply a requirement to use your ietf tools
credientials to post.

---

From: Arturo Servin <[email-masked]>
Date: Tue, 30 Jul 2013 16:44:38 +0200

> But this is probably a better topic for the tools-discuss list, eh? ;-)
Peter,

    I thought it was another not-technical reason. Now that is clear,
let's move on.

    Thanks for the quick reply.

/as

---

From: Peter Saint-Andre <[email-masked]>
Date: Tue, 30 Jul 2013 17:17:13 +0200

> Thanks for the quick reply.

Two issues here:

(1) do we want comments? seems like a topic for [email-masked]

(2) if we want comments, how do we handle it? seems like a topic for
[email-masked]

Peter

- -- 
Peter Saint-Andre
https://stpeter.im/

---

From: SM <[email-masked]>
Date: Tue, 30 Jul 2013 08:47:33 -0700

Hi Jari, Pete,
At 06:53 30-07-2013, Jari Arkko wrote:
>We have discussed diversity at the IETF at length. Yesterday, Pete 
>Resnick and I wrote an article about what we think the goal for the 
>IETF should be, as well as listing some of the early activities that 
>we have taken at the IETF. Our goal is making the IETF more 
>inclusive for everyone who needs to be working on Internet 
>standards. We are at the beginning, however, and a lot of work 
>remains ahead. Here's the article:

I agree that the word "diversity" is a catch phrase.

There was an exchange between Leaf Yeh and Ted Hardie on this mailing 
list.  It is encouraging to see people from different sides of the 
world having an exchange of opinions.

It's been one IETF meeting since several women spoke at the 
microphone during the plenary.  There aren't that many people from 
different countries speaking at the microphone during a plenary.

I have one question.  The subject line says "setting a goal".  How 
would you assess the results?  Please note that I am not asking about 
how to measure the results.

Regards,
-sm

---

From: Keith Moore <[email-masked]>
Date: Tue, 30 Jul 2013 17:54:45 +0200

> Also, I wanted to let everyone know that tomorrow in the Administrative Plenary, Kathleen Moriarty and Suresh Krishnan will be talking about what they have uncovered so far in their efforts in the…

This is something that I've struggled with for years.   A big part of the "problem" (from one point-of-view) is that we've become so geographically diverse in our choice of meeting sites that we've drastically raised the cost of attending meetings on a regular basis - everyone has to travel a lot to so (though people in North America still have an easier time of it).   And while there are clearly things that could be done to reduce meeting costs, we'd be doing very well to reduce total trip cost by more than say 15%.

But earlier today I realized that the problem isn't just the cost of attending meetings - it's the value that we get in return for those meetings.   I've been taking notes about how ineffectively we use our meeting time.   Most of what I've observed won't surprise anybody, but here's a summary:

WG meeting sessions aren't scheduled to encourage discussion, but to discourage it.   At meeting after meeting, in several different areas, I see the lion's share of the time devoted to presentations rather than discussion. 

Similarly, WG meetings generally aren't run in such a way to facilitate discussion, but to discourage it.  It's only Tuesday afternoon and I've already lost count of how many times I've heard a meeting chair tell people that they have to stop discussing things because there are more presentations to do.

Rooms are set up not to facilitate discussion, but to discourage it.   The lights are dim, the chairs are facing forward rather than other participants, the projector screen (not the person facilitating a discussion, even if someone is trying to facilitate a discussion) is the center of attention.    The chairs are set so close together and with so few aisles that it's hard for most of the attendees to get to the mics.   The "microphone discipline" which was intended to facilitate remote participation ends up making discussion more difficult for everybody who has paid to be on site. 

In the vast majority of WG sessions, everyone has his nose in a laptop.   (me included).   This is because the information being presented at the moment is generally not valuable enough to occupy the attendees' attention.  The attendees are there for one of two reasons - either they're just trying to absorb some low-value information while still doing something else that is more useful, or they're waiting for some opportunity to actually interact - either within the context of that WG meeting or afterward (perhaps because the best way to catch a particular person is often to show up at a WG meeting that that person is attending.)

All of these things have been standard practice, in IETF and elsewhere, for so long, that hardly anyone questions them.   They have to be that way because they're habit, and even if one or two people try to change things (and I realize some ADs are trying), they have to contend with the mindless habit-driven decisions of everyone else involved.

Well, please excuse my candor, but f*ck habit.   We can't be effective engineers if we let bad habits continue to dictate how we work.

------

My expenses for this meeting are around USD 2.500.   Some are paying more, some less, but if we multiply average expense times the number of people attending, that's a tremendous amount of money.   Add that value is dwarfed by the value of the people's time that is being spent here.

We are spending this time to travel to meet face-to-face, not so that we can see PowerPoint all day for a week, but so we can interact.   Presentations, for the most part, do not help.   They get in the way.

Visual aids can help to facilitate a discussion, but they should be as brief as possible, and the room setup, meeting schedule, etc. should not be optimized for the visual aids.   They should be optimized for discussion.

For 80% of most WG meetings, the lights should be bright, the participants should face each other.   If there's a person facilitating the discussion that person should be the center of attention.    If we're going to use microphones, the rooms should be set up to allow everyone in the room to have easy access to them.   We should have several microphones, again facing each other, so that several people can have a conversation without everyone having to queue up.

And maybe, in addition, we need to provide better places for people to hang out and work while trying to get an opportunity to interact with specific people.   The terminal rooms are generally placed in out-of-the-way corners, but the most effective places to interact with people are in the hallways.

Keith

---

From: Michael Richardson <[email-masked]>
Date: Tue, 30 Jul 2013 12:10:53 -0400

Keith Moore <[email-masked]> wrote:
    > But earlier today I realized that the problem isn't just the cost of attending
    > meetings - it's the value that we get in return for those meetings.   I've been
    > taking notes about how ineffectively we use our meeting time.   Most of what
    > I've observed won't surprise anybody, but here's a summary:

Thanks for this.

    > Rooms are set up not to facilitate discussion, but to discourage it.   The
    > lights are dim, the chairs are facing forward rather than other participants,
    > the projector screen (not the person facilitating a discussion, even if someone
    > is trying to facilitate a discussion) is the center of attention.    The chairs
    > are set so close together and with so few aisles that it's hard for most of the
    > attendees to get to the mics.   The "microphone discipline" which was intended
    > to facilitate remote participation ends up making discussion more difficult for
    > everybody who has paid to be on site.

I think that these physical things are something that we can do some
experiments about.

    > Well, please excuse my candor, but f*ck habit.   We can't be effective
    > engineers if we let bad habits continue to dictate how we work.

I agree.

    > For 80% of most WG meetings, the lights should be bright, the participants
    > should face each other.   If there's a person facilitating the discussion that
    > person should be the center of attention.    If we're going to use microphones,
    > the rooms should be set up to allow everyone in the room to have easy access to
    > them.   We should have several microphones, again facing each other, so that
    > several people can have a conversation without everyone having to queue up.

Can we please try this in Vancouver?
This would work especially well for BOFs.
Maybe we can start there.
Chairs will need training as *facilitators*

    > And maybe, in addition, we need to provide better places for people to hang out
    > and work while trying to get an opportunity to interact with specific people.
    > The terminal rooms are generally placed in out-of-the-way corners, but the most
    > effective places to interact with people are in the hallways.

I agree.

--
]               Never tell me the odds!                 | ipv6 mesh networks [
]   Michael Richardson, Sandelman Software Works        | network architect  [
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [

--
Michael Richardson <[email-masked]>, Sandelman Software Works

---

From: Yoav Nir <[email-masked]>
Date: Tue, 30 Jul 2013 16:32:44 +0000

> Chairs will need training as *facilitators*

The IETF is not tasked with inventing "discussion" or even "collaborative design". This things already exist, and we can maybe look around and see what works in other places. Many of us work for vendors or other groups where designs are created in collaboration. At least where I work now, we don't do design by facing forward while someone presents. The usual way is 2-4 people standing next to a whiteboard drawing stuff. Photographing the whiteboard with a smartphone has become a new addition, and using a flip-chart is a fine variation. There are the larger design meetings (usually attended by a manager, some QA people, a technical documenter, and other "stakeholders"). Those tend to have some slides, but the whiteboard is still there and people generally sit around a table. 

Even those larger meetings rarely go over 10-12 people. This experience doesn't transfer well to working groups with 50-100 participants, some of which are remote. So what is one to do?

Well, one option is to move most of the discussion out of these "main events". Sure, you can still have small design sessions at an IETF meeting, but I think the bulk of the documents that we work on have less than 12 people actively working on them (yes, http/2.0 is an outlier here). These people can meet often virtually, and there are several tools that allow these virtual interim meetings that even allow you to shared a whiteboard. 

The results of such meetings can and should be reported to the WG mailing list for feed-back, and then we can have real presentations at the face-to-face meetings, where we solicit comments by those who are not part of the core group, and are not following closely. I just don't believe in effective discussion among a group of 50-100 people. The best we can hope for is a Q&A session with the design team. If you want another example of an ineffective discussion in a group of 100+ people, just take a look at your local parliament / congress. There's a reason why all of them have formed committees, and why the executive branch has usurped much of their power in many countries. Trying to force such a body to effective discussion will not work.

Yoav

---

From: Donald Eastlake <[email-masked]>
Date: Wed, 31 Jul 2013 04:30:26 -0400

The most valuable part of IETF meeting is and has always been the hall
conversations and side meetings

Thanks,
Donald
=============================
 Donald E. Eastlake 3rd   +1-508-333-2270 (cell)
 155 Beaver Street, Milford, MA 01757 USA
 [email-masked]

---

From: Michael Richardson <[email-masked]>
Date: Wed, 31 Jul 2013 05:08:57 -0400

> conversations and side meetings

So that implies to me that we should use our session time extremely
efficiently, always finish sessions early (to facilitate time for ad-hoc
conversations), and that the number of simultaneous sessions should be
reduced so that people have more free time.

We should in fact discourage discussions at the mic, because they take up
time.  Maybe only have presentations, and prepared written questions?

(What a curious email address. Is it code, or is it just all the good ones
were taken?)

---

From: Abdussalam Baryun <[email-masked]>
Date: Wed, 31 Jul 2013 12:50:46 +0100

I agree with some of your points, thanks, comments below,

On Tue, Jul 30, 2013 at 4:54 PM, Keith Moore <[email-masked]>wrote:

> Also, I wanted to let everyone know that tomorrow in the Administrative
> Plenary, Kathleen Moriarty and Suresh Krishnan will be talking about what
> they have uncovered so far in their efforts in the diversity design team.
> I'm looking very much forward to their report. Their efforts will help us
> understand where we have room to improve - often by much :-) - and what
> kinds of actions we can take to improve our inclusiveness.
>
> This is something that I've struggled with for years.   A big part of the
> "problem" (from one point-of-view) is that we've become so geographically
> diverse in our choice of meeting sites that we've drastically raised the
> cost of attending meetings on a regular basis - everyone has to travel a
> lot to so (though people in North America still have an easier time of it).
>   And while there are clearly things that could be done to reduce meeting
> costs, we'd be doing very well to reduce total trip cost by more than say
> 15%.
>
> But earlier today I realized that the problem isn't just the cost of
> attending meetings - it's the value that we get in return for those
> meetings.   I've been taking notes about how ineffectively we use our
> meeting time.   Most of what I've observed won't surprise anybody, but
> here's a summary:
>
> WG meeting sessions aren't scheduled to encourage discussion, but to
> discourage it.   At meeting after meeting, in several different areas, I
> see the lion's share of the time devoted to presentations rather than
> discussion.
>
> Similarly, WG meetings generally aren't run in such a way to facilitate
> discussion, but to discourage it.  It's only Tuesday afternoon and I've
> already lost count of how many times I've heard a meeting chair tell people
> that they have to stop discussing things because there are more *
> presentations* to do.
>

I think I was told that IESG is in charge of management of the meeting, so
we should ask it to clarify its position, WHY it was done that way?
However, I mentioned that time management was not done well in MANET WG in
previous meetings but no one cares of my comments. I hope your will get
through to IESG.

> lights are dim, the chairs are facing forward rather than other
> participants, the projector screen (not the person facilitating a
> discussion, even if someone is trying to facilitate a discussion) is the
> center of attention.    The chairs are set so close together and with so
> few aisles that it's hard for most of the attendees to get to the mics.
> The "microphone discipline" which was intended to facilitate remote
> participation ends up making discussion more difficult for everybody who
> has paid to be on site.
>

I mentioned before that I was discouraged while I was remote participant,
but seems like even some f2f participants get that feelings from time to
time. The management of meetings should respond to your comments (not a
person but the body, which I expect IESG).

>
> In the vast majority of WG sessions, everyone has his nose in a laptop.
> (me included).   This is because the information being presented at the
> moment is generally not valuable enough to occupy the attendees' attention.
>  The attendees are there for one of two reasons - either they're just
> trying to absorb some low-value information while still doing something
> else that is more useful, or they're waiting for some opportunity to
> actually interact - either within the context of that WG meeting or
> afterward (perhaps because the best way to catch a particular person is
> often to show up at a WG meeting that that person is attending.)
>

I usually will blame the IETF chairs to do better attraction to
participants including remote ones on jabber.

>
> All of these things have been standard practice, in IETF and elsewhere,
> for so long, that hardly anyone questions them.   They have to be that way
> because they're habit, and even if one or two people try to change things
> (and I realize some ADs are trying), they have to contend with the mindless
> habit-driven decisions of everyone else involved.
>

We can change meetings management, and I don't think there is a standard
practice for management of this meeting and others. We need an RFC for how
to best manage the meeting, which can update from time to time, however, I
mentioned to the venue selectors to be involved because selecting venue
affects the meeting management capacity.

> engineers if we let bad habits continue to dictate how we work.

You keep repeating habit as it is not good, but I think we need it, but we
need management to make people's habit in the direction of the IETF habits
:-)

AB

>
> ------
>
>
> My expenses for this meeting are around USD 2.500.   Some are paying more,
> some less, but if we multiply average expense times the number of people
> attending, that's a tremendous amount of money.   Add that value is dwarfed
> by the value of the people's time that is being spent here.
>
> We are spending this time to travel to meet face-to-face, not so that we
> can see PowerPoint all day for a week, but so we can interact.
> Presentations, for the most part, do not help.   They get in the way.
>
> Visual aids can help to facilitate a discussion, but they should be as
> brief as possible, and the room setup, meeting schedule, etc. should not be
> optimized for the visual aids.   They should be optimized for discussion.
>
> should face each other.   If there's a person facilitating the discussion
> that person should be the center of attention.    If we're going to use
> microphones, the rooms should be set up to allow everyone in the room to
> have easy access to them.   We should have several microphones, again
> facing each other, so that several people can have a conversation without
> everyone having to queue up.
>
> And maybe, in addition, we need to provide better places for people to
> hang out and work while trying to get an opportunity to interact with
> specific people.   The terminal rooms are generally placed in
> out-of-the-way corners, but the most effective places to interact with
> people are in the hallways.
>
>
> Keith
>
>

---

From: Abdussalam Baryun <[email-masked]>
Date: Wed, 31 Jul 2013 12:59:44 +0100

I think *side meetings* are killing IETF, I call it *hidden meetings*,
there is no input for IETF when we have side meetings. The input to IETF in
through meeting sessions and discussion lists. So I agree with Keith that
meeting sessions have low discussions, and may discourage remote
participants to discuss as well.

I think why you feel that side meetings are valuable, is because it has
short presenting, each person talks for less than 5 minutes and discussion
time is interesting. So you and Keith seem to be having same aim to exclude
long presentations of issues. Furthermore, I will add that we need not to
only ask questions and discuss with the authors/presenters, we should be
discussing to the IETF WG with the meeting. This way the habit will be not
boring and ALL will be attracted.

AB

On Wed, Jul 31, 2013 at 9:30 AM, Donald Eastlake <[email-masked]> wrote:

> participants,

---

From: Barry Leiba <[email-masked]>
Date: Wed, 31 Jul 2013 10:00:39 -0400

> I think *side meetings* are killing IETF, I call it *hidden meetings*, there
> is no input for IETF when we have side meetings. The input to IETF in
> through meeting sessions and discussion lists.

I have no argument with your last sentence; it's absolutely correct.

But I think you misunderstand the point Donald is making about things
such as small hallway conversations.

Example: A few people get together in a corner and one says, "About
that point I made on the list that you brushed off... here's what I'm
talking about:", and five or ten minutes of discussion ensues.  At the
end, either the guy with the point now understands why he's wrong (or
why his point isn't practical), or the document editor says, "OK, I
get your point now.  Let me work up some proposed text and post it to
the list."

Example: A few people get together during a session time they have
free, and they bash out some text to resolve an issue that came up.
They come to the working group meeting session with an explanation of
their conversation and the proposed text, and it's discussed in the
meeting session (and posted to the list afterward).

Example: Someone has an idea for a new document or other new work, so
he gathers some people to have breakfast one morning, explains his
idea, bashes it around with his colleagues, and as a result of that
breakfast chat he goes home after the IETF meeting and writes up an
Internet Draft.

None of this is hidden; none of this is secret.  It's all the way work
gets done efficiently: a small group of people crack some tough nuts,
and present the results to a wider audience.

Barry

---

From: Keith Moore <[email-masked]>
Date: Wed, 31 Jul 2013 16:24:11 +0200

> conversations and side meetings

The hall conversations and side meetings will continue to be immensely valuable.   But working group sessions can, and should, also be valuable. 

This gets back to my original point, which is that if we want to encourage broader participation in IETF we need to make participation in IETF work the participants' time and money.

Also, if we help working group sessions make better use of their time, WGs will reach closure more quickly.   Hardly anybody, I suspect, would mind that.

Keith