Subject: Re: Last Call: <draft-bormann-cbor-04.txt> (Concise Binary Object Representation (CBOR)) to Proposed Standard

From: Zach Shelby <[email-masked]>
Date: Sun, 28 Jul 2013 16:30:25 +0200

I have reviewed this version of the CBOR draft, and am fully supportive of this as a proposed standard. 

For IoT applications over CoAP and other protocols, there is a clear need for a standard binary object representation with a straightforward mapping to JSON that is suitable for constrained devices and networks. This is it. I have not yet implemented CBOR, but plan to do so for use with several commercial CoAP implementations. Furthermore, JSON based formats used in this field such as SenML, or standards from other SDOs like OMA Lightweight M2M that use JSON, will clearly benefit from standardising CBOR.  

I found the document to be well written and concise.

Zach Shelby

On Jul 16, 2013, at 9:58 PM, The IESG <[email-masked]> wrote:

> 
> The IESG has received a request from an individual submitter to consider
> the following document:
> - 'Concise Binary Object Representation (CBOR)'
>  <draft-bormann-cbor-04.txt> as Proposed Standard
> 
> The IESG plans to make a decision in the next few weeks, and solicits
> final comments on this action. Please send substantive comments to the
> [email-masked] mailing lists by 2013-08-13. Exceptionally, comments may be
> sent to [email-masked] instead. In either case, please retain the
> beginning of the Subject line to allow automated sorting.
> 
> Abstract
> 
> 
>   The Concise Binary Object Representation (CBOR) is a data format
>   whose design goals include the possibility of extremely small code
>   size, fairly small message size, and extensibility without the need
>   for version negotiation.  These design goals make it different from
>   earlier binary serializations such as ASN.1 and MessagePack.
> 
> 
> 
> 
> The file can be obtained via
> http://datatracker.ietf.org/doc/draft-bormann-cbor/
> 
> IESG discussion can be tracked via
> http://datatracker.ietf.org/doc/draft-bormann-cbor/ballot/
> 
> 
> No IPR declarations have been submitted directly on this I-D.
> 
> 

-- 
Zach Shelby, Chief Nerd, Sensinode Ltd.
http://www.sensinode.com @SensinodeIoT
Mobile: +358 40 7796297
Twitter: @zach_shelby
LinkedIn: http://fi.linkedin.com/in/zachshelby
6LoWPAN Book: http://6lowpan.net

---

From: Andrew Mcgregor <[email-masked]>
Date: Sun, 28 Jul 2013 10:19:55 -0700

I have reviewed the -03 version of this draft, and I support this as a
proposed standard.

As an exercise for review, I implemented a large part of the draft (in
plain Python) and found the description completely adequate to produce
working code that parsed the examples in the draft correctly, and could
generate many of them.

On 28 July 2013 07:30, Zach Shelby <[email-masked]> wrote:

> For IoT applications over CoAP and other protocols, there is a clear need
> for a standard binary object representation with a straightforward mapping
> to JSON that is suitable for constrained devices and networks. This is it.
> I have not yet implemented CBOR, but plan to do so for use with several
> commercial CoAP implementations. Furthermore, JSON based formats used in
> this field such as SenML, or standards from other SDOs like OMA Lightweight
> M2M that use JSON, will clearly benefit from standardising CBOR.
>

-- 
Andrew McGregor | SRE | [email-masked] | +61 4 8143 7128

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Sun, 28 Jul 2013 22:54:36 -0400

The question I want an answer to is whether this is going to be the only
standard for a binary version of JSON allowed.

I have an alternative proposal which is designed to be compatible with JSON
so that existing encoder and decoder implementations can be used and so
that a single decoder can handle the binary features as a superset of the
existing JSON specification.

http://tools.ietf.org/html/draft-hallambaker-jsonbcd-00

What is the process here?

So far I have been led to believe that this is a personal submission that
is not going to be the last chance we get to discuss this in IETF. Now I
see it being a proposed standard. And I am pretty sure that people are
going to be telling other people that this is the agreed IETF standard that
we all have to use because it is what was decided.

There are existing specs that does what CBOR does just as well that have
actual users. There are requirements that the individuals proposing this
chose not to address.

-- 
Website: http://hallambaker.com/

---

From: Peter Saint-Andre <[email-masked]>
Date: Mon, 29 Jul 2013 12:06:18 +0200

> standard for a binary version of JSON allowed.

That is certainly not what I heard during the APPSAWG session this
morning: the intent is that this be one format among many.

Peter

-- 
Peter Saint-Andre
https://stpeter.im/