Subject: Invitation to request an IETF mentor

From: IETF Chair <[email-masked]>
Date: Wed, 17 Jul 2013 15:58:41 -0700

All,

During IETF 87 in Berlin, we will be running a trial of the IETF Mentoring Program. The goal of the IETF Mentoring Program is to match people new to the IETF (people who have participated in three or fewer face-to-face meetings or anyone registering as a student) with experienced IETF mentors. As a mentoring participant, your mentor will personally introduce you to the IETF community, help you find your way around the IETF & the meeting, explain things, and introduce you to other attendees you might like to meet. Basically, your mentor will be your personal buddy during the meeting week, and possibly afterwards.

The IETF Mentoring Program was created to help new IETF participants to get up to speed rapidly and help them begin to contribute to the IETF quickly and easily.  If you wish to participate in the IETF Mentoring Program, you can follow the sign-up procedures described in the program FAQ:

https://www.ietf.org/resources/mentoring-program.html

After you follow the sign-up procedure, we will then introduce you to each other by email, and invite you to meet up in person at the IETF Meet & Greet event on Sunday afternoon in Berlin. From there on, you and your mentor decide on when and where to meet during the rest of the week and afterwards.

You are of course free to withdraw from the program at any time and for any reason, no questions asked, should a need arise. But I sincerely believe the IETF Mentoring Program will be a great way for new participants to get introduced to the IETF by an experienced participant with matching interest.

Regards,
Jari Arkko
IETF Chair

---

From: Hector Santos <[email-masked]>
Date: Sat, 20 Jul 2013 11:47:12 -0400

Overall, I think the IETF has a marketing problem addressing its #1 
customer base - electronic participants.

I was somewhat hoping to see more done in the mentor area of assisting 
electronic participants. Of coarse, this sort of electronic mentoring it 
could include an end goal to get folks more involved with the IETF 
directly, i.e. go to meetings, become leaders, etc, but overall assist 
with protocol standards development.

I presume, the IETF gets a far more population of electronic 
participants, many who first get involved with writing I-Ds. I have 
found it to be a high hurdle to get a I-D completed, especially if you 
never attended IETF meetings or have not sent someone or group on your 
company behalf.

As I have been advised by some IETF vets, I'm sure it will help with the 
process of getting others more comfortable with you and your work, but 
is it really absolutely necessary to attend IETF meetings to get an I-D 
moved thru the process?

I guess I could of requested more IETF interest/review for particular 
I-Ds I have worked on but it would of required stepping on some toes. I 
decided to avoid contention although the help I received was an attempt 
to avoid a conflict.

Maybe I'm off-base, but it just seems the mentoring efforts is targeted 
at attracting full time IETF members, future leaders, etc and not just 
the specific technical person who might be just interested in various 
protocols of interest and no more.  Our products are internet based and 
hence has dozens of protocols implemented. I'm here really just to keep 
on top of them, assist with improvements, and if need be try to get an 
I-D written if only to prove a point or get an idea out there for 
consideration and creative synergism.  Not interested in become an IETF 
full time attendee nor "leader" per se.

The IETF needs to improved its market across the globe and that really 
can only feasibly be done electronically.  There are needs to take 
efforts of getting electronic participants more involved. I think it can 
start with first helping and mentoring I-D writers.

What generally happens when an individual I-D is submitted?   Is there 
an overseer of the submissions and decides there is something that 
interest the IETF?

Thanks

--
HLS

---

From: Brian Haberman <[email-masked]>
Date: Sun, 21 Jul 2013 08:34:27 -0400

Hi Hector,

> customer base - electronic participants.

By this term, I assume (based on later text) you mean remote participants...

> with protocol standards development.

Since this is the first time we have tried to deploy a mentoring 
program, we wanted to limit the scope to keep things manageable.  If the 
mentoring program "succeeds" in Berlin, we will examine ways of 
expanding it.

<snip>

> full time attendee nor "leader" per se.

Not at all.  The people we are targeting are the newcomers (folks who 
have attended less than 3 meetings or are registered as students).  One 
goal is to increase the number of active participants, but we are not 
turning away people with focused technical goals.

> start with first helping and mentoring I-D writers.

I believe your concerns go well beyond the scope of the mentoring 
program.  There have been discussions on how to increase the performance 
of our remote participants 
(http://www.ietf.org/mail-archive/web/ietf/current/msg77020.html).
> an overseer of the submissions and decides there is something that

No, there is no "overseer".  Each participant is free to read (and 
possibly support) any individual I-D they see published.  Typically, the 
author(s) will start by soliciting reviews of their individual I-D by 
other IETF participants.

Regards,
Brian

---

From: Pete Resnick <[email-masked]>
Date: Sun, 21 Jul 2013 08:47:38 -0500

On 7/20/13 10:47 AM, Hector Santos wrote:
> electronic participants. Of coarse, this sort of electronic mentoring 
> it could include an end goal to get folks more involved with the IETF 

I think this would be a fabulous addition to the program. As Brian said, 
the mentoring program is just getting started, so a "meeting mentor" 
seems like a good starting point, but I have had many experiences with 
new electronic participants (be it remote meeting participants or simply 
active mailing list contributors) for whom a mentor would be a great 
thing. That said, one caveat:

> As I have been advised by some IETF vets, I'm sure it will help with 
> the process of getting others more comfortable with you and your work, 
> but is it really absolutely necessary to attend IETF meetings to get 
> an I-D moved thru the process?

It's certainly not necessary to attend face-to-face to get work done, 
but it sure does help develop a rapport with people. We are all humans, 
and electronic communications (especially elusively using email) are not 
ideal for getting our points across or convincing others without some 
face-to-face interaction. I know of several folks in the community that 
come across terribly in email and, if you didn't know them offline, 
understand their communication style, and know where to look in their 
email messages for the technical content, you'd have a terrible time 
getting them to be part of a consensus process. And that's the reason 
for the caveat I mentioned above: One of the big values of a mentoring 
program is that it allows the mentor to discover the mentee's 
communication style, help them interact (in person and electronically) 
with some of our more interesting characters with their interesting 
communication styles, and help the mentee figure out how to get 
technical points across effectively. Having a mentor for someone who 
they will not meet face-to-face makes that part of the metor-mentee 
relationship much harder to develop.

Even so, I definitely think that the expansion of the program you 
suggest is a great idea. Figuring out the logistics to make it effective 
will be tricky (maybe finding a mentor who is geographically close 
enough to the mentee to make a face-to-face meeting between them 
possible), but either way I think it is well worth doing.

pr

-- 
Pete Resnick<http://www.qualcomm.com/~presnick/>
Qualcomm Technologies, Inc. - +1 (858)651-4478

---

From: Fred Baker <[email-masked]>
Date: Mon, 22 Jul 2013 06:34:36 +0200

On Jul 20, 2013, at 5:47 PM, Hector Santos <[email-masked]> wrote:

> What generally happens when an individual I-D is submitted?   Is there an overseer of the submissions and decides there is something that interest the IETF?

Hmm. Define "IETF". It is in some sense an organization (I call it a "disorganization"), and in some sense a community of people. When we talk about something being "interesting to the IETF", we're talking about it being interesting to people.

To my knowledge, no. When I see a general individual submission (of which there are more than a few; in my mirror, I have 2240 current drafts, of which the identifiers of 1729 contain the identify of a working group, and 675 are working group drafts, leaving 511 general submissions and 1054 individual submissions to various working groups), it is usually because someone brought it to my attention. In most cases, that means that they posted it without specifically targeting a working group or targeting the wrong working group, and are now shopping it around.

As a working group chair, I have mixed views on this. I'm certainly willing to look at general submissions; v6ops will discuss two of them this time around, one of which has been previously discussed in homenet and one has been discussed in RIPE. However, I have tooling to help me manage my working group that sees general submissions as noise. In the tool that updates and manages my mirror, I have another tool that notices a new -00 draft whose name contains my working group's identifier, and sends two emails, one to the working group mailer advising the group of the draft and inviting discussion, and another to the author(s) asking some pointed questions about it's applicability and charter relevance. This way, it doesn't depend on my being at the top of my game on the magic day, and it doesn't depend on the author contacting me; "I", for some value of that word, initiate the conversation upon posting of the draft. When I create my agenda, I have another tool that searches my mirror for drafts containing the identity of my working group and others I add, and sorting them into four buckets - those older than the last IETF's date and those newer, and within those, those with names that start with draft-ietf- and those that don't. Looking at https://datatracker.ietf.org/doc/search/?search_submit=&activeDrafts=on&name=v6ops&rfcs=on&sortBy=status, which also looks for my working group's identity, I then manually reclassify some of them as "in the IESG's processes" or "in the RFC Editor's queue", and searching my mail database for the draft's base name (the name less the version extension) allows me to look at the history of discussion of the specific draft. The drafts that end up on my agenda have been written or updated since the last meeting, are "in the working group", and have had supportive list discussion. Anything else is a special case - and general submissions are always special cases.

I can't speak for other chairs. I would imagine they do something similar, but the way they do it is likely different.

So, if you don't know what working group your draft might be relevant to, by all means submit it as a general submission (e.g., with a name like "draft-<topic>-nn.txt"). When you have done so, it is your job to make people that might be interested in it aware of it, and to promote discussion. If you submit an individual submission to a working group (e.g., with a name like "draft-santos-<wg>-<topic>-nn.txt"), the secretariat does not announce it to the working group, but the working group chair should notice it at some point. You are well advised to send a note to the working group mailer promoting discussion. The only drafts that are automatically announced are working group drafts (e.g., with a name like "draft-ietf-<wg>-<topic>-nn.txt"). 

By the way, if you submit draft-<topic>-00.txt and subsequently submit draft-santos-<wg>-<topic>-00.txt, or submit draft-santos-<wg>-<topic>-nn.txt and subsequently submit draft-ietf-<wg>-<topic>-00.txt, or in general change the name of a draft, working group chairs appreciate your note to [email-masked] noting that "draft <this> replaces draft <that>". It helps us track drafts, and know what's on our plate and what isn't.

As a matter of statistics, since March 11 and coming into IETF 87, we have had 704 new (-00) Internet Drafts, of which 129 have been working group drafts, 374 have been individual submissions to working groups, and (the difference) 201 have been general submissions. For IETF 86, the submission breakout by month was:

                     individual
                     submission
                        to
          working     working     general
           group       group
    Nov     19          45          27
    Dec     19          39          19
    Jan     11          37          35
    Feb     27         185          49
    Mar      0           0           2

Which is to say that the vast majority of new drafts arrived more or less in a block in February, and they were by and large individual submissions to working groups. Oh, you wanted commentary, and you thought it was going to magically happen? How many of those new drafts did you notice and comment on? The IETF is, in this context, a community of people that read and comment on drafts...

Please note, all of that is about -00 drafts; I didn't look at updated drafts, which would be about 2/3 of drafts at any given time.

The best analogy to describe this, perhaps, is a news boy in Time Square, Trafalgar Square, or your favorite counterpart. You have a new idea or comment, and it might be a very useful or important one. The square is noisy, and there are a lot of people with comments that they think are important. We depend on crowd sourcing. If a lot of people say "hey, this is interesting, we should discuss it", we discuss it. If that doesn't happen... It's not because we like you, or we don't like you. It's not about you, or where you come from, or whatever. It's about whether your comment rises above the din. Trust me, area directors and working group chairs do what they do, and are chosen to do what they do, because they are interested, not because they want to prevent progress. If you make a comment, think about what mailers or people it might be appropriate to, and if that means creating a new working group or mailer context, so be it, think about the area it belongs in and what area director might take you where you want to go. Communities interested in a topic get attention. Create or contribute to one.

---

From: Jari Arkko <[email-masked]>
Date: Mon, 22 Jul 2013 16:07:30 +0300

Hector,

You raise an important point - and one that isn't just about mentoring, but the overall approach in our ability to involve more remote participation. We have and will continue to improve the facilities to improve the remote participation experience. Looking back, one big change in the way of working at the IETF in the last couple of years has been that many working groups have virtual meetings. Not so much as a replacement of the physical meetings, but as a place to do the day-to-day or month-to-month work. Like you, I believe the future is in over-the-Internet collaboration :-) Though as in any human interaction the physical meeting still have a place as well… And the success of the IETF depends on the ease of bringing good ideas here and getting them adopted. Including the ability to start things without always having to wait for a meeting and attending it physically.

It is true that the mentoring trial is more focused on the participants in the meeting. See the response from Brian. Perhaps it would be useful to consider extending it in the future to cover those who are doing work in some of our working groups but not attending the meetings. But I do think that the mentor program is focused on making people capable of getting their work done at the IETF, including both those who might spend a large part of their day with it as well as those with a narrower interest in a specific topic. It is always useful to understand the process and get to know others involved in it. As you know, most Internet technology efforts will in any case involve multiple aspects, such as the functionality itself, operations, security, etc.

As for your questions about individual I-Ds, the answer is that usually nothing happens on its own. Whether you are on site or attending remotely or just participating in mailing list discussions, the procedure is the same. The IETF is about standards, and standards are about groups of people agreeing to some common ideas. In order to make this happen, you need to find your group of like-minded people who have an interest in achieving something similar. Usually you find this from your colleagues in other organisations, from others in hallway discussions, or by sending a proposal to a working group and getting others interested in it. Ultimately, a proposal has to be brought formally to a working group or a new working group charted for the work. If adopted, it will be worked on and eventually comes out as an RFC.

Any of the above things - starting new work, talking about I-Ds, finding like-minded people can and has been done remotely. Although there are some things that are easier when you are there in person. As a result, most IETF work involves some amount of activity in the physical meetings. I'd love to see ideas on how we can make it easier for people to participate without necessarily attending the meetings.

Jari