Subject: Re: RFC 6234 code

From: Tony Finch <[email-masked]>
Date: Mon, 1 Jul 2013 10:22:36 +0100

Riccardo Bernardini <[email-masked]> wrote:
>
> This came to my mind while reading: why not embedding the archive in
> the text with some special "line header" that makes automatic
> extraction possible?

Like RCF 6716.

Tony.
-- 
f.anthony.n.finch  <[email-masked]>  http://dotat.at/
Forties, Cromarty: East, veering southeast, 4 or 5, occasionally 6 at first.
Rough, becoming slight or moderate. Showers, rain at first. Moderate or good,
occasionally poor at first.

---

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Mon, 1 Jul 2013 11:14:33 +0000

That's 20 minutes per person of course.

-- 
Christopher Dearlove
Senior Principal Engineer, Communications Group
Communications, Networks and Image Analysis Capability
BAE Systems Advanced Technology Centre
West Hanningfield Road, Great Baddow, Chelmsford, CM2 8HN, UK
Tel: +44 1245 242194 |  Fax: +44 1245 242124
[email-masked] | http://www.baesystems.com

BAE Systems (Operations) Limited
Registered Office: Warwick House, PO Box 87, Farnborough Aerospace Centre, Farnborough, Hants, GU14 6YU, UK
Registered in England & Wales No: 1996687

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Joe Abley
Sent: 28 June 2013 21:41
To: Paul Hoffman
Cc: John C Klensin; RFC Interest; [email-masked] list
Subject: Re: RFC 6234 code

----------------------! WARNING ! ----------------------
This message originates from outside our organisation,
either from an external partner or from the internet.
Keep this in mind if you answer this message.
Follow the 'Report Suspicious Emails' link on IT matters
for instructions on reporting suspicious email messages.
--------------------------------------------------------

On 2013-06-28, at 15:19, Paul Hoffman <[email-masked]> wrote:

> The RFC Editor is publishing code in a text file that is formatted like an RFC. The proposal is for the RFC Editor to publish *the exact same code* in a file without the RFC wrapping.
> 
> If you really think you see a legal difference in doing the second, fine; I propose that you are just searching for problems that do not exist.

Quite possibly they don't, and I'm not presuming to talk for John. But the vague thoughts that crossed my mine were the issues that allowed Phil Zimmerman to publish PGP source code in book form and avoid conviction for munitions export without a licence.

Perhaps this is no longer an issue in the US following Bernstein vs. United States and Junger vs. Daley.

Just thinking aloud, really.

I will observe that far more than 20 minutes of combined person-minutes have been consumed by this thread already, and the approach of minimum collective effort is still "scrape the code from the RFC yourself and compile it".

Joe
********************************************************************
This email and any attachments are confidential to the intended
recipient and may also be privileged. If you are not the intended
recipient please delete it from your system and notify the sender.
You should not copy it or use it for any purpose nor disclose or
distribute its contents to any other person.
********************************************************************