Subject: Re: draft-housley-two-maturity-levels

From: [email-masked] (Scott O. Bradner)
Date: Mon, 25 Oct 2010 22:48:11 -0400 (EDT)

> I'd like to hear from the community about pushing forward with this
> proposal or dropping it

I do not think this proposal fixes any known problems

the major reason (imo) that technology is not advanced along the
standards track is because there is no need to do so.  

someone labors for a while to get a proposed standard published and
people start to use it (if they did not start at the Internet Draft stage)
soon about anyone that has a need for the technology has implemented it and 
it is being used by customers all over the globe

just what is the reason that someone would take time from working on new 
technology to do the work to advance the proposed standard?  it is unlikely 
that all that many more people will implement or use the technology
so what is the point?

in addition, the IESG acts as if the proposed standard will be the last step
in the publication process (or at least reviews IDs as if this were the case)
so we have all the benefits of the cross area review (this making the proposed standards 
about as good as one could without requiring interoperable implementations at the
first stage (i.e. bringing back running code))

so I say drop it and live with the fact that rfc 2026 does not paint an accurate
picture of the current one step standard process

Scott

---

From: "Bert (IETF) Wijnen" <[email-masked]>
Date: Tue, 26 Oct 2010 10:16:14 +0200

Although I do sort of also agree with Scott, I think it is one step in the right
direction. So please seen a sponsor and get it published.

Bert

On 10/26/10 4:48 AM, Scott O. Bradner wrote:
> _______________________________________________
> Ietf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf
>

---

From: Eric Burger <[email-masked]>
Date: Tue, 26 Oct 2010 06:11:54 -0400

The known problem is it takes well over four years to get anything published.

I am experiencing in one never-ending saga the logical conclusion of the logic: since Proposed Standard is the new Draft Standard, and since the IESG has to make sure any proposal is beyond bullet-proof, the industry has long since implemented draft-mumble-21, which has not changed for over a year, and few in industry cares if the document publishes as an RFC, because from their point of view, if something has been working in the field for three years, has 18 independent implementations, and has not yet crashed the Internet, it is probably ready, whether the IETF formally says so or not. That is the fast track to making the IETF irrelevant.

The very real danger here is while that attitude may be OK for a small media application, that attitude could be a disaster in, for example, the routing area. Something really has to be done.

Now, I do agree with Scott here there is absolutely no incentive for anyone to bring a protocol to Draft/Internet Standard level.

What I *am* hoping is that with two, clearly defined maturity levels, we can go back to publishing Proposed Standards in about a year, and have Internet Standard mean something. Otherwise, we will be perpetually running the Internet on Internet Drafts, which is something I do not think anyone really can say is a good thing.

---

From: Russ Housley <[email-masked]>
Date: Tue, 26 Oct 2010 08:36:09 -0400

Scott:

Just to clarify, do you think that it would be better to document "one
step" or do you think that the community should not spend time on this
topic at all?

---

From: Dave CROCKER <[email-masked]>
Date: Tue, 26 Oct 2010 07:31:25 -0700

On 10/26/2010 3:11 AM, Eric Burger wrote:
> What I*am*  hoping is that with two, clearly defined maturity levels, we can
> go back to publishing Proposed Standards in about a year,

This seems to be the core idea driving support for this specification.

Unfortunately, there is nothing in the proposed change that will affect this goal.

The idea seems to be that "simplifying" the later part of the labeling model 
will somehow cause those controlling production of an initial version of a spec 
to get it produced more quickly.

It's a slightly charming idea, but it has no pragmatic, behavioral basis.

What ought to worry us about the process of adopting this change is the 
unwillingness to deal with questions and criticisms of it carefully.  Instead 
concerns have largely been ignored.

Rough consensus is important, but so is the efficacy of a spec.

We used to take "it won't work" statements seriously.

d/
-- 

   Dave Crocker
   Brandenburg InternetWorking
   bbiw.net

---

From: Julian Reschke <[email-masked]>
Date: Tue, 26 Oct 2010 16:39:55 +0200

On 26.10.2010 16:31, Dave CROCKER wrote:
> ...
> The idea seems to be that "simplifying" the later part of the labeling
> model will somehow cause those controlling production of an initial
> version of a spec to get it produced more quickly.
> ...

Maybe some of the current IESG members could offer their opinion about 
*why* the barriers for PS appear to be much higher than they used to be?

Best regards, Julian

---

From: John Leslie <[email-masked]>
Date: Tue, 26 Oct 2010 10:46:58 -0400

> The known problem is it takes well over four years to get anything

   We've actually been making progress on that, at least for the part
where the IESG is involved.

   Russ's draft _would_ reduce one issue: where a reference should be
Normative but hasn't been called out, the LastCall must be repeated.
This is an irritant, and never seems to actually change anything.

   I frankly cannot see how Russ's draft would speed the process any
other way. And I worry that changing to two levels would make folks
even more hesitant to approve Proposed Standard status. (This is more
a worry than an actual issue with what Russ's draft _says_...)

> I am experiencing in one never-ending saga the logical conclusion
> of the logic: since Proposed Standard is the new Draft Standard,
> and since the IESG has to make sure any proposal is beyond bullet-
> proof, the industry has long since implemented draft-mumble-21,
> which has not changed for over a year, and few in industry cares
> if the document publishes as an RFC, because from their point of
> view, if something has been working in the field for three years,
> has 18 independent implementations, and has not yet crashed the
> Internet, it is probably ready, whether the IETF formally says so
> or not. That is the fast track to making the IETF irrelevant.

   This is a function of WGCs worrying too much before asking the
IESG to act on Working-Group submissions. I can't see Russ's proposal
reducing that problem. :^(

   BTW, the Individual Submission route bypasses that problem, and
is being used fairly liberally. Individual Submissions _never_ take
four years (unless the submitter lost interest along the way).

> The very real danger here is while that attitude may be OK for a
> small media application, that attitude could be a disaster in,
> for example, the routing area. Something really has to be done.

   Indeed, we _have_ seen a disaster in the routing area... :^(

> Now, I do agree with Scott here there is absolutely no incentive
> for anyone to bring a protocol to Draft/Internet Standard level.

   Scott exaggerates a bit, but the incentive _is_ usually lacking.
It's the lack of incentive, combined with a belief that so-and-so
"should" shepherd the advancement, that has led to IESG desires
to remove known problems from PS drafts.

   (Thus, IMHO, the fix for this problem is either better incentives
or assigning responsibility for advancement to someone who _has_
an incentive to complete it.)

> What I *am* hoping is that with two, clearly defined maturity
> levels, we can go back to publishing Proposed Standards in about
> a year, and have Internet Standard mean something.

   "Hope springs eternal..."

   Alas, I can imagine no rational basis for that hope. :^(

> Otherwise, we will be perpetually running the Internet on Internet
> Drafts, which is something I do not think anyone really can say
> is a good thing.

   We _cannot_ stop folks from "running" the Internet on I-Ds. And,
to be honest, the Internet is based on RFCs that were _easier_ to
publish than I-Ds are today.

   Although Russ's draft _would_ fix the downref irritant, I can't
see it doing anything to reduce the PS logjams -- indeed, human
nature ensures we'll invent _more_ logjams once PS is "only one step"
from final Standard.

   Lots of us would like to reduce the PS logjams, but we need to
look outside the part of 2026 that deals with number of levels.

   We might, for example, specifically _allow_ Individual Submissions
to bypass a congested WG if no specific objections could be listed.

   We might reduce the level of "considerations" (such as Security
Considerations) expected for Proposed Standard (though, IMHO, that's
an increasingly dangerous place to go), or assign responsibility
for adding such Considerations to something like a Security Area
Directorate.

   We might forbid WGCs from putting things off until the next IETF
week...

   We might formalize issue-tracking for WGs considering something
for PS...

   We might formalize the Document Editor role to prevent "Document
Editors" from pushing their own viewpoint...

   We might formalize a WG Secretary role to clarify specific issues
raised during in-person and virtual meetings...

   We might _require_ virtual meetings whenever a milestone is in
danger of slipping...

   And, frankly, I could go on, and many others could go on listing
things which _would_ reduce some of the logjams that have led us
to such long leadtimes to reach PS status.

   We may be nearing the point, universally found in legislatures,
where we'll "vote for anything so we can adjourn". If so, we could
do worse than Russ's proposal.

   But "vote for anything" _very_ often leads to bad law. I fully
agree with Scott Bradner that changing the number of levels isn't
something we should do lightly.

--
John Leslie <[email-masked]>

---

From: Ralph Droms <[email-masked]>
Date: Wed, 27 Oct 2010 21:36:54 -0400

I'll take the contrarian position.

Demonstrate to me that the barriers for PS really are higher than they used to be.

- Ralph

On Oct 26, 2010, at 10:39 AM 10/26/10, Julian Reschke wrote:

> Maybe some of the current IESG members could offer their opinion about *why* the barriers for PS appear to be much higher than they used to be?
> 
> Best regards, Julian