Subject: RE: Document Action: 'ANSI C12.22, IEEE 1703 and MC12.22 TransportOver IP' to Informational RFC

From: "Avygdor Moise" <[email-masked]>
Date: Tue, 26 Oct 2010 10:16:56 -0600

Dear Nikos,

I believe that you appropriately addressed the comment and I are in complete 
agreement with your remarks.

I'd would also like to point out that Mr. St. Johns' concerns are also 
addressed on the IETF data tracker for this RFC 
(http://datatracker.ietf.org/doc/draft-c1222-transport-over-ip/), on the 
IESG Write-ups tab. Specifically there is a Technical Summary, a Working 
Group Summary and a Document Quality section. These sections  fully disclose 
and document the origin and the processes used to produce this RFC Draft and 
the qualifications of the contributors.

Sincerely
Avygdor Moise

Chair: ASC C12 SC17, WG2 / ANSI C12.19;  IEEE SCC31 / WG P1377
Editor: ASC C12 SC17, WG1/ ANSI C12.22;  IEEE SCC31 / WG 1703

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> ext Nikos Mavrogiannopoulos
> Sent: Tuesday, October 26, 2010 11:49 AM
> To: Michael StJohns
> Cc: [email-masked]; [email-masked]
> Subject: Re: Document Action: 'ANSI C12.22, IEEE 1703 and MC12.22
> TransportOver IP' to Informational RFC
>
> On Mon, Oct 25, 2010 at 7:39 PM, Michael StJohns <[email-masked]>
> wrote:
> > Hi -
> > I'm confused about this approval.
> > As I read the draft and the approval comments, this document is an
> independent submission describing how to do C12.22 over IP. But the
> document is without context for "who does this" typical to an
> informational RFC.
>
> Is that really typical? Check the MD5 algorithm in [0], I don't see
> such boilerplates like "we at RSA security do hashing like that". I
> think it is obvious that the authors of the document do that, or
> recommend that. I pretty like the current format of informational
> RFCs.
>
> [0]. http://tools.ietf.org/html/rfc1321
>
> > Is this
> > a) A document describing how the document authors would do this if
> they were a standards organization?
> > b) A description of how their company does this in their products?
>
> Is your question on what informational RFCs are?
>
> > c) A description of how another standards body (which one????) does
> this?
>
> I'd suppose if this was the case it would be mentioned in the document
> in question.
>
> > d) A back door attempt to form an international standard within the
> IETF without using the traditional IETF working group mechanisms?
>
> How can you know that? When somebody specifies his way of doing
> things, is to inform and have interoperability. It might actually
> happen that industry follows this approach and ends-up in a de-facto
> standard. I see nothing wrong with that.
>
> regards,
> Nikos
> _______________________________________________
> Ietf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf

---

From: Donald Eastlake <[email-masked]>
Date: Tue, 26 Oct 2010 16:42:31 -0400

If there is something in the IESG write-up that is needed to
understand the nature of a document, that material should also appear
in the document. Most people looking at RFCs probably don't even know
that an IESG write-up might exist or where to find it and even those
who do know about the IESG write-up will assume that the RFC (and
possibly any Errata) are all they need to look at.

This doesn't seem like a big deal. Just take the first two sentences
of the "Working Group Summary" section of the IESG write-up and add
them to the Abstract and/or Introduction, or something like that.

Thanks,
Donald

---

From: Michael StJohns <[email-masked]>
Date: Tue, 26 Oct 2010 16:58:27 -0400

One simple question:  Is this document an official and approved submission on behalf of the ANSI C12.22 and ANSI C12.19 working groups?

The specific language in the IESG record (in the working group summary) is 

"This document was created by technical experts of the ANSI C12.22
  and ANSI C12.19 Standards, based on they first hand implementation
  knowledge of existing C12.22 implementations for the Internet. Its
  content is an expression on the aggregate experience of all known
  implementations of ANSI C12.22 for the SmartGrid using the
  internet."

"Created by Technical Experts of the ..."  is NOT the same as "This document was created by (or is a product of) the ANSI C12.22 and C12.19 working groups"

If you're not paying attention, you might assume this was an official work product of C12.22 and C12.19.

Or is this in reality a C12.22 work product?  If so, why not say so?  Better yet, why not have the ANSI liaison say so?

The issue is not the qualifications of the contributors, nor the process for creating the document, but whether or not this is a private contribution rather than a standards body contribution.  The document is NOT clear on this and reads like a standards body submission.  Given the authors involvement with the C12 organization, a reasonable person might assume this is an official submission even though the Working Group Notes seem to point to an individual or private submission.  It seems reasonable to clarify which hat is being worn in terms of submission.

Mike

At 12:16 PM 10/26/2010, Avygdor Moise wrote:
>Dear Nikos,
>
>I believe that you appropriately addressed the comment and I are in complete agreement with your remarks.
>
>I'd would also like to point out that Mr. St. Johns' concerns are also addressed on the IETF data tracker for this RFC (http://datatracker.ietf.org/doc/draft-c1222-transport-over-ip/), on the IESG Write-ups tab. Specifically there is a Technical Summary, a Working Group Summary and a Document Quality section. These sections  fully disclose and document the origin and the processes used to produce this RFC Draft and the qualifications of the contributors.
>
>Sincerely
>Avygdor Moise
>

---

From: Ralph Droms <[email-masked]>
Date: Tue, 26 Oct 2010 17:34:54 -0400

Combining an excellent suggestion from Donald and Avygdor's clarification as to the official status of this document, I suggest an RFC Editor note to add the following text as a new last paragraph in the Introduction:

  This document was created by technical experts of the ANSI C12.22
  and ANSI C12.19 Standards, based on they first hand implementation
  knowledge of existing C12.22 implementations for the Internet.  It
  is not an official and approved submission on behalf of the ANSI
  C12.22 and ANSI C12.19 working groups.  The content of this document
  is an expression on the aggregate experience of all known
  implementations of ANSI C12.22 for the SmartGrid using the Internet.

- Ralph

On Oct 26, 2010, at 5:25 PM 10/26/10, Avygdor Moise wrote:

> Mr. St. Johns,
>  
> You ask: "Is this document an official and approved submission on behalf of the ANSI C12.22 and ANSI C12.19 working groups?"
> Answer: No it is not.
>  
> The ANSI C12.22 and ANSI C12.19 standards do not define the Transport Layer interfaces to the network. They only define the Application Layer Services and content.
> This RFC addressed the gap as it applies to transporting C12.22 APDUs over the Internet.  However technical experts that were involved in the making, deploying, testing and documenting the referred standards contributed to the making of this RFC.
>  
> ANSI, NEMA, NIST, SGIP, MC, IEEE, IETF, AEIC and EEI are fully aware of this effort and this RFC. The work was carried in plain view.
>  
> Avygdor Moise 
> ----- Original Message -----
> From: Michael StJohns
> To: Avygdor Moise
> Cc: [email-masked] ; IESG IESG ; Jonathan Brodkin
> Sent: Tuesday, October 26, 2010 2:58 PM
> Subject: RE: Document Action: 'ANSI C12.22, IEEE 1703 and MC12.22 TransportOver IP' to Informational RFC
> 
>> I'd would also like to point out that Mr. St. Johns' concerns are also addressed on the IETF data tracker for this RFC ( http://datatracker.ietf.org/doc/draft-c1222-transport-over-ip/), on the IESG Write-ups tab. Specifically there is a Technical Summary, a Working Group Summary and a Document Quality section. These sections  fully disclose and document the origin and the processes used to produce this RFC Draft and the qualifications of the contributors.
>> 
>> Sincerely
>> Avygdor Moise
>> 
>>> From: [email-masked] [ mailto:[email-masked]] On Behalf Of

---

From: Michael StJohns <[email-masked]>
Date: Tue, 26 Oct 2010 18:24:49 -0400

Hi Ralph - 

Exactly what I was getting at.  But a slight change in the wording you suggested to make things clear.

Instead as the first paragraph of the abstract or as an RFC editor note I suggest:

"This document is not an official submission on behalf of the ANSI C12.19 and C12.22 working groups.  It was created by participants in those groups building on knowledge of several proprietary C12.22 over IP implementations.  The content of this document is an expression of a consensus aggregation of those implementations."

This, unlike your formulation, doesn't beg the question of whether or not "existing implementations"  and "all known" means "every single one including ones not publicly announced"

Thanks, Mike

---

From: Michael Richardson <[email-masked]>
Date: Tue, 26 Oct 2010 18:33:08 -0400

>>>>> "Ralph" == Ralph Droms <[email-masked]> writes:
    Ralph> Combining an excellent suggestion from Donald and Avygdor's
    Ralph> clarification as to the official status of this document, I
    Ralph> suggest an RFC Editor note to add the following text as a new
    Ralph> last paragraph in the Introduction:

    Ralph>   This document was created by technical experts of the ANSI
    Ralph> C12.22 and ANSI C12.19 Standards, based on they first hand
    Ralph> implementation knowledge of existing C12.22 implementations
    Ralph> for the Internet.  It is not an official and approved
    Ralph> submission on behalf of the ANSI C12.22 and ANSI C12.19
    Ralph> working groups.  The content of this document is an
    Ralph> expression on the aggregate experience of all known
    Ralph> implementations of ANSI C12.22 for the SmartGrid using the
    Ralph> Internet.

But, Ralph, if we publish as an Informational RFC, which is *NOT* a
standards track document, how will utilities reference this into a
NAFTA Chapter 10, article 7 compliant RFP?

(Well, they can, because NAFTA tribunal lawyers do not understand our
nomenclature. See other thread...)

They will have to write "RFC-c1222-TCP or equivalent", which means
essentially, it can be provided by C12.22-over-RS422-on-chicken-wire.

I think that the SmartGrid directorate should adopt this document.

-- 
]       He who is tired of Weird Al is tired of life!           |  firewalls  [
]   Michael Richardson, Sandelman Software Works, Ottawa, ON    |net architect[
] [email-masked] http://www.sandelman.ottawa.on.ca/ |device driver[
   Kyoto Plus: watch the video <http://www.youtube.com/watch?v=kzx1ycLXQSE>
	               then sign the petition.

---

From: Ralph Droms <[email-masked]>
Date: Wed, 27 Oct 2010 08:04:23 -0400

Avygdor - can you tell me more about the implementations on which the document is based?

- Ralph

On Oct 27, 2010, at 2:50 AM 10/27/10, Avygdor Moise wrote:

> Dear Mr. St. Johns,
> 
> Respectfully, I think that it is not the purpose of the RFC to state what it is not.
> The term "all known" cleanly relates to the authors' knowledge of known implementations. Certainly there may be a few implementations that do not follow this RFC, but the same is true nearly for any known Standard.
> Also the term "several proprietary C12.22 over IP implementations" is rather strong in view of the history of the C12 Standards and the manner in which they are implemented.
> 
> Avygdor Moise
> 
> ----- Original Message ----- From: "Michael StJohns" <[email-masked]>
> To: "Ralph Droms" <[email-masked]>; "Avygdor Moise" <[email-masked]>
> Cc: "Ralph Droms" <[email-masked]>; "Jonathan Brodkin" <[email-masked]>; "IETF Discussion" <[email-masked]>; "IESG IESG" <[email-masked]>
> Sent: Tuesday, October 26, 2010 4:24 PM
> Subject: Re: Document Action: 'ANSI C12.22, IEEE 1703 and MC12.22 TransportOver IP' to Informational RFC
> 
> 
>> Hi Ralph -
>>

---

From: "Avygdor Moise" <[email-masked]>
Date: Tue, 26 Oct 2010 15:07:48 -0600

Donald,

I think I agree with you. But I do not know what the right answer is.
The document is self contained. The material presented in the IESG Write-ups 
represent background about the document.

We always listen and follow the guidance of IETF, and IETF Editor.

Regards
Avygdor Moise
----- Original Message ----- 
From: "Donald Eastlake" <[email-masked]>
To: "Avygdor Moise" <[email-masked]>
Cc: "Jonathan Brodkin" <[email-masked]>; <[email-masked]>; "IESG 
IESG" <[email-masked]>
Sent: Tuesday, October 26, 2010 2:42 PM
Subject: Re: Document Action: 'ANSI C12.22, IEEE 1703 and MC12.22 
TransportOver IP' to Informational RFC

Thanks,
Donald

---

From: "Avygdor Moise" <[email-masked]>
Date: Tue, 26 Oct 2010 15:25:24 -0600

Mr. St. Johns,

Avygdor Moise 
  ----- Original Message ----- 
  From: Michael StJohns 
  To: Avygdor Moise 
  Cc: [email-masked] ; IESG IESG ; Jonathan Brodkin 
  Sent: Tuesday, October 26, 2010 2:58 PM
  Subject: RE: Document Action: 'ANSI C12.22, IEEE 1703 and MC12.22 TransportOver IP' to Informational RFC

"This document was created by technical experts of the ANSI
C12.22
  and ANSI C12.19 Standards, based on they first hand
implementation
  knowledge of existing C12.22 implementations for the Internet.
Its
  content is an expression on the aggregate experience of all known
  implementations of ANSI C12.22 for the SmartGrid using the
  internet."

  Mike

    Dear Nikos,

    Sincerely
    Avygdor Moise

      -----Original Message-----
      From: [email-masked] [ mailto:[email-masked]] On Behalf Of
      ext Nikos Mavrogiannopoulos
      Sent: Tuesday, October 26, 2010 11:49 AM
      To: Michael StJohns
      Cc: [email-masked]; [email-masked]
      Subject: Re: Document Action: 'ANSI C12.22, IEEE 1703 and MC12.22
      TransportOver IP' to Informational RFC

      this?

      regards,
      Nikos

---

From: "Avygdor Moise" <[email-masked]>
Date: Wed, 27 Oct 2010 00:36:25 -0600

Dear Dr. Droms,

Given that we had to convert the Word Document (draft 07) to RFC XML form 
(as requested by the editor), I will add your the suggested text into the 
introduction as then upload the XML file and TXT file for publication.

Thanks
Avygdor Moise
----- Original Message ----- 
From: "Ralph Droms" <[email-masked]>
To: "Avygdor Moise" <[email-masked]>; "Michael StJohns" <[email-masked]>
Cc: "Ralph Droms" <[email-masked]>; "Jonathan Brodkin" 
<[email-masked]>; "IETF Discussion" <[email-masked]>; "IESG IESG" 
<[email-masked]>
Sent: Tuesday, October 26, 2010 3:34 PM
Subject: Re: Document Action: 'ANSI C12.22, IEEE 1703 and MC12.22 
TransportOver IP' to Informational RFC

Combining an excellent suggestion from Donald and Avygdor's clarification as 
to the official status of this document, I suggest an RFC Editor note to add 
the following text as a new last paragraph in the Introduction:

- Ralph

On Oct 26, 2010, at 5:25 PM 10/26/10, Avygdor Moise wrote:

> Mr. St. Johns,
>
> You ask: "Is this document an official and approved submission on behalf 
> of the ANSI C12.22 and ANSI C12.19 working groups?"
> Answer: No it is not.
>
> The ANSI C12.22 and ANSI C12.19 standards do not define the Transport 
> Layer interfaces to the network. They only define the Application Layer 
> Services and content.
> This RFC addressed the gap as it applies to transporting C12.22 APDUs over 
> the Internet.  However technical experts that were involved in the making, 
> deploying, testing and documenting the referred standards contributed to 
> the making of this RFC.
>
> ANSI, NEMA, NIST, SGIP, MC, IEEE, IETF, AEIC and EEI are fully aware of 
> this effort and this RFC. The work was carried in plain view.
>
> Avygdor Moise
> One simple question:  Is this document an official and approved submission 
> on behalf of the ANSI C12.22 and ANSI C12.19 working groups?
>
>
> "Created by Technical Experts of the ..."  is NOT the same as "This 
> document was created by (or is a product of) the ANSI C12.22 and C12.19 
> working groups"
>
> Or is this in reality a C12.22 work product?  If so, why not say so? 
> Better yet, why not have the ANSI liaison say so?
>
>
> The issue is not the qualifications of the contributors, nor the process 
> for creating the document, but whether or not this is a private 
> contribution rather than a standards body contribution.  The document is 
> NOT clear on this and reads like a standards body submission.  Given the 
> authors involvement with the C12 organization, a reasonable person might 
> assume this is an official submission even though the Working Group Notes 
> seem to point to an individual or private submission.  It seems reasonable 
> to clarify which hat is being worn in terms of submission.
>
>
> Mike
>
>> addressed on the IETF data tracker for this RFC ( 
>> http://datatracker.ietf.org/doc/draft-c1222-transport-over-ip/), on the 
>> Group Summary and a Document Quality section. These sections  fully 
>> disclose and document the origin and the processes used to produce this 
>> RFC Draft and the qualifications of the contributors.
>>
>> Sincerely
>> Avygdor Moise
>>

---

From: "Avygdor Moise" <[email-masked]>
Date: Wed, 27 Oct 2010 00:50:30 -0600

Dear Mr. St. Johns,

Respectfully, I think that it is not the purpose of the RFC to state what it 
is not.
The term "all known" cleanly relates to the authors' knowledge of known 
implementations. Certainly there may be a few implementations that do not 
follow this RFC, but the same is true nearly for any known Standard.
Also the term "several proprietary C12.22 over IP implementations" is rather 
strong in view of the history of the C12 Standards and the manner in which 
they are implemented.

Avygdor Moise

----- Original Message ----- 
From: "Michael StJohns" <[email-masked]>
To: "Ralph Droms" <[email-masked]>; "Avygdor Moise" <[email-masked]>
Cc: "Ralph Droms" <[email-masked]>; "Jonathan Brodkin" 

> "This document is not an official submission on behalf of the ANSI C12.19 
> and C12.22 working groups.  It was created by participants in those groups 
> building on knowledge of several proprietary C12.22 over IP 
> implementations.  The content of this document is an expression of a 
> consensus aggregation of those implementations."
>
>
> This, unlike your formulation, doesn't beg the question of whether or not 
> "existing implementations"  and "all known" means "every single one 
> including ones not publicly announced"
>
> Thanks, Mike
>
>
>>Combining an excellent suggestion from Donald and Avygdor's clarification 
>>as to the official status of this document, I suggest an RFC Editor note 
>>to add the following text as a new last paragraph in the Introduction:
>>
>>> This RFC addressed the gap as it applies to transporting C12.22 APDUs 
>>> over the Internet.  However technical experts that were involved in the 
>>> making, deploying, testing and documenting the referred standards 
>>> contributed to the making of this RFC.
>>>
>>> One simple question:  Is this document an official and approved 
>>> submission on behalf of the ANSI C12.22 and ANSI C12.19 working groups?
>>>
>>>
>>> assume this is an official submission even though the Working Group 
>>> Notes seem to point to an individual or private submission.  It seems 
>>> reasonable to clarify which hat is being worn in terms of submission.
>>>
>>>
>>> Mike
>>>
>>>> IESG Write-ups tab. Specifically there is a Technical Summary, a 
>>>> Working Group Summary and a Document Quality section. These sections 
>>>> fully disclose and document the origin and the processes used to 
>>>> produce this RFC Draft and the qualifications of the contributors.
>>>>
>>>> Sincerely
>>>> Avygdor Moise
>>>>

---

From: Michael StJohns <[email-masked]>
Date: Wed, 27 Oct 2010 17:58:51 -0400

I beg to differ....  pretty much all Informational RFCs bear the following notation:
This document is not an Internet Standards Track specification;

This is clearly an example of an RFC stating what it is not.

For the rest:

"all known" is different than "all implementations known of by the authors and anyone they consulted (which could be a pretty limited group)" which is what you're trying to claim is an equivalence.  :-)  To use your own term "all known" is "rather strong".  

 "proprietary" simply means not publicly owned/produced/developed so not sure what you mean by "several proprietary C12.22... implementations" being "rather strong".  As far as I know, there are no non-proprietary implementations since there are no non-proprietary standards for this.  To be even more specific, the publication of this document will not create a non-proprietary standard - its just documenting existing proprietary specifications/implementations, and publication in and of itself doesn't change that status.

---

From: "Avygdor Moise" <[email-masked]>
Date: Wed, 27 Oct 2010 17:06:52 -0600

The following text was added to the abstract:
  "This document was created by technical experts of the ANSI C12.22/IEEE 1703/MC12.22 and ANSI C12.19/IEEE 1377/MC12.19 Standards working groups, based on their first hand knowledge of existing C12.22 implementations for the Internet. It is not an official and approved submission on behalf of the ANSI/IEEE or MC working groups. The content of this document is an expression of the aggregate experience of known implementations of ANSI C12.22/IEEE 1703/MC12.22 for the SmartGrid using the Internet."

  I think it addresses the concerns you raise.
Regarding your assertion that "pretty much all Informational RFCs bear the following notation: This document is not an Internet Standards Track specification;"
  We are not an expects on the subject of IETF RFC front matter. I am confident that the correct front matter and copyrights material will be added by the RFC Editor. This material is not normally proided by the Authors since it is boiler plate machine generated text.
Otherwise, I am not very clear about what you are driving at, primarily because I do not have a clear context for your reasoning or your background with C12.22. I would recommend that if you are aware of proprietary implementations of C12.22 over IP that differ substantially from the documented framework in this RFC, then by all means bring them forward to our attention and we can review them for compliance first with IEEE 1703 / ANSI C12.22 / MC12.22 then this RFC and identify gaps, if any.

Thank You
Avygdor Moise

  ----- Original Message ----- 
  From: Michael StJohns 
  To: Avygdor Moise ; Ralph Droms 
  Cc: Ralph Droms ; Jonathan Brodkin ; IETF Discussion ; IESG IESG 
  Sent: Wednesday, October 27, 2010 3:58 PM
  Subject: Re: Document Action: 'ANSI C12.22, IEEE 1703 and MC12.22 TransportOver IP' to Informational RFC

  For the rest:

    Dear Mr. St. Johns,

    Avygdor Moise

      Hi Ralph -

      Thanks, Mike

        - Ralph

          Mr. St. Johns,

          Avygdor Moise
          ----- Original Message -----
          From: Michael StJohns
          To: Avygdor Moise

          Mike

            Dear Nikos,

            Sincerely
            Avygdor Moise

              -----Original Message-----

              this?

              regards,
              Nikos