Subject: Extending the Datatracker to display user-specific lists of drafts

From: Paul Hoffman <[email-masked]>
Date: Fri, 22 Oct 2010 14:51:49 -0700

Greetings again. There is a new draft that may be of interest to many people in the IETF: <http://tools.ietf.org/html/draft-ietf-genarea-datatracker-community>. The abstract is:

   The document gives a set of requirements for extending the IETF
   Datatracker to give individual IETF community members, including the
   IETF leadership, easy methods for tracking the progress of the
   Internet Drafts of interest to them.

For example, you would be able to easily create a list of the drafts from WGs you were interested in, and also include specific non-WG drafts you cared about. You could then find out their current status as well as get notifications when any of the drafts in your list changes state. The extension to the tool will hopefully be useful to active IETF participants who care about dozens of drafts as well as less-active people who only care about a few.

If you are interested in helping set the requirements for this extension to the Datatacker, please join the mailing list for the discussion at <https://www.ietf.org/mailman/listinfo/datatracker-rqmts>. There will also be a BoF session (iddtspec) for this topic in Beijing.

--Paul Hoffman

---

From: Fred Baker <[email-masked]>
Date: Fri, 22 Oct 2010 22:30:14 -0700

> If you are interested in helping set the requirements for this extension to the Datatacker, please join the mailing list for the discussion at <https://www.ietf.org/mailman/listinfo/datatracker-rqm…

Interesting draft, Paul. So I gather this is something like - enable a registered user to maintain one or more "interest lists" and to do things based on them.

Let me throw out an idea. You may be familiar with http://changedetect.com; if you aren't, take a look. What it does is poll http and https sites and send you an email when they change. It's really useful for looking at things like https://datatracker.ietf.org/docs/<your favorite doc>, which I do as a document shepherd and as a working group chair. The one thing I don't like about it is that they charge you for https. So I wrote my own equivalent, a small perl script that uses curl to download web pages, diff to compare them, and then opens the web page if it appears to have changed.

One thing that would be nice from a working group chair perspective would be to be able to "watch" such sites from IETF and be alerted when they change. This would of course be a set of pages I chose, which might include working group documents, individual submissions, my own submissions, etc.

---

From: Julian Reschke <[email-masked]>
Date: Sat, 23 Oct 2010 11:27:52 +0200

On 23.10.2010 07:30, Fred Baker wrote:
> ...
> ...

I thought that's what we have Atom feeds for? (at 
https://datatracker.ietf.org/doc/...)

Best regards, Julian

---

From: Arnt Gulbrandsen <[email-masked]>
Date: Sat, 23 Oct 2010 11:38:21 +0200

> https://datatracker.ietf.org/doc/...)

There isn't an atom feed for draft*-foo*-*, only for specific 
documents/urls. Right?

Arnt

---

From: Paul Hoffman <[email-masked]>
Date: Sat, 23 Oct 2010 09:54:27 -0700

>Interesting draft, Paul. So I gather this is something like - enable a registered user to maintain one or more "interest lists" and to do things based on them.

Indeed. Could we move this thread over to the mailing list that was set up for the project?

>If you are interested in helping set the requirements for this extension to the Datatacker, please join the mailing list for the discussion at <https://www.ietf.org/mailman/listinfo/datatracker-rqmt…

--Paul Hoffman, Director
--VPN Consortium

---

From: Paul Hoffman <[email-masked]>
Date: Sat, 23 Oct 2010 10:04:29 -0700

At 11:38 AM +0200 10/23/10, Arnt Gulbrandsen wrote:
>There isn't an atom feed for draft*-foo*-*, only for specific documents/urls. Right?

(Again, hoping this moves to the project-specific mailing list...) The requirement in the current says that there would be a feed for the whole list, not per-draft. If people want both, we could add that requirement as well.

--Paul Hoffman, Director
--VPN Consortium