Subject: Re: US DoD and IPv6

From: [email-masked] (Noel Chiappa)
Date: Tue, 5 Oct 2010 23:42:34 -0400 (EDT)

> From: Michael Richardson <[email-masked]>
    
    >> So what %-age of traffic across major backbones is now IPv6?
	       ^^^^^
    > From what I've read, it's about the same size as the IPv4 in 1992

I don't think so... unless you meant 'total number of packets', not
'percentage' (as I asked).

The point is that backbone traffic is still mostly IPv4 - and with the IPv4
address space runout in only a few months, that's unlikely to change
substantially between now and then. So whatever's going to happen when IPv4
addresses run out, a mass conversion of traffic to IPv6 probably isn't it.

	Noel

---

From: Keith Moore <[email-masked]>
Date: Wed, 6 Oct 2010 00:18:59 -0400

> addresses run out, a mass conversion of traffic to IPv6 probably isn't it.

I think the demise of IPv4 will be a lot like the demise of BITNET. 

Keith

---

From: David Conrad <[email-masked]>
Date: Tue, 5 Oct 2010 20:04:55 -1000

Noel,

On Oct 5, 2010, at 5:42 PM, Noel Chiappa wrote:
> So whatever's going to happen when IPv4

Of course not.  Obtaining IPv4 addresses will simply become more expensive, with all that implies.  Folks that depend on a cheap supply of new IP addresses are going to figure out ways of continuing to obtain their supplies, but costs will be non-linear and unpredictable.  This will encourage ISPs to cannibalize internal public holdings (e.g., addresses for internal infrastructure) migrating to RFC 1918 or IPv6 internally and, when that runs out (which won't take long), purchase IPv4 address on the black/grey/white (depending on how the RIRs deal with runout) market.  Costs will, of course, be passed down to the end user.  End users will either respond by: 

a) deciding they are OK with 1 or 2 public addresses and NATv4'ing everything else, returning PA address space to their ISPs or selling/leasing PI address space to folks willing to pay; 

and/or 

b) turn on IPv6 and demand their ISPs and preferred content providers support it, and deploy v4 to v6 NAT as a stop gap (which probably will such just as much and as little as option (a)).

Option (b) is probably better in the long run, though some folks might disagree.  Oddly enough, I don't see a way forward that doesn't include vast amounts of NAT.  The only question is what flavor of NAT.

ISPs that have routers that are on the edge memory- or CPU-wise should really consider upgrading, as there is likely to be a flood of long prefix IPv4 routes as the markets take effect.  If they can't upgrade, then we revisit history and see prefix length filters showing up again.  

Regards,
-drc