Subject: Re: Ad Hoc BOFs

From: Yoav Nir <[email-masked]>
Date: Sun, 1 Aug 2010 11:47:47 +0300

On Aug 1, 2010, at 9:45 AM, Melinda Shore wrote:

> Yoav Nir wrote:
>> Who's "folks"? A lot of people come to an IETF meeting, and are 
>> only following one or two of the working groups. That does not mean
>> that they sit in their hotel rooms for the rest of the meeting.
>> Instead, they pick what looks like interesting meetings, and go
>> there, with the hope of catching something interesting.
> 
> That's a really good point, actually.  I've also made a
> point in the past of attending at least one session
> completely unrelated to what I'm working on, in hopes of
> learning something or getting new ideas or new associations
> or something.  But still, it seems to me that there are
> two somewhat but not quite orthogonal questions here: 1)
> whether or not the increasing formalization of the bar
> BOF reflects an increased expectation of attendance in
> order to participate/advance work in the IETF, and 2) what
> a working group meeting is.

I'll pass on answering #2, but as for #1, I think the bar BoF "institution" is mis-used as a working group of last resort. If I can't present my idea at a regular working group (because of time constraints or because it doesn't fit the charter of any current WG), and I can't present it at the area gathering (for lack of space), adding a "bar BoF" to the wiki seems to be the only way. In the end we don't get a lot of discussion - merely a presentation + Q&A session. And still the "right" people are often not there.

So formalizing a bunch of presentations is a good thing, although I think it needs to be done differently. 

Formalizing a bunch of people throwing ideas around (the "true" bar BoF) is not a good thing.

---

From: "Joel M. Halpern" <[email-masked]>
Date: Sun, 01 Aug 2010 10:08:32 -0400

In hallway discussion about this, it was suggested to me that part of 
the problem is that some folks can not figure out how to socialize their 
ideas.

If ideas are really preliminary, sitting down with 4-6 other folks who 
are skilled and informed on the particular topic to discuss the idea, 
and try to firm it up makes good sense.  The IETF is a very good place 
to do that.  That is what the traditional Bar BoF was for.

If the idea is that unformed, it is probably not a good idea to invite 
70 of your unknown compatriots to come discuss it with you.

Conversely, if the idea is better formed, write an I-D.  Then either 
create a mailing list, or ask the leadership for help creating a mailing 
list.  Ask the relevant chairs to pass on an email about the email lsit.
Have discussion on the email list.

This is the known recipe for getting to a successful BoF.  It works.

Conversely, having a large number of informal, large "BarBoFs" to try to 
drum up interest in a topic is not good for the community.  Folks need 
time to talk to eahc other individually about many topics.  Folks should 
be allowed time to eat sane meals and get some sleep.

We can not ban all such meetings.  But we need to remind people that 
culturally, this is the way that the IETF has found to be effective.

This leads to two suggestions:
1) If there is no I-D and no mailing list, then no, you can not have a 
room suitable for 50+ people.
2) When requests come in for actual BoFs, and the request includes 
supporting indications of interest, and claim that a BarBof indicates 
interest should be ignored by the leadership.

Yours,
Joel

Yoav Nir wrote:
> _______________________________________________
> Ietf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf
>

---

From: Dave CROCKER <[email-masked]>
Date: Sun, 01 Aug 2010 16:48:12 +0200

On 7/31/2010 1:00 PM, Peter Saint-Andre wrote:
> or perhaps many
> drafts are written in such a way that folks can't easily grok the problem
> and its proposed solution. Regarding the latter, one of the WGs I advise
> held a small "tutorial" session in a side room on Friday morning and that
> turned out to be quite useful because it forced some of the key
> contributors (in this case the chairs) to clearly explain the core
> concepts behind the protocol under development within the WG, and I think
> that effort will pay off in the form of a much clearer and more readable
> specification.

Kudos.

There has long been discomfort about working group meetings that are primarily 
tutorial.  Given the very short time there is for wg meetings, it really is 
essential that they be devoted to resolving specific questions through face to 
face debate. That's really all there is time for.

That said, careful summary/tutorial can often be quite helpful.  And you point 
the perhaps-not-obvious benefit that it solidifies the presentation abilities of 
the principles, rather than only providing basic exposure for new folk.

So I find myself reacting to your note by thinking that perhaps we should 
distinguish these activities and schedule them separately, with clear labeling. 
  Only some groups will need tutorials.  Only some folk will need/want to attend 
them.  If a group needs /only/ tutorial, we might want to take a moment and 
wonder how that can be.

I could, for example, imagine a message of brief tutorials filling some of Sunday...

d/
-- 

   Dave Crocker
   Brandenburg InternetWorking
   bbiw.net

---

From: Donald Eastlake <[email-masked]>
Date: Sun, 1 Aug 2010 16:06:25 -0400

On Sun, Aug 1, 2010 at 10:08 AM, Joel M. Halpern <[email-masked]>wrote:

> ...
> 1) If there is no I-D and no mailing list, then no, you can not have a room
> suitable for 50+ people.
> ...
>

+10**10

If there is no ID and no mailing list at least several weeks in advance, you
should either have a real bar BoF with a handful of appropriate people, or
you can seek opportunities to present at appropriate WG or Area meetings.

> Joel

Thanks,
Donald

>>>> Who's "folks"? A lot of people come to an IETF meeting, and are only
>>>> following one or two of the working groups. That does not mean
>> I'll pass on answering #2, but as for #1, I think the bar BoF
>> "institution" is mis-used as a working group of last resort. If I can't
>> present my idea at a regular working group (because of time constraints or
>> because it doesn't fit the charter of any current WG), and I can't present
>> it at the area gathering (for lack of space), adding a "bar BoF" to the wiki
>> seems to be the only way. In the end we don't get a lot of discussion -
>> merely a presentation + Q&A session. And still the "right" people are often
>> not there.
>>

---

From: Yoav Nir <[email-masked]>
Date: Mon, 2 Aug 2010 10:49:07 +0300

Partially agree. 

Just requiring a draft (that was not submitted within the meeting week) gives you a two-week waiting period. I'm not so sure about the mailing list requirement. 

One of the best presentations-posing-as-barBoF in IETF 77 was about a traceback experiment in Japan. They did write a draft, but I don't think there was a mailing list, and I don't know whether such a mailing list would have helped anyone. They only talked about what they had already done. 

I guess the requirement for a mailing list depends no whether you want to present something the IETF should (in your opinion) do, or whether you just want to present some information.

We could have this requirement and allow ADs to waive it.

________________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of Donald Eastlake
Sent: 01 August 2010 23:06
To: Joel M. Halpern
Cc: IETF discussion list
Subject: Re: Ad Hoc BOFs

On Sun, Aug 1, 2010 at 10:08 AM, Joel M. Halpern <[email-masked]> wrote:
...
1) If there is no I-D and no mailing list, then no, you can not have a room suitable for 50+ people.
...

+10**10

If there is no ID and no mailing list at least several weeks in advance, you should either have a real bar BoF with a handful of appropriate people, or you can seek opportunities to present at appropriate WG or Area meetings.

---

From: Marshall Eubanks <[email-masked]>
Date: Mon, 2 Aug 2010 10:48:51 -0400

Dear Joel;

On Aug 1, 2010, at 10:08 AM, Joel M. Halpern wrote:

> In hallway discussion about this, it was suggested to me that part  
> of the problem is that some folks can not figure out how to  
> socialize their ideas.
>

I would say that if a BarBOF is organized independent of the IETF  
process, it is not appropriate to measure it by the rules of the IETF  
process.

> If ideas are really preliminary, sitting down with 4-6 other folks  
> who are skilled and informed on the particular topic to discuss the  
> idea, and try to firm it up makes good sense.  The IETF is a very  
> good place to do that.  That is what the traditional Bar BoF was for.

The trouble I have with that is that I may not know who those people  
are, and even if I do it is hard (in my experience) to find vacant  
time slots to get those people together. (The IETF can be great for  
meeting and spending some time with people you don't know, simply  
because you are in the restaurant / bar / social together, but we all  
know it can be very hard to arrange time to meet with a specific set  
of people.) To get even 5 people together, it is frequently necessary  
to resort to a doodle poll, and that means a certain amount of  
organization.

In the case of the 2 BarBOFS I organized at IETF-78, in both cases  
there were very useful contributions made by  people I didn't know and  
therefore wouldn't have invited. Even if the efforts fail (and one of  
them was DOA and will not move forward), I am glad to have had the  
opportunity to get to know more people in an area of interest to me.

Regards
Marshall

>
> If the idea is that unformed, it is probably not a good idea to  
> invite 70 of your unknown compatriots to come discuss it with you.
>
> create a mailing list, or ask the leadership for help creating a  
> mailing list.  Ask the relevant chairs to pass on an email about the  
> email lsit.
> Conversely, having a large number of informal, large "BarBoFs" to  
> try to drum up interest in a topic is not good for the community.   
> Folks need time to talk to eahc other individually about many  
> topics.  Folks should be allowed time to eat sane meals and get some  
> sleep.
>
> supporting indications of interest, and claim that a BarBof  
> indicates interest should be ignored by the leadership.
>
> Yours,
> Joel
>
> Yoav Nir wrote:
>> "institution" is mis-used as a working group of last resort. If I  
>> can't present my idea at a regular working group (because of time  
>> constraints or because it doesn't fit the charter of any current  
>> WG), and I can't present it at the area gathering (for lack of  
>> space), adding a "bar BoF" to the wiki seems to be the only way. In  
>> the end we don't get a lot of discussion - merely a presentation +  
>> Q&A session. And still the "right" people are often not there.
>> So formalizing a bunch of presentations is a good thing, although I  
>> think it needs to be done differently. Formalizing a bunch of  
>> people throwing ideas around (the "true" bar BoF) is not a good  
>> thing. _______________________________________________
>> Ietf mailing list
>> [email-masked]

---

From: Yoav Nir <[email-masked]>
Date: Mon, 2 Aug 2010 18:04:57 +0300

> opportunity to get to know more people in an area of interest to me.

And that is why I think that these meetings would have been better served if presented as a presentation, rather than a bar BoF.

Suppose we had a list of "non-WG presentations" with a listing like this

Title: Tunneling IPSec over HTTP using XML
Presenter: Marshall Eubanks
Draft:  draft-eubanks-ipsec-bloated-transport
Abstract:
For years now http has not enjoyed the benefits of XML. We are now about to change all that. No longer will IPsec be constrained to efficient formats.

---

From: "Spencer Dawkins" <[email-masked]>
Date: Mon, 2 Aug 2010 17:16:06 +0200

> And that is why I think that these meetings would have been better served 
> if presented as a presentation, rather than a bar BoF.
>
> For years now http has not enjoyed the benefits of XML. We are now about 
> to change all that. No longer will IPsec be constrained to efficient 
> formats.

I think it's brilliant for us to talk about "poster sessions", or "lightning 
talks", at IETF meetings, but we should definitely not confuse that with 
"having a bar BOF" in this context...

Spencer

---

From: Yoav Nir <[email-masked]>
Date: Mon, 2 Aug 2010 22:20:34 +0300

> "having a bar BOF" in this context...

I agree. My point is that a lot of the things listed as bar BoFs are in fact lightning talks. Take them away to their own list, and the true bar BoFs will not need to be listed on the wiki, and won't need conference rooms either.

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 30 Jul 2010 23:06:03 +0200

On Jul 30, 2010, at 14:54, Jari Arkko wrote:

> people consistently referring to the meetings as "BOFs", 

The fix is to call the formal working group formation planning meetings "working group formation planning meetings", not to stop calling the literal BoF meetings "BoFs".  A lot of conferences have a good BoF system, with schedules and all, and these can be very nice informal, productive meetings, with or without a projector present.  (Providing a scheduling raster for BoFs so their location and timing is not a poorly plannable overlay to the secretariat's scheduling might help us, too, but I'm not entirely sure about that.)

> the only real bar BoF that I attended was horrible in terms of being able to hear what the other people said.

I'm not a native English speaker, and my brain is optimized for symbolic processing, not for maximum likelihood decoding.  In my 17 years of IETF experience, almost no real "bar" BoF has been useful for me (i.e., has allowed me to be useful).  Tabled meeting spaces like the ones we had in Dublin and here in Maastricht have been most useful for focused point work.  The meeting room with a round (oval) table arrangement and a projector we had for the 6lowapp "bar" BoF (yes, there was real beer) was great for the 10 minutes of focus talk and 1 hour of focused discussion that helped define the problem and ultimately led to the CoRE WG.  Meetings in nice, quiet restaurants have been great for breaking the ice and subtly making progress at solving political problems -- if the group wasn't too large for that.  And even the little WG chair job that yours truly tries to fulfill leaves me exhausted after an IETF week, and I have no idea how you all in I* survive that week. 

Gruesse, Carsten
[still using my backup mail address until certain MTU issues are fixed.]

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Sun, 1 Aug 2010 09:01:00 -0400

Nah, a working group of last resort is when you create your own
standards organization to work on it.

Or in some cases that is a first resort. I find it rather amusing to
find the number of such efforts that were started with the idea that
they had to move faster than the existing standards orgs could allow
and then end up spending their first two to three years essentially
stalled while they work out all the infrastructure issues they could
have had for free.

But I digress.

If the purpose of the exercise is to do design then you really don't
want more then five people and you probably don't want to tell anyone
else about it.

But before you do design you need to know about the requirements and
constraints that affect your proposal. And for that it is useful to
have the largest number of people possible.

In most cases though, the reason you want a working group is to get
buy-in for the eventual solution. Design is easy. Getting the designs
deployed is very hard. Some working groups realize this and take
deployment very seriously. Others do not.

-- 
Website: http://hallambaker.com/

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Sun, 1 Aug 2010 18:18:05 -0400

Or why not go further and reorganize IETF completely on the same lines
as most other standards bodies.

IETF would be split into intensive one or two day working groups in
which the WG was expected to make significant progress on closing out
its issues list.

Wednesday would be set aside for the tutorial / cross area / cross
IETF sessions with the morning set aside for area meetups and the
afternoon for plenaries led by the IAB and IESG. So instead of the WG
sessions being mostly rather boring status updates we could actually
do some useful work.

A small number of working groups could probably be absorbed into an
area-wide 'maintenance' working group. A lot of security working
groups appear to be impossible to shut down because there is always a
need to maintain lists of algorithms and so on. For several years
running I have put S/MIME on my duty list and then found that the
agenda was completed before I had chance to log into the jabber room.

The current scheme appears to have evolved from the days when the
fore-runners of the ADs were the ARPA program managers and the
fore-runner of IETF meetings were essentially status meetings.

If the IESG insists on making itself the critical path on every loop
it is going to find itself over-worked. And lets not forget that the
IETF is handling a progressively smaller portion of Internet Standards
work. Anyone really think that the IETF could cope with also handling
the work done in W3C and OASIS in addition to its current load?

The current scheme has one meeting format that is attempting to
satisfy two objectives that do not seem to me to be very compatible.

We have three meetings a year, we can experiment with one meeting
every few years or so and see if other arrangements meet those needs
better. We don't even need to experiment with a whole meeting. What I
am proposing might well work better for some areas than others and
some working groups than others.

On Sun, Aug 1, 2010 at 10:48 AM, Dave CROCKER <[email-masked]> wrote:
> There has long been discomfort about working group meetings that are
> primarily tutorial.  Given the very short time there is for wg meetings, it
> really is essential that they be devoted to resolving specific questions
> through face to face debate. That's really all there is time for.
>
> That said, careful summary/tutorial can often be quite helpful.  And you
> point the perhaps-not-obvious benefit that it solidifies the presentation
> abilities of the principles, rather than only providing basic exposure for
> new folk.
>
> distinguish these activities and schedule them separately, with clear
> labeling.  Only some groups will need tutorials.  Only some folk will
> need/want to attend them.  If a group needs /only/ tutorial, we might want
> to take a moment and wonder how that can be.
>

---

From: Scott W Brim <[email-masked]>
Date: Tue, 3 Aug 2010 12:58:41 -0400

Throwing a draft at the IETF without a lot of supporting work rarely gets
anywhere, but some people find it hard to figure out just what "supporting"
work is actually effective and to execute on it. It's the non-procedural
parts of the IETF process that confound people, and lead to various end
runs. I suspect that the way to lessen the number of "on the edge"
activities is to (1) encourage interim meetings including BOFs with good
teleconferencing, and (2) make the process for getting work considered in
the IETF even more procedural than it is, to make it easier for sumner to
work with it.

On Jul 30, 2010 3:07 PM, "Yoav Nir" <[email-masked]> wrote:

On Jul 30, 2010, at 7:32 PM, Melinda Shore wrote:

> Yoav Nir wrote:
>> First is people who have an...
True.

> The implication that there needs to be a session, with a room
> and slides and humans sitting in ...
There doesn't need to be, but that is one way to do things. There are
hundreds of drafts posted every week. We all ignore most of them. A short
presentation might get enough people interested to start a discussion on
some mailing list.

https://www.ietf.o...

---

From: Scott W Brim <[email-masked]>
Date: Tue, 3 Aug 2010 12:58:41 -0400

Once upon a time Bob Braden would alternate WG sessions, one "open" and then
one only for people who were actually contributing.

On Jul 31, 2010 7:00 AM, "Peter Saint-Andre" <[email-masked]> wrote:

> At 9:32 AM -0800 7/30/10, Melinda Shore wrote:
>

>>and slides and humans sitting in c...
Double bingo. The number of WG sessions (which are ostensibly scheduled
for the purpose of "working") in which folks have not read the drafts or
otherwise prepared themselves to actively contribute is also distressingly
high. Perhaps we all simply have too much work to do, or perhaps many
drafts are written in such a way that folks can't easily grok the problem
and its proposed solution. Regarding the latter, one of the WGs I advise
held a small "tutorial" session in a side room on Friday morning and that
turned out to be quite useful because it forced some of the key
contributors (in this case the chairs) to clearly explain the core
concepts behind the protocol under development within the WG, and I think
that effort will pay off in the form of a much clearer and more readable
specification.

Peter

https://www.ietf.or...

---

From: John C Klensin <[email-masked]>
Date: Wed, 04 Aug 2010 10:30:34 -0400

Peter,

I may have more to say about the general topic in a more
comprehensive note but I think your comment calls for a
challenge to the community and the IESG.

--On Saturday, July 31, 2010 05:00 -0600 Peter Saint-Andre
<[email-masked]> wrote:

>> "participate" is too strong a word. Scheduled-but-ad-hoc BoFs
>> now have the same unfortunate properties of many WGs, namely
>> that 80+% of the people there are only there to listen, not
>> help.
> 
> Double bingo. The number of WG sessions (which are ostensibly
> scheduled for the purpose of "working") in which folks have
> not read the drafts or otherwise prepared themselves to
> actively contribute is also distressingly high. Perhaps we all
> simply have too much work to do, or perhaps many drafts are
> written in such a way that folks can't easily grok the problem
> and its proposed solution. Regarding the latter, one of the
> WGs I advise held a small "tutorial" session in a side room on
> Friday morning and that turned out to be quite useful because
> it forced some of the key contributors (in this case the
> chairs) to clearly explain the core concepts behind the
> protocol under development within the WG, and I think that
> effort will pay off in the form of a much clearer and more
> readable specification.

I think that, in theory, the IESG has the ability to "solve"
many of these problems by adopting a management doctrine that
groups get meeting resources only if they can justify them on
the basis of posted drafts and active discussion of those drafts
on mailing lists.  The IESG should retain the ability to be
flexible when appropriate, but "no activity on that topic"
should imply "no agenda time" and "no drafts or other activity"
should imply "no meeting slot"... whether we are talking about
WGs, formal BOFs, or various informal activities that require
IETF meeting resources.  I recognize the advantages of tutorials
too, but they should be identified as such and should be very
few within the life cycle of a WG (or WG organizing process).

The challenge to the community is that, each time something like
this has been suggested to the IESG in recent years, the
response has been either "but the community really wants all of
those meetings and we have to do what they are telling us" or
"lots of people are willing to have more restrictions on
meetings as long as the meetings they are interested in are not
affected".  I fear that both of those responses are correct.
So, if we actually want to turn this around, we need to convince
the IESG that there really is significant community support for
more aggressive management of WGs and meetings.  If that support
actually does not exist, maybe discussions like this one are,
themselves, a waste of time and resources.

    john

---

From: Melinda Shore <[email-masked]>
Date: Wed, 4 Aug 2010 11:03:31 -0800

On Aug 4, 2010, at 6:30 AM, John C Klensin wrote:
> on mailing lists.

I participated (kinda) in this meeting remotely, and it's
really become quite noticeable the extent to which the 
work of the IETF is now done in meetings rather than on
mailing lists.  Part of this is that while the audio 
streaming has gotten quite excellent, the jabber support
has deteriorated quite badly.  There used to be a few
sessions in which there was no jabber scribing and now it's
more common than not.  While I suppose it's a natural
consequence of the much improved audio quality it has the
unfortunate side-effect of making it that much more 
difficult to comment remotely during the session.  Far
more disturbing, however, was the session in which the
chair looked for volunteers, but limited volunteers to
people physically present.

I wonder if raising the bar on meeting space allocation
by expecting more pre-meeting mailing list activity won't
also have the effect of reversing this trend and making the
IETF function better for people participating remotely.

Melinda

---

From: Scott Brim <[email-masked]>
Date: Wed, 04 Aug 2010 15:13:24 -0400

On 08/04/2010 15:03 EDT, Melinda Shore wrote:
> more common than not.  

When I'm doing meeting notes, I like to focus on the meeting notes and
then do incremental copy/paste dumps of those notes into the jabber
conference whenever I have idle moments.  That way only one person is
required for both meeting notes and "scribing", and you're never without
a jabber scribe (since notes are required).  However, someone else needs
to monitor what's going on in jabber in order to act as a proxy and
relay comments or questions to the group.

> While I suppose it's a natural
> consequence of the much improved audio quality

I would suspect it's just that people have found jabbering awkward and
with little return all along, so now that the honeymoon is over they're
not bothering.

---

From: Yoav Nir <[email-masked]>
Date: Thu, 5 Aug 2010 10:49:33 +0300

> I agree. My point is that a lot of the things listed as bar BoFs are in fact lightning talks. Take them away to their own list, and the true bar BoFs will not need to be listed on the wiki, and won…

In keeping with IETF traditions, I'm putting some XML where my mouth is.

Here's a -00 draft about this.

http://www.ietf.org/internet-drafts/draft-nir-non-wg-presentations-00.txt

---

From: Michael Richardson <[email-masked]>
Date: Thu, 05 Aug 2010 10:07:03 -0400

>>>>> "Yoav" == Yoav Nir <[email-masked]> writes:
    Yoav> In keeping with IETF traditions, I'm putting some XML where my
    Yoav> mouth is.

    Yoav> Here's a -00 draft about this.

    Yoav> http://www.ietf.org/internet-drafts/draft-nir-non-wg-presentations-00.txt

I like it... I would add:
  - the room should be a regular room (mp3 stream)
  - the secretariat should consider having one fewer regular track
  on Monday/Tuesday.

I like that you've insisted that the slides be uploaded.
(Honestly, can we please use PDF for all slides?)

I would further suggest that in order to sync the mp3/foils, that the
presenter be reminded that many will be looking through the presentation
later on, from the "archives"

You have said that this track is not for things that belong in WGs.
I want to take the opposite view: a lot of presentations are in WGs,
should I think, not take the time of the group.

-- 
]       He who is tired of Weird Al is tired of life!           |  firewalls  [
]   Michael Richardson, Sandelman Software Works, Ottawa, ON    |net architect[
] [email-masked] http://www.sandelman.ottawa.on.ca/ |device driver[
   Kyoto Plus: watch the video <http://www.youtube.com/watch?v=kzx1ycLXQSE>
	               then sign the petition.

---

From: Paul Hoffman <[email-masked]>
Date: Thu, 5 Aug 2010 07:22:06 -0700

>  - the room should be a regular room (mp3 stream)

I don't think the MP3 streaming happens after the last regular meeting is finished. The mics had been removed from the rooms well before the nonBoFs happened in Maastricht.

>  - the secretariat should consider having one fewer regular track

Fully disagree. We had a lot of contention for real IETF slots at this meeting, and I don't want to see folks fall back to non-WG meetings.

--Paul Hoffman, Director
--VPN Consortium

---

From: Michael Richardson <[email-masked]>
Date: Thu, 05 Aug 2010 10:51:04 -0400

>>>>> "Paul" == Paul Hoffman <[email-masked]> writes:

    Paul> I don't think the MP3 streaming happens after the last regular
    Paul> meeting is finished. The mics had been removed from the rooms
    Paul> well before the nonBoFs happened in Maastricht.

    >> - the secretariat should consider having one fewer regular track

    Paul> Fully disagree. We had a lot of contention for real IETF slots
    Paul> at this meeting, and I don't want to see folks fall back to
    Paul> non-WG meetings.

Yes there certainly is contention, but I know at least one WG that did
not use one of their two slots. 

I also experienced a number of WGs (all remote) where there were
multiple presentations which were:
         a) not related to any draft I could find.
         b) not uploaded beforehand.
         c) not clearly related to any action of the WG.

(no Paul, none of them in IPSECME)

I contend that we use our in-person meeting time very poorly, and that
we need less meeting time, not more.

Providing an outlet for presentations like this would, I think, make it
easier for WG chairs to stick to the action items at hand.

---

From: Joel Jaeggli <[email-masked]>
Date: Thu, 05 Aug 2010 09:57:04 -0700

>     Paul> well before the nonBoFs happened in Maastricht.

normally it actually streams all night. In maastricht the due to thefts
from the facility during setup we removed the recorders every night
after the last session.

---

From: Ralph Droms <[email-masked]>
Date: Fri, 6 Aug 2010 08:45:10 -0400

One of the contributors, in my opinion, to the evolution of an "ad hoc meeting in a bar" to "Bar Bof" as Fred defines it has been a series of small actions, intended to facilitate the organization ad hoc meetings, that have had the unintended consequence of increasing the apparent close relationship between a Bar BoF, an IETF meeting and the WG formation process:

Specifically:

* AD attendance at Bar Bofs
  Intention (at least speaking for myself): early awareness
  Unintended consequence: formal invitations and expected attendance
* scheduling unused meeting rooms during IETF meetings, usually
    over lunch or after 
  Intention: avoid the overhead of finding a non-conficting
    space for a meeting
  Unintended consequence: Extra admin overhead for IETF secretariat;
    Bar BoFs look more like formally scheduled IETF events
* conversation about Bar BoF scheduling on IETF mailing lists
  Intention: 
  Unintended consequence: Bar BoFs are widely advertised and many
    of attendees are in listen-only mode
* posting of Bar Bof logistics on an IETF wiki
  Intention: central location for Bar BoF logistics
  Unintended consequence: Bar BoFs look more like formally scheduled
    IETF events

I will confess to describing a problem here without suggesting an associated solution.  It's hard to support banning any one of these actions taken individually.  Taken together, they seem to move us away from ad hoc meetings to an unplanned additional layer of formalism in our process.

- Ralph

On Jul 29, 2010, at 4:00 PM 7/29/10, Fred Baker wrote:

> [...]
> Let me explain what a Bar BOF is, and what it is not. Our formal BOFs are scheduled with an AD, and are generally for formalizing a charter. The assumption is that a prior ad hoc process, usually on a mailing list or via telephone or conferencing systems has happened, and a work item has matured to the point that we have interested people, proto-specifications or at least problem statements, and so on.
> 
> The initiation point of that is often-but-not-always a handful of people talking over a meal or in a bar on a topic, often having convened mere moments before. Sketches might be drawn on napkins, and people that are hungry or thirsty have a waiter/waitress at hand to deal with that. A Bar BOF, as such small gatherings are called, is *not* a full-blown meeting of perhaps hundreds of people placed at a mealtime but in a place that prevents them from eating. It does not require powerpoint, and is not a catered event. It is not ten minutes stolen from some other subject. Key concept: we respect each other and each other's time, and so we meet in a place that has food and drink, and we have an intimate conversation among people who will be interested to carry on some work item. 
> 
> [...]
>

---

From: Edward Lewis <[email-masked]>
Date: Fri, 6 Aug 2010 09:09:17 -0400

At 22:00 +0200 7/29/10, Fred Baker wrote:

>If we're going to continue this avalanche of ad hoc meetings that we call
>"Bar BOFs", I would recommend that the Secretariat provide a web page for
>requesting them. The title of the web page should be "Poorly Planned
>Meetings" or something like that.

In Anaheim I organized of such meetings.  To add as a data point...

The principle rationale for the meeting was that a sizeable mass of 
interested parties were at the IETF, interested in a particular set 
of issues that is.  (Not necessarily a critical mass but enough to 
make this interesting.)

The reason for requesting a meeting space was primarily acoustics, I 
find it increasingly (as I get older) to hear in a noisy environment 
such as a bar or lunch room.

The outcome of the meeting was not to organize any activity in the 
IETF, not at this time at least.  Activity did out of the meeting, 
but after further discussions in other venues (e.g., CENTR), it was 
felt that there wasn't work to bring to the IETF.  (The issues 
crossed protocol and operations, when operators were presented with a 
plan to update a protocol, it was decided the plan meant too much 
work and the protocol was fine as is.)

The expectations of the meeting were met, and it proved quite useful. 
With the result being "no work for the IETF" I would have considered 
it a loss to have to have followed a formal process for a simple 
gathering.

-- 
-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
Edward Lewis
NeuStar                    You can leave a voice message at +1-571-434-5468

Spouses, like Internet protocols, lack necessary troubleshooting tools. Sigh.

---

From: Arnt Gulbrandsen <[email-masked]>
Date: Fri, 6 Aug 2010 16:24:21 +0200

On 08/06/2010 02:45 PM, Ralph Droms wrote:
> I will confess to describing a problem here without suggesting an associated solution.

The natural consequence of your mail seems to be to allow attendees to 
book spare space at IETF events. Suggested rules:

  1. Space is booked by an individual (or up to two, perhaps).
  2. The IETF keeps no plan or record of the usage.
  3. If an IETF activity needs the space, out goes the individual.
  4. The meeting web site shows a map of the free rooms.
  5. Large rooms aren't available, only ones.

Arnt

---

From: Yoav Nir <[email-masked]>
Date: Sun, 8 Aug 2010 11:25:04 +0300

>  - the secretariat should consider having one fewer regular track

One of the goals is to get these non-WG items out of people's lunch hours, so that we can spend them on what lunch hours should be spent: lunch, and wondering why someone's walking around with a note stand. So yes, I agree that they should be scheduled at the same time as regular meetings. The reason the presenter should be allowed to pick the slot within the sessions is so that his presentation doesn't collide with a WG session where all his target audience is going to be.

Reality is though, that the Friday and late Thursday slots are not popular, because some people want to go home either early Friday or even Thursday night. Unless they actually make it harder for working groups to meet, it won't be easy.

> (Honestly, can we please use PDF for all slides?)

Some people like animation and flying bullet points. Once I tried to give a presentation written in OpenOffice, then saved as .ppt. Instead of flying in, the bullet points appeared, then flew out. Since then I always export to PDF, but some people like the animation.

> later on, from the "archives"

Just as true for WG meetings.

> should I think, not take the time of the group.

The availability of this venue, would tempt WG chairs to tell people to "take it to the Berlin track", for things they don't like. But if something is a certificate profile, or an update to PKCS #something, it should go in PKIX, rather than act as though there's no WG working on PKI. I don't think our aim should be to gather support, so that later we can shove the work item down the working group's throat, or else use this as a light-weight working group, giving a presentation with an update since last meeting. Hmm, I'll explicitly prohibit this in the next iteration of the draft.