Subject: Re: Is this true?

From: [email-masked] (Noel Chiappa)
Date: Tue, 31 Aug 2010 13:54:33 -0400 (EDT)

> From: Fernando Gont <[email-masked]>

    > As far as I recall *reading* (I wasn't around at the time :-) ) email
    > was a couple of FTP commands? 

That was more back in the NCP days (prior to TCP/IP). SMTP came in about the
time TCP/IP was really starting to roll (don't recall the exact timing, but
it would have been circa 1980 or so).

	Noel

---

From: Bob Braden <[email-masked]>
Date: Tue, 31 Aug 2010 12:21:52 -0700

The history of the development of email protocols is contained in the 
RFC series.  Those interested might for example look at RFCs 196, 458, 
524, 772, and 788.

Bob Braden

On 8/31/2010 10:54 AM, Noel Chiappa wrote:
>      >  From: Fernando Gont<[email-masked]>
>
> _______________________________________________
> Ietf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf

---

From: John C Klensin <[email-masked]>
Date: Tue, 31 Aug 2010 15:24:43 -0400

--On Tuesday, August 31, 2010 13:54 -0400 Noel Chiappa
<[email-masked]> wrote:

>     > As far as I recall *reading* (I wasn't around at the
> time :-) ) email     > was a couple of FTP commands? 
> 
> That was more back in the NCP days (prior to TCP/IP). SMTP
> came in about the time TCP/IP was really starting to roll
> (don't recall the exact timing, but it would have been circa
> 1980 or so).

Yes.

But, regardless of whether one counts from FTP-based email or
from SMTP, the statement that email was the only application is
simply nonsense.  Telnet was alive and well, FTP was heavily
used (and I trust it is obvious that we could have had FTP-based
email without FTP), user and system information protocols like
finger and whois were around and in use, and so were a bunch of
things that are "applications" or not depending on one's
definitions and a fairly large collection of applications (not
just applications-support protocols) built directly on TCP (or
NCP, or later on various socket layers) whose descriptions never
made it into the RFC series.

     john

---

From: Dave CROCKER <[email-masked]>
Date: Tue, 31 Aug 2010 11:22:06 -0700

On 8/31/2010 10:54 AM, Noel Chiappa wrote:
>      >        email

SMTP was defined in 1982.  So was the DNS.  It took both some years to gain 
production levels of use of each.  The Internet's TCP/IP had code start running 
in 1976 and went into production operation in 1983.

Hence there was a period of time during which the Internet relied on the 
original FTP-based mail commands.  SMTP's primary enhancement was support for 
multiple addressees per transaction.  By and large, this improvement was 
invisible to email users.

d/
-- 

   Dave Crocker
   Brandenburg InternetWorking
   bbiw.net

---

From: Dave CROCKER <[email-masked]>
Date: Tue, 31 Aug 2010 12:48:28 -0700

On 8/31/2010 12:21 PM, Bob Braden wrote:
>
> The history of the development of email protocols is contained in the RFC
> series. Those interested might for example look at RFCs 196, 458, 524, 772, and
> 788.

One of the myths that these early RFCs dispel is that email was a casual 
addition to FTP.  I got involved in time for the very last FTP meeting, so I 
wasn't privy to any of the email discussions.  I had heard a rumor that email 
got added as a result of a Saturday night's casual suggestion of an MIT grad 
student who happened to be passing by Abhay Bhushan's office -- he authored the 
FTP spec.  About 10 years ago he reassured me that the real story was nothing 
like that.  These RFCs bear that out.

d/
-- 

   Dave Crocker