Subject: RFC levels and I-D "levels"

From: Yaron Sheffer <[email-masked]>
Date: Fri, 13 Nov 2009 13:42:32 +0200

Hi everyone,

I'd like to support the notion that standards levels for RFCs simply do not matter. In my own domain (IPsec), we try to spend time on keeping the protocol viable (by adding useful stuff and trying to avoid cruft) rather than working on mostly pointless PS->DS->FS projects. Whether we're doing a good job is for others to judge...

On the other hand, I think we're not doing well on the other side of the spectrum, Internet Drafts. The industry and even other SDOs (3GPP is a case in point) are too happy to implement expired drafts, which as we know may be lower quality, less secure, and/or non-interoperable. In fact in recent years we have made it even easier to access and use long expired drafts, and this is hurting us. I'd like to make two related proposals to deal with this issue:

-          Make the "tools" URL for an I-D into the mainstream way to access I-Ds. Specifically, include this URL in the I-D announcement mail. This would have the benefit of pointing people to related RFCs and to relevant IPR statements.
-          Only non-expired drafts should be directly accessible from the tools area, or in fact have a stable IETF URL. Expired drafts will still be kept around, but will require a (freely available) "tools" login. So non-IETFers will have to spend 5 minutes' effort to reach them.

This would go a long way towards having I-Ds as temporary documents, like they used to be, while still letting us work with the old documents when necessary.

Thanks,
            Yaron

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 14 Nov 2009 11:41:54 +1300

Yaron,

> -          Only non-expired drafts should be directly accessible from the tools area, or in fact have a stable IETF URL.

Everything at tools.ietf.org is volunteer-maintained and unofficial.
That's why the I-D announcements contain the URL that they do, which
only allows you to recover the given version until it expires or is
updated.

If you quote http://tools.ietf.org/id/draft-something or
http://tools.ietf.org/html/draft-something *without* the version
number, you get the latest version. That's what I usually quote for
external (non-IETF) use, so that the recipient will always see the
latest.

> Expired drafts will still be kept around, but will require a (freely available) "tools" login.

This would be highly inconvenient, and the Google cache defeats its purpose
anyway.

I think we have an ideal setup right now (for I-Ds that is; I have
given up worrying about the standards track, since the IETF is clearly
incapable of consensus on this aspect).

    Brian