Subject: Re: ISSN for RFC Series under Consideration

From: John C Klensin <[email-masked]>
Date: Thu, 22 May 2008 08:51:33 -0400

bbbbbb

--On Thursday, 22 May, 2008 07:18 -0400 Melinda Shore
<[email-masked]> wrote:

> On 5/22/08 2:01 AM, "Ed Juskevicius" <[email-masked]> wrote:
>> I believe that getting each RFC cataloged individually would
>> not be possible using an ISSN, so we would need to employ
>> ISBNs.
> 
> No, not necessarily.  A serial published as a serial
> ("The Bulletin of the Singapore Guppy Society") is cataloged
> as such, while a monograph series that has an ISSN may have the
> monographs cataloged individually (this is under the Anglo-
> American Cataloging Rules rev 2, and there may be some national
> variations).  
> 
> Getting an ISSN in no way prevents individual RFCs from being
> cataloged individually.

Of course not.  It doesn't even prevent individual RFCs, or
clusters of RFCs, being assigned ISBNs or, if one feels like
setting them to music or performing them in public and releasing
audio or video of those forms ISMNs or ISANs (the assorted
acronyms are left as an exercise for the reader).

Indeed, another way of looking at this question is that deciding
to register an ISSN for the RFC series really does not preclude
anything else (including, were we so inclined, putting DOIs on
each RFC) and we should therefore be asking "ISSN or not ISSN"
with all questions about other sorts of identifiers and
cataloging being viewed as separate.   Stated that way, I think
the answer to the ISSN question is pretty close to "some
advantages, very low cost, no possible reason why not"

      john

_______________________________________________
IETF mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ietf

---

From: Melinda Shore <[email-masked]>
Date: Thu, 22 May 2008 09:12:03 -0400

On 5/22/08 8:51 AM, "John C Klensin" <[email-masked]> wrote:
> cataloging being viewed as separate.

I think the cataloging question is probably central to the
question of whether or not to bother with an ISSN.  I don't
think an ISSN has any practical value other than that it
increases the likelihood that LC will catalog the series/
serial and that libraries will then start sticking it into
their electronic holdings.  Now, I'm not sure I see an
advantage to getting libraries to pick up RFCs given how
trivial it is to find them online, but that's another matter.
Another advantage is discrimination in the event that some other
serial publication is also called "Request for Comments," but
again I'm not sure that's an actual problem.  But mainly,
getting an ISSN gets the series into the library system.

Melinda

---

From: Steve Crocker <[email-masked]>
Date: Thu, 22 May 2008 09:20:33 -0400

Every so often someone suggests RFCs are not first class documents  
and hence not comparable to, say, "real" standards documents.   
Getting traditional identifiers attached to them might squelch some  
of this nonsense.

Steve

---

From: John C Klensin <[email-masked]>
Date: Thu, 22 May 2008 09:20:55 -0400

bb

--On Thursday, 22 May, 2008 09:12 -0400 Melinda Shore
<[email-masked]> wrote:

> Another advantage is discrimination in the event that some
> other serial publication is also called "Request for
> Comments," but again I'm not sure that's an actual problem.
> But mainly, getting an ISSN gets the series into the library
> system.

Melinda,

It is my understanding (more or less third-hand and I no longer
remember the details) that we've been asked about an ISSN by
other bodies, perhaps bodies who are concerned about the exact
discrimination problem you identify.  I believe that at least
one of those bodies was an academic journal or other standards
body that was queasy about referencing RFCs by URL only.  

The problem for them is, of course, not _finding_ the RFCs but
knowing that something that they find is authoritatively part of
the IETF/ RFC-Editor RFC series.  Whether they should or not,
ISSNs are official enough to make them less anxious about that
type of question.

     john

---

From: Marshall Eubanks <[email-masked]>
Date: Thu, 22 May 2008 09:54:14 -0400

> getting an ISSN gets the series into the library system.

It is easy to find RFC's now, but it may not be in a century.

This may seem silly, but I think that RFCs will still have relevance  
in a century and,
having experience searching for 100+ year old astronomical  
publications and data,
in my opinion, RFC's need to be cataloged in libraries.

Libraries have running code for the maintenance of
intellectual property over centuries; the IETF does not.

Regards
Marshall

---

From: "Ed Juskevicius" <[email-masked]>
Date: Thu, 22 May 2008 10:15:09 -0400

Steve:

> Every so often someone suggests RFCs are not first class
> documents and hence not comparable to, say, "real"
> standards documents. Getting traditional identifiers attached
> to them might squelch some of this nonsense.

I have the impression that we would be pioneering the use of an ISSN to
identify a standards' series, if we choose to do this.  The "real"
standards from other organizations seem to be identified with individual
ISBNs.

Would the purveyors of nonsense be squelched by an ISSN, or emboldened?
Some might cite our decision as yet another example of the IETF doing
something different and 'non-standard'.

Marshall, to your point:

> This may seem silly, but I think that RFCs will still
> have relevance in a century and, having experience
> searching for 100+ year old astronomical publications
> and data, in my opinion, RFC's need to be cataloged in
> libraries.
>

I agree with you 100%.  I think this is indeed a tangible and desirable
objective.

Best Regards,

Ed  J.

---

From: Marshall Eubanks <[email-masked]>
Date: Thu, 22 May 2008 11:00:45 -0400

On May 22, 2008, at 10:35 AM, John C Klensin wrote:

>
>
> --On Thursday, 22 May, 2008 10:15 -0400 Ed Juskevicius
> <[email-masked]> wrote:
>
>> Steve:
>>
>> I have the impression that we would be pioneering the use of
>> an ISSN to identify a standards' series, if we choose to do
>> this.  The "real" standards from other organizations seem to
>> be identified with individual ISBNs.
>
> If all RFCs were standards, this would be a good argument.
> However, the RFC series contains Standards, various types of
> substandards for which those other bodies either have no
> equivalents or publish differently, experimental protocol
> specifications, BCP statements, and an assortment of
> informational documents.   What an ISSN identifies is the
> series, not the individual documents, and that series is _not_ a
> "standards series".
>
> My impression is that this type of application is not
> particularly novel.   More on that next week.
>
> As I indicated in my note to Melissa, having an ISSN for the
> series would not prevent obtaining ISBNs and/or DOIs for
> selected individual documents, so those ideas are really
> completely separate questions.
>
>> Would the purveyors of nonsense be squelched by an ISSN, or
>> emboldened? Some might cite our decision as yet another
>> example of the IETF doing something different and
>> 'non-standard'.
>
> Very unlikely.  At worst, we would be "accused" of illustrating
> ways in which an existing standard mechanism can be carried
> forward in interesting ways into the modern Internet age.   On
> the other hand, if we treat RFCs as basically paper (and
> page-format) publications that are freely available online as I
> suggested in an earlier note, this becomes that most routine of
> applications.
>

Here is a concrete suggestion.

We (for some definition of we) have the Internet Journal, which is  
paper.
Publish a "Supplement of the Internet Journal," in paper, or on line,  
which is

- physically published 3 times a year
- has all of the RFC's published since then
- includes the level 1 RFC errata as available
- includes other notes like RFC's that have been made obsolete, etc.
- charge it to cover costs at least (say, $ 500 / year for a  
subscription).

This would be picked up by at least some libraries, and would solve  
the "on-line is ephemera" problem.

Regards
Marshall

>> I agree with you 100%.  I think this is indeed a tangible and
>> desirable objective.
>
> Indeed.  And libraries, especially the subset of libraries that
> have national archival responsibilities, do pay attention to
> these identifiers.
>
>      john
>

---

From: John C Klensin <[email-masked]>
Date: Thu, 22 May 2008 10:35:17 -0400

john

---

From: John C Klensin <[email-masked]>
Date: Thu, 22 May 2008 11:18:19 -0400

--On Thursday, 22 May, 2008 11:00 -0400 Marshall Eubanks
<[email-masked]> wrote:

> We (for some definition of we) have the Internet Journal,
> which is   paper.
> Publish a "Supplement of the Internet Journal," in paper, or
> on line,   which is
> 
> - includes other notes like RFC's that have been made
> obsolete, etc. - charge it to cover costs at least (say, $ 500
> / year for a   subscription).
> 
> This would be picked up by at least some libraries, and would
> solve   the "on-line is ephemera" problem.

Marshall,

I think this is an interesting idea.   It is, however, one that
would require some staffing, budget, working with ISOC on
arrangements, etc.  I don't see any of those things as a big
deal, but I could be wrong.   And they are certainly a bigger
deal than assigning an ISSN number and, if necessary, simply
running a printer and stuffing an envelope (as Bill suggested,
we've actually done that in the more or less distant past).

So my constructive suggestions are

(i) Let's not make this hard for ourselves.

(ii) Assigning an ISSN to the series would not interfere, in any
way, with what you suggest should the demand be there, either
for library subscriptions, as an added symbolic benefit for some
level of ISOC membership, or both.   And, for some of the
purposes for which an ISSN for the RFC series would be a good
idea, assigning that number to a compendium that includes
non-RFC materials would be self-defeating.

(iii) As someone suggested earlier in this thread, the IETF
Journal should probably have an ISSN of its own, but that is a
quite separate issue.

regards,
    john

---

From: Bob Braden <[email-masked]>
Date: Thu, 22 May 2008 10:08:19 -0700

>- has all of the RFC's published since then

The average RFC is 30 pages, and the average publication rate
is O(30) per month.  That seems to work out to 3600 pages to
be published with each Internet Journal.

Bob Braden

---

From: Marshall Eubanks <[email-masked]>
Date: Thu, 22 May 2008 21:25:00 -0400

>> - has all of the RFC's published since then

I meant, of course, since the last one.

> be published with each Internet Journal.

Or order 10^4 pages per year for the Supplement.

BTW, it strikes me as interesting that in the physical archives of the  
IETF Trust there are
zero pages of printed RFCs. There are the cut and paste-on-paper  
viewgraph originals from IETF-1, but no printed
RFC's.

Regards
Marshall

Regards
Marshall

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Fri, 23 May 2008 15:03:05 +0200

On Thu, May 22, 2008 at 09:20:33AM -0400,
 Steve Crocker <[email-masked]> wrote 

> and hence not comparable to, say, "real" standards documents.

That's interesting because not all other SDO do it. ISO, mother of the
ISSN standard, does not use it in this way... ISO standards are
referenced by an ISO-specific syntax (such as "ISO 3297:2007", which
does not seem very different from the syntax "RFC 5141").

---

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Fri, 23 May 2008 07:49:03 -0700

Some points:

1) If the objective is to have a URN for RFCs this has already been done:

RFC 2648: http://www.ietf.org/rfc/rfc2648.txt "A URN Namespace for IETF Documents"

These identifiers must be the canonical identifiers for the RFC series. But they need not be the only identifiers.

2) Schemes which rely on paying registrars to sell people numbers are probably unsustainable in the long run unless there is a business reason to use that specific number.

This is certainly the case for IP numbers. I don't see the business reason for this particular application. Hence I don't see a value in purchasing a DOI identifier at the reported $1500/annum or for accepting one for free use. I would consider that to be an endorsement and I don't think that the IETF or ISOC should get any further into that game than it alrady has.

3) Whether the documents are paper or digital is now irrelevant. Dead tree publication technology will certainly disappear at some point. My book sells in both paper and Kindle editions. The killer application of Kindle appears to be sale of periodicals and newspapers rather than just books.

The industry has a clear business need and so they will apply ISSNs to this new field regardless of what the rules might say on the matter. 

4) ISSNs are used in the library system. They are used in the Z39.50 protocol which is the principal protocol used to support that infrastructure today. I think we should get one.

5) This topic is a very interesting one and thus one on which a large number of people may have an opinion. The problems raised in the ESDS BOF are very similar.

Because it is an area where many people may have an opinion it appears to me that the decisive technical breakthrough we might need in this area might well be to develop a technology that allows people to have separate opinions in this area and not attempt to impose more homogeneity than is actually required.

---

From: Marshall Eubanks <[email-masked]>
Date: Fri, 23 May 2008 10:54:22 -0400

Dear John;

> we've actually done that in the more or less distant past).

It would certainly not be free. And, if you look at the prices for  
"Supplements," the
per page cost tends to be high.

For example, for "The Astrophysical Journal Supplement", a US  
subscription is $ 200 / year
for a print copy, $ 28 for an on-line copy, for a journal printed on  
archival quality paper.
The ApJ Supplement is about 300 pages / month or 3600 per year, for a  
per page cost of about 5.5 cents
per page. The Internet Journal Supplement, with ~ 10^4 pages per year,  
would be ~ $ 556 / year
for the same per page cost. The ApJ Supplement also provides editorial  
support which in this case
is already paid for.

What I would recommend before anything is done is that some  
_Librarians_ be asked for their
opinion as to how to best get the RFC series archived in libraries.

Regards
Marshall

---

From: Marshall Eubanks <[email-masked]>
Date: Fri, 23 May 2008 11:30:45 -0400

On May 23, 2008, at 10:49 AM, Hallam-Baker, Phillip wrote:

> These identifiers must be the canonical identifiers for the RFC  
> series. But they need not be the only identifiers.
>
> 2) Schemes which rely on paying registrars to sell people numbers  
> are probably unsustainable in the long run unless there is a  
> business reason to use that specific number.
>
> This is certainly the case for IP numbers. I don't see the business  
> reason for this particular application. Hence I don't see a value in  
> purchasing a DOI identifier at the reported $1500/annum or for  
> accepting one for free use.
>
That was $ 1500 per annum for a block of 9,999. It is a little more  
complicated - see

http://www.usdoi.org/index.php?page=DOI_prefix

The cost for a prefix for 9,999 RFC's would be

- $ 250 up front
- $ 1500 for the block

or a continuing charge of less than $ 1 / RFC / year.

I am not advocating DOI's, just reporting on what is entailed. Note  
that this is not the only registrar; others may be more or less  
expensive.

Regards
Marshall

> I would consider that to be an endorsement and I don't think that  
> the IETF or ISOC should get any further into that game than it  
> alrady has.
>
> 3) Whether the documents are paper or digital is now irrelevant.  
> Dead tree publication technology will certainly disappear at some  
> point. My book sells in both paper and Kindle editions. The killer  
> application of Kindle appears to be sale of periodicals and  
> newspapers rather than just books.
>
> The industry has a clear business need and so they will apply ISSNs  
> to this new field regardless of what the rules might say on the  
> matter.
>
> 4) ISSNs are used in the library system. They are used in the Z39.50  
> protocol which is the principal protocol used to support that  
> infrastructure today. I think we should get one.
>
>
> 5) This topic is a very interesting one and thus one on which a  
> large number of people may have an opinion. The problems raised in  
> the ESDS BOF are very similar.
>
> Because it is an area where many people may have an opinion it  
> appears to me that the decisive technical breakthrough we might need  
> in this area might well be to develop a technology that allows  
> people to have separate opinions in this area and not attempt to  
> impose more homogeneity than is actually required.
>

---

From: "Frank Ellermann" <[email-masked]>
Date: Fri, 23 May 2008 18:53:35 +0200

Stephane Bortzmeyer wrote:

> ISO standards are referenced by an ISO-specific syntax 
> (such as "ISO 3297:2007", which does not seem very 
> different from the syntax "RFC 5141").

FWIW ISO created an URN recently, see urn:ietf:rfc:5141
or <http://purl.net/net/rfc/5141> 
or <http://tools.ietf.org/html/rfc5141>

 Frank