Subject: Re: IETF Website Redesign Effort

From: Stephane Bortzmeyer <[email-masked]>
Date: Wed, 7 May 2008 16:57:05 +0200

On Wed, May 07, 2008 at 07:23:41AM -0700,
 Alexa Morris <[email-masked]> wrote 
 a message of 33 lines which said:

> We are inviting the first ten (10) interested members of the IETF
> community who respond to this email to become a part of the website
> redesign team. If you are interested in assisting with this effort,
> please respond to this email as soon as possible.

It is no longer "rough consensus and running code", it is now "quick
click and no SMTP latency".

_______________________________________________
IETF mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ietf

---

From: Russ Housley <[email-masked]>
Date: Wed, 07 May 2008 16:11:14 -0400

>click and no SMTP latency".

This approach was taken at my suggestion.

These early reviewers are so that the Secretariat can get some 
feedback about the new design without have a large number of people 
pile on.  Think of it as a product test group.  Once these folks are 
comfortable that the new design is an improvement, there will be an 
opportunity for broader comment.

Russ
IETF Chair

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 08 May 2008 10:11:31 +1200

> opportunity for broader comment.

I have to say, though, that it was discriminatory against people
living in certain time zones, unless they happened to be on line
at 2:23 a.m....

I would suggest that a few principles of the redesign should be
written down and sent out for comment first. From some previous
email with Alexa, I believe the principles she has in mind are
good ones, but it would be nice to have consensus.

Lest any of that sounds like a complaint, I'm delighted to
see this effort starting.

    Brian

---

From: Song Haibin <[email-masked]>
Date: Thu, 08 May 2008 09:25:02 +0800

I'd like to contribute some time to do the product test. Interesting work,
isn't it?

Best Regards,
Song Haibin
Email: [email-masked]

>-----Original Message-----
>From: [email-masked] [mailto:[email-masked]] On Behalf Of
Russ
>Housley
>Sent: Thursday, May 08, 2008 4:11 AM
>To: Stephane Bortzmeyer
>Cc: [email-masked]
>Subject: Re: IETF Website Redesign Effort
>
>Stephane:
>

---

From: Song Haibin <[email-masked]>
Date: Thu, 08 May 2008 09:46:34 +0800

Withdraw my words. I just noticed that I was late, because the original
email was received at midnight here.

Best Regards,
Song Haibin

>From: [email-masked] [mailto:[email-masked]] On Behalf Of
Song
>Haibin
>Sent: Thursday, May 08, 2008 9:25 AM
>To: 'Russ Housley'; 'Stephane Bortzmeyer'
>Cc: [email-masked]
>Subject: RE: IETF Website Redesign Effort
>

---

From: Mark Nottingham <[email-masked]>
Date: Thu, 8 May 2008 11:52:53 +1000

The message on-announce was worded as if these people would be  
*performing* the redesign, but I read your message below as saying  
that they'll serve a a pool of testers.

I sincerely hope the truth is closer to the latter...

--
Mark Nottingham     http://www.mnot.net/

---

From: "Eric Gray" <[email-masked]>
Date: Thu, 8 May 2008 07:08:53 -0500

Mark,

	Unfortunately, the way I read this, it is effectively not
the latter.  The impression I am left with is that 10 volunteers
are being asked for feedback on changes.  Assuming this is an
iterative process, their collective feedback could have almost
any arbitrary degree of impact on the final result - depending
on how well developed the current plan is and how responsive the
change makers expect to be to feedback.

	Hence the value of Brian's observation that there should
be some effort to determine if the general outline of planned
changes is something that most people agree to.

	Also, as has been politely hinted at already, the sample
selection method is likely to "poison" the sample.  Why the first
10 starting from a specific message at a specific time convenient
to only a narrow set of time zones?  Why only 10?  Why publish 
the names of the victim^H^H^H^H^Holunteers?  None of these seem
to be the sort of factors one would like to see in getting a 
reasonable cross section of the (probably) tens of thousands of
people who use the IETF website on a regular basis (where is that 
visitor counter, or the web-site at the moment, anyway?).

--
Eric Gray
Principal Engineer
Ericsson  

> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Mark Nottingham
> Sent: Wednesday, May 07, 2008 9:53 PM
> To: Russ Housley
> Cc: [email-masked]

---

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Thu, 8 May 2008 13:25:16 -0700

Actually this represents currently accepted engineering practice in the
usability field.

According to Nielsen you can identify 80% of issues with small scale
studies of 5 people. The point here is not to create a statistically
representative sample, it is to identity the chief issues that may be of
concern.

You should always do a pre-survey before you do the main run or else you
will fail to ask the right questions.

Now I do have a big problem with the practice of publishing 'scientific
studies' on the basis of small sample sizes. You can get a paper
published in the security usability field on the basis of three samples
of 9 persons each. That is actually one of the larger studies. But that
is a different matter and in any case they have rather more
methodological issues to deal with than sample size.

> Behalf Of Eric Gray
> Sent: Thursday, May 08, 2008 8:09 AM
> To: Mark Nottingham
> Cc: [email-masked]
> 	Unfortunately, the way I read this, it is effectively 
> not the latter.  The impression I am left with is that 10 
> volunteers are being asked for feedback on changes.  Assuming 
> this is an iterative process, their collective feedback could 
> have almost any arbitrary degree of impact on the final 
> result - depending on how well developed the current plan is 
> and how responsive the change makers expect to be to feedback.
> 
> 	Hence the value of Brian's observation that there 
> should be some effort to determine if the general outline of 
> planned changes is something that most people agree to.
> 
> 	Also, as has been politely hinted at already, the 
> sample selection method is likely to "poison" the sample.  
> Why the first 10 starting from a specific message at a 
> specific time convenient to only a narrow set of time zones?  
> Why only 10?  Why publish the names of the 
> victim^H^H^H^H^Holunteers?  None of these seem to be the sort 
> of factors one would like to see in getting a reasonable 
> cross section of the (probably) tens of thousands of people 
> who use the IETF website on a regular basis (where is that

---

From: Hadriel Kaplan <[email-masked]>
Date: Sat, 10 May 2008 01:09:13 -0400

I realize the point of getting a small group of people as lab rats is to get a first pass before the deluge, but I have just a couple very quick questions that you can ignore as spam. :)

1) What is the scope of the redesign?  Is it just www.ietf.org, or does it include tools, datatracker, and rfc-editor?
2) Will it include the mail-archive's interface?
3) Can it please, for the love of humanity, fix the agenda pages created for every IETF meeting that have an http-linked background image inside https-served pages?  The browser security warning pop-ups triggered by that are ever so annoying.

-hadriel
p.s. and thank you sincerely for doing a redesign!
_______________________________________________
IETF mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ietf

---

From: "Sivasubramanian Muthusamy" <[email-masked]>
Date: Sun, 11 May 2008 18:58:40 +0530

hello

I wish to join this team and contribute to the IETF website redsign.

Thank you.
Sivasubramanian Muthusamy
India.