Subject: Random Network Endpoint Technology (RNET)

From: Chad Giffin <[email-masked]>
Date: Wed, 21 May 2008 17:09:54 -0400

The following is an explanation of how to accomplish setting up a path of communication between two RNET Hosts. Some of you may have already figured this out... now you have the definitive answer.Consider this; You have two RNET Hosts, host A and host B. Both hosts wish to communicate with each other. Since both used un-advertised IP addresses, this seems impossible. The solution is to setup a route path between them so that the routers between them will forward packets destined for each of the two hosts. The operator of host A must contact the operator of host B through some other means of communication. The operator of host A need only acquire the, advertised, IP address of host B's gateway. Once this is done, host A sends an RNET Route Request specifying the host B's address as the target address and directs this request to the gateway of host B. The result is that all the routers in between host A and host B will have setup an RNET Route entry for host A as the RNET Host and with host B as the Target Host. At this point either host may initiate contact with the other as the routers between them will know where to forward their packet(s).I hope this clears up any confusion or misunderstanding (or lack thereof.)If you have any suggestions or comments, please feel free to email me directly at mailto:[email-masked].
 
Sincerely,

Chad Christopher Giffin
T-Net Information Systems
(a.k.a. "typo")
_________________________________________________________________
If you like crossword puzzles, then you'll love Flexicon, a game which combines four overlapping crossword puzzles into one!
http://g.msn.ca/ca55/208

_______________________________________________
IETF mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ietf

---

From: [email-masked]
Date: Wed, 21 May 2008 21:49:24 +0000

So we have reinvented STUN?
Sent from my Verizon Wireless BlackBerry

-----Original Message-----
From: Chad Giffin <[email-masked]>

Date: Wed, 21 May 2008 17:09:54 
To:<[email-masked]>
Cc:[email-masked], [email-masked]
Subject: Random Network Endpoint Technology (RNET)

The following is an explanation of how to accomplish setting up a path of communication between two RNET Hosts. Some of you may have already figured this out... now you have the definitive answer.

Consider this; You have two RNET Hosts, host A and host B. Both hosts wish to communicate with each other. Since both used un-advertised IP addresses, this seems impossible. The solution is to setup a route path between them so that the routers between them will forward packets destined for each of the two hosts. 

The operator of host A must contact the operator of host B through some other means of communication. The operator of host A need only acquire the, advertised, IP address of host B's gateway. Once this is done, host A sends an RNET Route Request specifying the host B's address as the target address and directs this request to the gateway of host B. The result is that all the routers in between host A and host B will have setup an RNET Route entry for host A as the RNET Host and with host B as the Target Host. At this point either host may initiate contact with the other as the routers between them will know where to forward their packet(s).

I hope this clears up any confusion or misunderstanding (or lack thereof.)

If you have any suggestions or comments, please feel free to email me directly at mailto:[email-masked] <mailto:[email-masked]> .
  
 Sincerely,

 Chad Christopher Giffin

----------------

---

From: Melinda Shore <[email-masked]>
Date: Wed, 21 May 2008 17:55:57 -0400

> So we have reinvented STUN?

This is probably closer to Paul Francis's NUTSS stuff without
the cool crankback and especially without resolving the location
problem.

Melinda

---

From: Dean Willis <[email-masked]>
Date: Wed, 21 May 2008 20:19:59 -0500

> So we have reinvented STUN?

No, we've moved the state of STUN into each of the routers between the  
two hosts, and have to hope we don't have a route flap somewhere.

It's sort of like RSVP.

--
Dean

---

From: Scott Brim <[email-masked]>
Date: Wed, 21 May 2008 20:27:06 -0700

> the cool crankback and especially without resolving the location

With NUTSS the destination is (probably) seen in routing from the
start, but signaling is required to set up a desirable path.  Here the
problem is that neither source nor destination is globally routed.

I'm concerned about scaling.  That's a lot of dynamic state in the
core routers, precisely where we don't want it.  He's probably better
off source-routing.  See NIMROD
<http://ana-3.lcs.mit.edu/~jnc/nimrod/docs.html> and remember what it
stands for! :-)

He should also see the proposals in the Routing Research Group
<http://www3.tools.ietf.org/group/irtf/trac/wiki/RoutingResearchGroup>

swb