Subject: RE: [Ltru] Last call comments on LTRU registry and initialization documents

From: "Addison Phillips" <[email-masked]>
Date: Fri, 9 Sep 2005 14:15:26 -0700

Hi John,

Thanks for your note back. First I'll respond to a trivial item and then, separately, to the STD/BCP question.

You wrote:
> (ii)
> The idea of using a registry of components (in this case
> subtags) that can be mixed and matched at the implementer's
> discretion, albeit according to specific rules, is somewhat
> untested in the IETF and the Internet applications community.

Perhaps true in most respects, but not with regard to RFC 3066!

RFC 3066 allows specific tag registration, yes, but it also includes a generative syntax (albeit not identified formally as such).

Thus the concern you have about people doing subtag mix-and-match already exists in RFC 3066 (as I'm sure you're aware) and the community has ample experience with that. Here are some perfectly valid RFC 3066 tags that are silly or at least dubious and also not registered:

  tlh-AQ (Klingon as used in the Antarctic)
  it-SG (Italian as used in Singapore)
  zh-CO (Chinese as used in Columbia)
  ang-TL (Old English as used in Timor Leste)
  cs-CS  (Czech as used in Serbia and Montenegro)

So... RFC 3066 has already tested the idea thoroughly and we are just dancing in the margins (he says, squinting VERY hard to ignore obvious questions of order of magnitude). 

Addison

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: "Addison Phillips" <[email-masked]>
Date: Sat, 10 Sep 2005 13:30:34 -0700

The problem I have with going to the STD track has nothing to do with the process of progressing as a standard. The IESG will decide which track to go down and either track suits me fine... provided...

Draft-registry is actually, despite the appearance of being very different, very much a particular profile of RFC 3066. Its grammar could be pasted into RFC 3066 with no ill effect, since all generative or registered tags extant today follow it. The creation of a central registry to mirror the many external standards (and rules for choosing among them) also has no deleterious effect on implementations because the registry accurately mirrors the rules for tag choice in RFC 3066.

There are two problems, though, that must be solved if we are to go down the STD path.

1. Is draft-registry "Obsoletes: 3066"?

Many standards, protocols, and formats reference something called "RFC 3066 or its successor". Thus the question of whether draft-registry is 3066's successor is important to those standards, protocols, and formats. I have no problem with BCP 47 being replaced with STD xyz, but everyone will be curious about what to do if we have both BCP 47 and STD xyz.

2. When does the registry replace the existing IANA registry?

I don't see how the two language tag registration schemes can coexist peacefully. Even if draft-registry is not RFC 3066's successor, there has to be some consideration for interoperability between the two.

Thus, I think that, if we go down the STD track for whatever reason, these two questions need to be clarified quickly and clearly so that implementers and content taggers can made good, informed choices.

I look forward to the IESG's deliberations.

Addison

Addison P. Phillips

> -----Original Message-----
> From: John C Klensin [mailto:[email-masked]]
> Sent: Friday, September 09, 2005 11:15 AM
> To: Addison Phillips; [email-masked]
> Cc: [email-masked]; [email-masked]
> Subject: RE: [Ltru] Last call comments on LTRU registry and initialization
> documents
> 
> 
> 
> --On Wednesday, 07 September, 2005 12:19 -0700 Addison Phillips
> <[email-masked]> wrote:
> 
> >> Comments on draft-ietf-ltru-registry and
> >> draft-ietf-ltru-initial and, secondarily, on
> >> draft-ietf-ltru-matching...
> >
> > I've thought a lot about the excellent analysis and comments
> > in John Klensin's message. My perception is that we have a
> > divergent view of the structure and significance of the LTRU
> > draft(s).
> 
> First, my thanks for the obviously careful reading and thought.
> We may indeed have divergent views, although, after reading your
> notes I believe that, in practical terms, we are pretty close
> together.
> ...... <snip to end>