Subject: RE: Possible new Real-Time Applications and Infrastucture (RAI) Area

From: "Yaakov Stein" <[email-masked]>
Date: Tue, 20 Sep 2005 10:16:03 +0200

As we see from the comments so far, 
the problem with giving a name to this new area 
reveals uncertainty as to the intent.

Signaling-centric comments
----------------------------------------
Harald used the phrase "SIP-type services"
(note the emphasis on the signaling aspects)
implying that anything that can be setup using SIP 
and its extensions (or somehow connected with such services)
is included.

James word-smiths Harald's phrase into "what is in and around SIP" 
but modulates it with a "not absolutely!", 
in order to nudge it in the direction of "Rich Media Apps".

>From these comments the interactivity and delay sensitivity 
is not criticial to the definition. However, as SIP is often used to
set up "real-time" services, they are somehow connected.

Traffic-centric comments
-----------------------------------
Melinda is worried that "real-time" might imply timing rigor
(presumably Allan deviations, MTIE/TDEV masks and other
 mathematical monsters) and so presumably is interested
in handling real-time (i.e. continuous time) services,
but wants to leave the mathematical aspects out.

Marshall wishes us to recognizes the difference between sensitivity to 
delay and to jitter, and emphasizes the former.

Grenville sees the challenge in standardizing protocols
for delay-sensitive applications, adding interactive gaming to the list.

These comments emphasize the difficulty in working over IP
when delay (and perhaps delay variation) is critical,
which typically means interactive applications.

I like to probe the difference between these approaches by asking
not about WGs, but about specific apps.
 
Should streaming one-way video, which is real-time but not
interactive nor delay sensitive (although it may be jitter sensitive)
be under the aegis of this new area ?

How about instant messaging and presence indications
(mentioned in Brian's original message) which are interactive,
but not "real-time" in the DSP sense ?

What about TDM over IP (a subject close to my heart)
which is real-time and timing is critical,
but is set up using LDP and not SIP ?

Y(J)S

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: "Yaakov Stein" <[email-masked]>
Date: Thu, 22 Sep 2005 18:06:12 +0200

> 	Hmmmm.  Someone told me once that real-time means on a 
> time scale such that no measurable time elapses between event 
> occurrences and their recognition. 

There are technically 2 different types of real-time.

Hard real-time means that all processing required is always performed
before the next buffer arrives.  Soft (or statistical) real-time
means that on the average processing finishes before the
next buffer arrives, but additional memory will be needed
to ensure that data is not lost.

So there is no absolute cap on the time-scale for RT delays,
it depends on the rate of the data being processed.

<snip>
> 	Admittedly, in a networking context, real time is being 
> measured over shorter and shorter time intervals. But the 
> Area being proposed is not really about networking, is it?

I hope it is. As I mentioned in my first email on this subject.
separation of the processing from the networking
results in suboptimality of the combination.

Y(J)S

---

From: "Yaakov Stein" <[email-masked]>
Date: Sun, 25 Sep 2005 09:09:32 +0200

> Hi.  I'm just catching up but I think "signaling" is not an 
> essential discriminator of what we're talking about, and thus 
> this name is in fact unreasonable.  Some relationships are 
> established or tailored through signaling that have nothing 
> to do with interactiveness or delay tolerance (or SIP).  

I too have concerns about the wording "signaling",
which can mean many different things.
In a previous email I mentioned LDP, 
commonly called "signaling" in the MPLS world.
I could have picked any of the ITU-T Q series of recommendations
(the series being entitled "signalling protocols").

However, admittedly there is some correlation
between interactive communications and the need
for signaling a ephemeral connection.

> "Delay-sensitive interpersonal communications" seems to be an 
> excellent description of the scope.  

I originally thought so too (although I really don't like the
"interpersonal")
and was quite excited about the proposed new area.

However, after reading clarifications that the true intent is merely to
split up
the unwieldly transport area, I think that OFT (Offloaded from
Transport) best
describes the suggested collection of WGs.

Y(J)S

---

From: [email-masked]
Date: Sun, 25 Sep 2005 07:00:46 -0400

On Saturday, September 24, 2005 17:02 PM, Pete Resnick allegedly wrote:
> On 9/24/05 at 4:41 PM -0400, Scott W Brim wrote:
> 
>> On Sat, Sep 24, 2005 11:15:51AM -0500, Pete Resnick allegedly wrote:
>>> Signalling  Applications and Infrastructure Area
> 
> Actually, I screwed up: It's "Signalled Applications and
> Infrastructure". 
> 
>> Some relationships are established or tailored through signaling
>> that have nothing to do with interactiveness or delay tolerance (or
>> SIP).
> 
> True, but which "Signalled Applications" are you thinking of that
> wouldn't fit into this area? Further, I can think of all sorts of
> interactive and delay intolerant things that do not belong in this
> area. *Signalled* applications (and the infrastructure to support
> them) seems *exactly to describe the things that I want grouped
> together. 

The problem I have is that just about every application is "signaled",
in the sense that there is a control plane exchange to align state and
establish paths and parameters before data is exchanged.  HTTP includes
both, but how about FTP, where the control port and data ports are
distinct, and signaling is path-decoupled?  Also consider Grids, in
which there can be quite a significant setup phase during which
signaling takes place.  

I now understand that "signaled" is just as important as "interactive"
to you, so I won't suggest taking it out of the name, but "signaled" is
not enough of a differentiator all by itself.  I don't mind ambiguous
names but I do get concerned about names that are confusing or
misleading.

swb