Subject: FW: Possible new Real-Time Applications and Infrastucture (RAI) Area

From: [email-masked]
Date: Tue, 20 Sep 2005 12:44:26 +0300

Hi,

I'm in favor of establishing this new area.

During the past few years the SIP/VoIP/RAI-related work has grown enormously, so that it today forms already a significant proportion of the overall work of the IETF. When that work was integrated under transport area, there were only a couple of WGs, i.e. AVT and MMUSIC. Those have spinned off to various directions, and today we have in addition SIP, SIPPING, SIMPLE, XCON and ECRIT, not to even mention all of the somewhat related WGs that are listed in the proposal below. So, clearly, this work, which was never really only transport, has become too large for the current Transport Area. I think the forming of the new area would improve the synergies of these WGs better thant the current structure.

In addition to this IETF centric perspective, another factor that should be considered is that there is also a significant industry interest in this work. This is clearly visible in the amount of dependencies that other organizations (3GPP, 3GPP2, ATIS, ETSI, OMA, ...) have on the deliverables of SIP* and other related WGs. From that point of view I think the new area would help in facilitation of those interactions, and also it would help the industry and other organizations to focus.

In general I have been worried about the output of SIP* WGs lately, since there is just so much going on without much getting finished. Obviously forming a new area does not fix this, but at least it would give a clearer chance for managing the work. For instance with the new proposed structure it might make sense to even have such things as RAI interim meetings (already there was one for SIP/SIPPING/SIMPLE/XCON, why not take ECRIT, ENUM etc. along next time). I think there are many people in the IETF like myself, who mainly participate (during the meetings and in the mailing lists) in roughly those WGs which are in the RAI proposal, and usually do not attend much else.

Regarding the growth of IETG from 13 to 15 members: I see a risk that it will take more time to get documents through the process if there are more people whose approval is needed. I think this needs some attention, but it should not compromise this initiatigve. On the other hand we have always heard how overloaded the ADs are. So, having some more cycles in the IESG should help in that sense, especially now in the affected areas, i.e. Apps, Transport and RAI.  

Regards,
	Markus

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of ext IETF Chair
> Sent: 16 September, 2005 16:14
> To: IETF Announcement list
> Subject: Possible new Real-Time Applications and Infrastucture (RAI)
> Area 
> 
> 
> As mentioned in the recent call for NomCom volunteers, the IESG
> is considering the creation of a new area, as set out below.  We 
> solicit feedback from the community on the scope of this potential 
> new area as well as the impact on the IETF's infrastructure and 
> efficiency of setting up this new area. We need to decide quite
> quickly, to fit the NomCom schedule.
> 
> Please write to [email-masked], or to [email-masked] if you want
> community discussion of your comment. (There's no need
> to write to both!)
> 
>    Brian Carpenter
> 
> -----------------
> 
> Real-Time Applications and Infrastucture (RAI) Area Description
> 
> The Real-Time Applications and Infrastructure Area develops protocols
> and architectures for delay-sensitive interpersonal 
> communications. Work
> in this area serves an emerging industry whose applications 
> and services
> include voice and video over IP, instant messaging and presence. These
> applications and services are "real-time" in the sense that delay
> impedes human participation in the associated systems.
> 
> The RAI Area is seeded with existing working groups from the Transport
> and Applications Area: SIP, SIPPING, XCON, SIMPLE, GEOPRIV, 
> ECRIT, ENUM,
> IPTEL, MEGACO, MMUSIC, IEPREP, SPEECHSC, and SIGTRAN.  A good rule of
> thumb for the incorporation of new work into RAI, as opposed to
> Transport or Applications, is that the work in question has 
> major goals
> supporting instant interpersonal communication or its infrastructure.
> For example, they can range from applications to help users make
> decisions about how best to communicate using presence services, to
> session signaling protocols and emergency call routing solutions, to
> work on the "layer five" issues for Internet telephony.
> 
> Like all areas of the IETF, the RAI Area draws on the work of numerous
> other areas, and as such there can be no neat mathematical boundaries
> delineating RAI's work from the rest of the IETF. The new area will
> allow an existing community within the IETF to solidify its vision and
> to benefit from increased institutional support.
> 
> _______________________________________________
> IETF-Announce mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ietf-announce
> 

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: Harald Tveit Alvestrand <[email-masked]>
Date: Tue, 20 Sep 2005 14:42:13 +0200

There seems to be rough consensus that the area should exist, and even what 
it's supposed to contain - but total confusion about the name!

Suggestion: Let's have a popularity contest for the name - someone collect 
suggestions, and Henrik can make a voting site to gather opinions - and the 
first person to suggest the name that wins out in the end gets a special 
badge reading "IETF Area Namer" at the Vancouver IETF!

In the meantime, let it be referred to as TAWNNY - The Area With No Name 
Yet!

                        Harald, tongue firmly in cheek

---

From: C Wegrzyn <[email-masked]>
Date: Tue, 20 Sep 2005 10:21:27 -0400

How about  Converged Real-time APplications? (CRAP)

Harald Tveit Alvestrand wrote:

> There seems to be rough consensus that the area should exist, and even
> what it's supposed to contain - but total confusion about the name!
>
> Suggestion: Let's have a popularity contest for the name - someone
> collect suggestions, and Henrik can make a voting site to gather
> opinions - and the first person to suggest the name that wins out in
> the end gets a special badge reading "IETF Area Namer" at the
> Vancouver IETF!
>
> In the meantime, let it be referred to as TAWNNY - The Area With No
> Name Yet!
>

---

From: [email-masked]
Date: Tue, 20 Sep 2005 08:15:51 -0700 (PDT)

How about just Bob...

No need for acronym, just name it Bob.

We will require all ADs that are the ADs for Bob to change their name
formally to Bruce.

Bill

---

From: Bill Fenner <[email-masked]>
Date: Tue, 20 Sep 2005 10:00:53 -0700

> We will require all ADs that are the ADs for Bob to change their name

Eric,

That's the best idea I've heard yet.

  Eric

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 22 Sep 2005 13:34:35 +0200

> That's the best idea I've heard yet.

Time was that the multicast name around here was Steve.

Bob does at least meet one constraint (3 letters, which is required for the
IETF agenda to be nicely aligned).

But surely the ADs should then be called Alice?

Seriously though - the discussion about exact scope is valuable. Obviously, if we
go ahead with the area, the scope will be tuned, and the name could be modified
accordingly.

    Anon