Subject: RE: net.stewards [Re: BitTorrent (Was: Re: [Isms] ISMS charter broken- onus should be on WG to fix it)]

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Fri, 16 Sep 2005 06:08:08 -0700

> Behalf Of Brian E Carpenter

> Up to a point, but there are limits to what we can do.
> 
> We can request that the RFC Editor not publish things we 
> think are damaging. The IESG does this a few times a year. 
> Similarly, we can request that IANA not register things we 
> think are damaging, or at least to label them as potentially 
> dangerous.
> 
> We can publish screeds about damaging practices. The IAB does 
> this a few times a year.
> 
> We can try to develop non-damaging solutions for requirements 
> where the easy solutions are damaging, and we can try to 
> repair our own damage (as HTTP 1.1 repairs HTTP 1.0).
> 
> We can try to ensure that the Internet can 'route around 
> damage' - that's one of the main reasons for defending the 
> e2e principle, for example.
> 
> But we can't prevent people from deploying solutions that we 
> didn't develop, and we shouldn't even try to IMHO.

Mao was wrong, the root of power is not coercion, it is persuasion.

Sure the IETF can pursuade IANA not to register a code point. But if
that happens it only makes things worse. There is nothing that can be
done to prevent unregistered use and no real disadvantage to doing so as
nobody will want to accept an official registration polluted by prior
use.

I do not see an argument being made that BitTorrent is worse than the
alternatives that can be used. Instead there is a NIH argument that
BitTorrent is in competition with multicast.

I think it is important to distinguish net.stewardship from special
pleading trying to use the vast political influence of the IETF as
described by Brian to force consumers to adopt the anointed solution
over the deployed.

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 16 Sep 2005 15:36:11 +0200

> nobody will want to accept an official registration polluted by prior

All true. That's why I wrote "or at least to label them as potentially
dangerous."
> 
> I do not see an argument being made that XXXX is worse than the
> XXXX is in competition with YYYY.

I am not making any comment about specific technologies.

> described by Brian to force consumers to adopt the anointed solution

Sigh. That's exactly my point; our stewardship role is really limited
to advocacy and to providing better altermatives. I don't see where you
can find "special pleading", "vast political influence", "force"
or "anointed" in what I wrote. I think we would do well to avoid
polemic language on this list.

    Brian