Subject: A New BoF [16ng BoF: IPv6 over IEEE 802.16(e) Networks]

From: Soohong Daniel Park <[email-masked]>
Date: Tue, 27 Sep 2005 08:08:51 +0900

Folks,

We would like to announce a BoF at the upcoming IETF, leading to identify what limitations and considerations apply to IPv6 adoption over IEEE 802.16(e), and to propose available solutions. A mailing list is set up at [email-masked] and a proposed description is below.

==========================================

IPv6 over IEEE 802.16(e) Networks BoF (16ng)

CHAIRS:

Soohong Daniel Park<[email-masked]>
Gabriel Montenegro<[email-masked]>

DESCRIPTION:

Broadband Wireless Access Network addresses the inadequacies of low bandwidth wireless communication for user requirements such as high quality data/voice service, fast mobility, wide coverage, etc. The IEEE 802.16 Working Group on Broadband Wireless Access Standards develops standards and recommended practices to support the development and deployment of broadband Wireless Metropolitan Area Networks. In addition, IEEE 802.16e supports mobility over IEEE 802.16 as an amendment to the IEEE 802.16 specification. 

Recently, much work is in progress by the WiMAX Forum. In particular, its NWG (Network Working Group) is responsible for the IEEE 802.16(e) network architecture (e.g., IPv4, IPv6, Mobility, Interworking with different networks, AAA, etc). The NWG is thus taking on work at layers above those defined by the IEEE 802 standards (typically limited to the physical and link layers only). Similarly, WiBro (Wireless Broadband) is a Korean effort based on the IEEE 802.16e specification which focuses on the 2.3 GHz spectrum band.

IEEE 802.16(e) is different from existing wireless access technologies such as  IEEE 802.11 or 3G. Accordingly, the use of IP over an IEEE 802.16(e) link is currently undefined, and will benefit from IETF input and specification. For example, even though Neighbor Discovery has been specified to work over point-to-point type links (e.g., as available in 3G), it applies most naturally to link technologies capable of native multicasing. Thus, it is not yet clear how it would work over IEEE 802.16(e) networks. Even though these supports a PMP (Point-to-Multipoint) mode, there is no provision for multicasting IP packets, hindering the basic standard IPv6 operation. An IEEE 802.16(e) connection for IP packet transfer is a point-to-point unidirectional mapping between medium access control layers at the ubscriber station and the base station. This eventually requires convergence protocols to emulate the desired service on network entities such as base stations, which may limit IPv6 features. As for fast mobility, the characteristics of IEEE 802.16e link-layer operation may require an amendment to the Fast Handover Mobile IPv6 scheme (RFC 4068), something which may be pursued in the MIPSHOP WG.

The principal objective of the 16ng BoF is to identify what limitations and considerations apply to IPv6 adoption over IEEE 802.16(e), and to propose available solutions. The working group may issue recommendations to IEEE 802.16(e) suggesting protocol modifications for better IP support. 

In 2006, WiBro deployment will begin, and the WiMAX Forum is slated to specify IPv6 operation over IEEE 802.16(e) in 2006. Accordingly, the working group will work and coordinate with the WiMAX Forum and with the WiBro efforts.

MAILING LIST: 

General Discussion: [email-masked]
To Subscribe: http://eeca16.sogang.ac.kr/mailman/listinfo/16ng 
Archive: http://eeca16.sogang.ac.kr/pipermail/16ng 

REFERENCES:

http://www.ietf.org/internet-drafts/draft-jang-mipshop-fh80216e-00.txt
http://www.watersprings.org/pub/id/draft-jin-ipv6-over-ieee802.16-00.txt
http://www.ietf.org/internet-drafts/draft-jee-mip4-fh80216e-00.txt 
IPv6 over IEEE 802.16(e) Networks Problem Statements (coming soon) 

Regards,

Gabriel & Daniel 
16ng BoF co-chairs

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: Erik Nordmark <[email-masked]>
Date: Mon, 26 Sep 2005 17:41:18 -0700

Can IETF participants freely access the 802.16 and WIMAX documents, so 
that we can understand what this thing is before we have a BoF?

(That's been a sticking point for previous BoFs relating to other 
technologies.)

    Erik