Subject: Re: Cost vs. Benefit of Real-Time Applications and Infrastucture Area

From: [email-masked] (Scott Bradner)
Date: Tue, 20 Sep 2005 23:19:11 -0400 (EDT)

One David opines

- we need two more people out of the community who are going to spend
  a lot of their time on the administrative side of our organization
  instead of producing real work for the IETF.

>> ADs do not have to stop doing useful work - many ADs (and even a
>> chair
>> or two) have done useful technical work while doing teh AD role

- IETF documents will receive more scrutiny in the IESG. While this
  could be considered a good thing, there has been a significant
  amount of backlash in the community that enough is enough. I for one
  believe that we currently already provide enough review, and possibly
  already too much.

>> I assume you mean 2 more people looking at things
>> I'm not sure this will make a significant difference to the flow
>> through the IESG which I always found to be more dependent on
>> the pickyest AD not the number of ADs

- Management research has shown that optimal group sizes are in
  general quite a bit smaller than the current IESG. In fact, I see
  already significant strains within the IESG due to our group size.

>> imo - the size of the IESG has been more than some would consider
>> ideal for quite a while, I do not think that adding two more ADs
>> will do additional harm to its functionality - I think the more
>> important issue is how the IESG operates & reviews things - maybe
>> things have changed since I was on the IESG but in those days
>> there were only a few ADs that were consistently active on the
>> mailing list when we were discussing  "big" issues - a few more 
>> active folk would actually have helped in those days

An IESG that doesn't operate efficiently is not in the benefit of the IETF.

>> agreed, but imo, that problem is already there and is 
>> quite independent of the number of ADs

I believe it is very dangerous to add an area before addressing the
issues associated with a larger IESG

>> fwiw, I disagree with this because I think that the proposal
>> will add people who can dedicate more attention to this set
>> of WGs and I think that is a good thing - see above, I think
>> the optimal size may have been exceeded a while back but
>> I think that adding two additional folk would produce
>> more positives than negatives at this point

Another approach could be to do serious surgery on how the IESG
operates to make it a more scalable group.

>> I think this should be done (and have proposed some ideas 
>> in the past) but I expect it to take quite a while and I'd like
>> to get focused attention on this (conceptionial) area in the 
>> meantime

Another David opines
If we applied much more strict quality, relevance and timeliness
measures to the existing IETF load, we would probably get rid of 
1/3 to 1/2 of our current activities.  And possibly more.

>> that is an option, but I expect that the level of IETF work would 
>> not change much, the work would just be distributed among 
>> fewer WGs  (but I do not doubt that some number of existing WGs
>> should be closed for one reason or another)

Scott

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: "Yaakov Stein" <[email-masked]>
Date: Wed, 21 Sep 2005 09:36:58 +0200

David Kessens stated (amongst other things):
> As for the benefits, I see that we would give more well 
> deserved attention to an important area of work within the 
> IETF. 

In this very area the IETF was once able
in a relatively short period of time to overtake the ITU,
with SIP becoming preferable to H.323 .

But a small (and now very wealthy) group has developed,
in a even shorter period of time, a proprietary system 
that has overtaken IETF mechanisms (both in capabilities
and market acceptance). 

If this is not deemed sufficient justification for the IETF to 
concentrate on this area, then we can sit back and let 
nonstandardized technologies take over.

Y(J)S

---

From: "Yaakov Stein" <[email-masked]>
Date: Thu, 22 Sep 2005 12:04:40 +0200

> Note that the next proposal for an additional area is just around the
> corner: the Internet area has a very heavy load of working 
> groups as well and the next thing that could easily be 
> imagined is a Mobility Area which also sounds very reasonable.

Yes, implicit in my mentioning the number of WGs in the
Internet area was that they too have a problem.

I am not sure what the optimal ratios are,
but I can make a simple comparisons
In addition to the IETF I also attend ITU-T meetings,
where there is an additional layer of management
   Study Group (SG) chair             =  AD
   Working Party (WP) chair
   rapporteur (= question chair)      =  WG chair.

There are 13 SG chairs (just like our IESG),
with between 5 and 24 questions per SG.
These numbers are similar to the IETF situation,
HOWEVER, each SG chair has between 2 and 8 vice-chairs,
up to 4 WPs (each of which has at least one chair and one vice-chair) 
and two secretaries (who are full-time employees).

Does that weighty managerial structure make things
flow more smoothly? To an extent, but at a price.
For example, documents produced by a question
must first be presented at the WP plenary and approved,
and then the same document (but with a new number)
must be presented once again at the full SG plenary.

However, the most obvious difference between the two
systems is that it is a rare event to see a SG chair at 
a question session. The SG chair function is purely 
managerial, since there are so many levels between the
SG chair and the document editors. 

I doubt that many of the present IESG would want to 
swap jobs with an ITU-T SG chair. 

Y(J)S