Subject: MPLS,IETF, etc..

From: "Abbie Barbir" <[email-masked]>
Date: Fri, 31 Aug 2001 13:09:48 -0400

fyi

this is interesting to read

http://www.lightreading.com/document.asp?doc_id=7805

well what do u think

abbie

---

From: "Natale, Robert C (Bob)" <[email-masked]>
Date: Fri, 31 Aug 2001 16:49:39 -0400

Hi Abbie,

>http://www.lightreading.com/document.asp?doc_id=7805 

The set of articles and threads behind the article you
cite above reveals some of the worst possibilities in
"evangelism" and in "journalism", IMHO.

First, let me say that simplicity is the essence of
good engineering and achieving it (usually the result
of synthesis as much as analysis...and you find very
few capable synthesists around these days) can be
extremely difficult.  In solving the essential problem
it was tasked for (reducing routing control/signaling
overhead via a more efficient marriage of (routed) L3
messages and (switched) L2 transports), MPLS (thanks
to its tag switching ancestors) is, IMHO, an elegantly
simple  solution. That a solution can exhibit simplicity
does not mean that people unskilled in synthesis will
understand the meaning (purposes, limits, etc.) at all.

However, the tendency to over-evangelize such things
can lead to taking a core solution component and extending
it ever outward to cover a larger and larger problem space.
This is most obvious in pure software, where one can begin
almost anywhere (in terms of requirements) and end up (in
terms of development) with a "integrated <x> environment"
for doing just about anything and/or everything.  I believe
that something like that is what Mike O'Dell was critiquing
and (if so) I'd certainly have to agree with him on that.
(I am particularly bothered by references to MPLS as a
"transport technology"...as in, "MPLS or ATM" and (believe
it or not) "MPLS or Ethernet"!)

On the other hand, however, the "MPLS poll" that appeared
in LightReading is a silly sham...typically of many
"journalistic" efforts these days.  The questions it asked
were hardly representative of a meaningful way to analyze
the value and the weaknesses of the current MPLS landscape
and the options in the multiple-choice answers that were
offered hardly allowed for a meaningful assessment by a
knowledgeable respondent.  Gimme a break.

To really jump the tracks here (since I'm pretty much just
rambling on here anyway):  It could be argued that both the
"dot com" mania and melt-down were attributable -- in large
part -- to the same mix of evangelistic and journalistic
misunderstanding of simplicity.

Thanks,

BobN