Subject: TCP/IP check sum

From: jacob mathews <[email-masked]>
Date: Tue, 28 Aug 2001 09:05:03 +0100 (BST)

Hi,
On a etherent frame CRC is used for error detection.
For TCP/IP frames frame check is done by using 16bit
1's complemet addtion.
Why is TCP/IP frame check required when the same is
verified by the ethernet MAC?
What is then the motivation of providing TCP/IP
checksum overload by some products?

Waiting for responses.
thanking you,
jacob

____________________________________________________________
Do You Yahoo!?
Send a newsletter, share photos & files, conduct polls, organize chat events. Visit http://in/ groups.yahoo.com

---

From: "Franck Martin" <[email-masked]>
Date: Sat, 5 Jan 1980 06:11:42 +1200

I know some products and implementations that do not do ethernet error
correction...

Cheers.
[email-masked]

----- Original Message -----
From: jacob mathews <[email-masked]>
To: <[email-masked]>; <UNEXPECTED_DATA_AFTER_ADDRESS@.SYNTAX-ERROR>
Sent: Tuesday, 28 August 2001 20:05
Subject: TCP/IP check sum

> Send a newsletter, share photos & files, conduct polls, organize chat
events. Visit http://in/ groups.yahoo.com

---

From: Jason R Thorpe <[email-masked]>
Date: Tue, 28 Aug 2001 07:23:11 -0700

> I know some products and implementations that do not do ethernet error

...never mind that... there are some systems that pass packets w/ good
Ethernet CRCs and bad TCP/IP checksums (i.e. the data was corrupted by
e.g. a broken DMA controller between the host and the MAC).

-- 
        -- Jason R. Thorpe <[email-masked]>

---

From: Dave Crocker <[email-masked]>
Date: Tue, 28 Aug 2001 08:28:09 -0700

>verified by the ethernet MAC?

TCP/IP is designed for INTER-networking.  That means that it works through 
SEQUENCES of components.  Some of the components well might provide strong 
data integrity mechanisms.  Some might not.  Even more important is that 
the INTERFACE BETWEEN components might not ensure data integrity.

The TCP checksum is simple (not very powerful) because it is intended only 
to catch integrity problems not caught by other mechanisms.

d/

----------
Dave Crocker  <mailto:[email-masked]>
Brandenburg InternetWorking  <http://www.brandenburg.com>
tel +1.408.246.8253;  fax +1.408.273.6464