Subject: Re: TCP/IP check sum

From: "Chandra Shekar Reddy Challagonda" <[email-masked]>
Date: Tue, 28 Aug 2001 13:56:00 +0500

Hi Jacob
CRC check is done at the Ethernet MAC layer(or Data Link Layer 
conceptually).  This error detection process is to detect the errors at 
the MAC layer packets, which is the errors caused by the physical layer 
or MAC layer.  
In some products single big TCP/IP packet(Jumbo Packet) can broken into 
the small packets at the MAC layer depending on the maximum size of the 
packet that link supports(Some thing like MRU).  So the error in the 
datapackets which are broken and sent by the MAC layer, is detected by 
the CRC in the MAC layer.  When sender sends the broken data packets 
each separately, at the reciever side also, these all packets are 
joined into single packet again before passing it to TCP/IP layer.  To 
check the errors in joined TCP/IP packet, frame check is used at that 
layer.  This is to detect the errors occuring in the TCP/IP packets due 
to breaking up and joining up.
So both has relevant significance at each layer.

Chandra

----- Original Message -----
From: jacob mathews <[email-masked]>
Date: Tuesday, August 28, 2001 1:35 pm
Subject: TCP/IP check sum

> Hi,
> On a etherent frame CRC is used for error detection.
> For TCP/IP frames frame check is done by using 16bit
> 1's complemet addtion.
> Why is TCP/IP frame check required when the same is
> verified by the ethernet MAC?
> What is then the motivation of providing TCP/IP
> checksum overload by some products?
> 
> Waiting for responses.
> thanking you,
> jacob
> 
> ____________________________________________________________
> Do You Yahoo!?
> Send a newsletter, share photos & files, conduct polls, organize 
> chat events. Visit http://in/ groups.yahoo.com
> 
>

---

From: Bob Braden <[email-masked]>
Date: Tue, 28 Aug 2001 16:14:55 GMT

*> From [email-masked]  Tue Aug 28 01:24:10 2001
  *> Date: Tue, 28 Aug 2001 09:05:03 +0100 (BST)
  *> From: =?iso-8859-1?q?jacob=20mathews?= <[email-masked]>
  *> Subject: TCP/IP check sum
  *> To: [email-masked], UNEXPECTED_DATA_AFTER_ADDRESS@.SYNTAX-ERROR
  *> MIME-Version: 1.0
  *> Content-Transfer-Encoding: 8bit
  *> Content-Transfer-Encoding: 8bit
  *> X-Loop: [email-masked]
  *> Content-Transfer-Encoding: 8bit
  *> 
  *> Hi,
  *> On a etherent frame CRC is used for error detection.
  *> For TCP/IP frames frame check is done by using 16bit
  *> 1's complemet addtion.
  *> Why is TCP/IP frame check required when the same is
  *> verified by the ethernet MAC?
  *> What is then the motivation of providing TCP/IP
  *> checksum overload by some products?
  *> 
  *> Waiting for responses.
  *> thanking you,
  *> jacob

Please see, e.g., the explanation in Section 11.3 of "TCP/IP
Illustrated, Vol. 1" by the late W. Richard Stevens (Addison-Wesley
1994).  And may we suggest that you read the whole book?

Bob Braden

  *> 
  *> ____________________________________________________________
  *> Do You Yahoo!?
  *> Send a newsletter, share photos & files, conduct polls, organize chat events. Visit http://in/ groups.yahoo.com
  *>